summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-20 13:56:47 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-20 13:56:47 +0000
commite9062ae8e195c5622415f95af81b6dd62a918742 (patch)
tree74b688ffa29069fb895f704c9ac900a172eec3d2 /net-p2p
parentfix my name in ChangeLog (diff)
downloadgentoo-2-e9062ae8e195c5622415f95af81b6dd62a918742.tar.gz
gentoo-2-e9062ae8e195c5622415f95af81b6dd62a918742.tar.bz2
gentoo-2-e9062ae8e195c5622415f95af81b6dd62a918742.zip
Fixing parallel build and --as-needed issues wrt bug 313165. Thanks Diego for reporting.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gnunet/ChangeLog8
-rw-r--r--net-p2p/gnunet/files/0.8.1-asneeded.patch47
-rw-r--r--net-p2p/gnunet/files/0.8.1-parallel-build.patch242
-rw-r--r--net-p2p/gnunet/gnunet-0.8.1.ebuild27
4 files changed, 308 insertions, 16 deletions
diff --git a/net-p2p/gnunet/ChangeLog b/net-p2p/gnunet/ChangeLog
index a46935f21c31..954f9a38b6c7 100644
--- a/net-p2p/gnunet/ChangeLog
+++ b/net-p2p/gnunet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/gnunet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.67 2010/01/28 11:48:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.68 2010/06/20 13:56:46 xarthisius Exp $
+
+ 20 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/0.8.1-asneeded.patch, gnunet-0.8.1.ebuild,
+ +files/0.8.1-parallel-build.patch:
+ Fixing parallel build and --as-needed issues wrt bug 313165. Thanks Diego
+ for reporting.
*gnunet-0.8.1 (28 Jan 2010)
diff --git a/net-p2p/gnunet/files/0.8.1-asneeded.patch b/net-p2p/gnunet/files/0.8.1-asneeded.patch
new file mode 100644
index 000000000000..ad7f98b12cff
--- /dev/null
+++ b/net-p2p/gnunet/files/0.8.1-asneeded.patch
@@ -0,0 +1,47 @@
+Fixing as-needed issues
+
+http://bugs.gentoo.org/313165
+
+--- configure.ac
++++ configure.ac
+@@ -39,8 +39,8 @@
+ AC_PROG_MAKE_SET
+ LT_CONFIG_LTDL_DIR([libltdl])
+ LT_INIT([disable-static dlopen win32-dll])
+-AM_PATH_LIBLTDL([lt_dlopenext lt_dlsym], ,AC_MSG_ERROR([GNUnet needs libltdl]))
+ LT_LIB_DLLOAD
++AM_PATH_LIBLTDL([lt_dlopenext lt_dlsym], ,AC_MSG_ERROR([GNUnet needs libltdl]))
+ AC_SUBST(MKDIR_P)
+
+ # large file support
+--- m4/libltdl-external.m4
++++ m4/libltdl-external.m4
+@@ -19,15 +19,17 @@
+ libltdl_prefix="$withval", libltdl_prefix="")
+ ltdl_save_CPPFLAGS="$CPPFLAGS"
+ ltdl_save_LDFLAGS="$LDFLAGS"
++ ltdl_save_LIBS="$LIBS"
+ if test x$libltdl_prefix != x ; then
+- CPPFLAGS="-I$libltdl_prefix/include $CPPFLAGS"
+- LDFLAGS="-L$libltdl_prefix/lib -lltdl $LDFLAGS"
++ CPPFLAGS="$CPPFLAGS -I$libltdl_prefix/include"
++ LDFLAGS="$LDFLAGS -L$libltdl_prefix/lib"
++ LIBS="-lltdl $LIBS"
+ else
+ if test x"$LIBLTDL" = x ; then
+ LIBLTDL="-lltdl"
+ fi
+ CPPFLAGS="$LTDLINCL $CPPFLAGS"
+- LDFLAGS="$LIBLTDL $LDFLAGS"
++ LIBS="$LIBLTDL $LIBS"
+ fi
+
+ symbols_to_check=ifelse([$1], ,"ltdl_dlopen","$1")
+@@ -59,6 +61,7 @@
+ fi
+ CPPFLAGS="$ltdl_save_CPPFLAGS"
+ LDFLAGS="$ltdl_save_LDFLAGS"
++ LIBS="$ltdl_save_LIBS"
+
+ AC_MSG_CHECKING(for libltdl with symbols $symbols_to_check)
+ if test $ltdl_found = yes; then
diff --git a/net-p2p/gnunet/files/0.8.1-parallel-build.patch b/net-p2p/gnunet/files/0.8.1-parallel-build.patch
new file mode 100644
index 000000000000..697451c84c05
--- /dev/null
+++ b/net-p2p/gnunet/files/0.8.1-parallel-build.patch
@@ -0,0 +1,242 @@
+Fixing parallel build issues
+
+--- src/server/Makefile.am
++++ src/server/Makefile.am
+@@ -30,26 +30,25 @@
+ gnunetd_SOURCES = \
+ gnunetd.c
+ gnunetd_LDADD = \
+- $(top_builddir)/src/server/libgnunetcore.la \
++ libgnunetcore.la \
+ $(GN_LIBINTL)
+
+
+ gnunet_update_SOURCES = \
+ gnunet-update.c
+ gnunet_update_LDADD = \
+- $(top_builddir)/src/server/libgnunetcore.la \
++ libgnunetcore.la \
+ $(GN_LIBINTL)
+
+ gnunet_peer_info_SOURCES = \
+ gnunet-peer-info.c
+ gnunet_peer_info_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+- $(top_builddir)/src/server/libgnunetcore.la \
++ libgnunetcore.la \
+ $(GN_LIBINTL)
+
+ gnunet_transport_check_SOURCES = \
+ gnunet-transport-check.c
+ gnunet_transport_check_LDADD = \
+- $(top_builddir)/src/server/libgnunetcore.la \
++ libgnunetcore.la \
+ $(GN_LIBINTL)
+-
+--- src/applications/stats/Makefile.am
++++ src/applications/stats/Makefile.am
+@@ -21,7 +21,7 @@
+ gnunet_stats_SOURCES = \
+ gnunet-stats.c
+ gnunet_stats_LDADD = \
+- $(top_builddir)/src/applications/stats/libgnunetstatsapi.la \
++ libgnunetstatsapi.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+
+--- src/applications/rpc/Makefile.am
++++ src/applications/rpc/Makefile.am
+@@ -16,7 +16,7 @@
+ libgnunetmodule_rpc_la_LDFLAGS = \
+ $(GN_PLUGIN_LDFLAGS)
+ libgnunetmodule_rpc_la_LIBADD = \
+- $(top_builddir)/src/applications/rpc/libgnunetrpcutil.la \
++ libgnunetrpcutil.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+
+--- src/applications/tracekit/Makefile.am
++++ src/applications/tracekit/Makefile.am
+@@ -18,7 +18,7 @@
+ gnunet-tracekit.c \
+ tracekit.h
+ gnunet_tracekit_LDADD = \
+- $(top_builddir)/src/applications/tracekit/libgnunettracekitapi.la \
++ libgnunettracekitapi.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+
+@@ -53,5 +53,5 @@
+ tracekittest_LDADD = \
+ $(top_builddir)/src/applications/testing/libgnunettestingapi.la \
+ $(top_builddir)/src/applications/stats/libgnunetstatsapi.la \
+- $(top_builddir)/src/applications/tracekit/libgnunettracekitapi.la \
++ libgnunettracekitapi.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+--- src/applications/testing/Makefile.am
++++ src/applications/testing/Makefile.am
+@@ -40,20 +40,20 @@
+ testingtest.c
+ testingtest_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+- $(top_builddir)/src/applications/testing/libgnunettestingapi.la
++ libgnunettestingapi.la
+
+ remotetest_SOURCES = \
+ remotetest.c
+ remotetest_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+- $(top_builddir)/src/applications/testing/libgnunetremoteapi.la
++ libgnunetremoteapi.la
+
+
+ testingtest_loop_SOURCES = \
+ testingtest_loop.c
+ testingtest_loop_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+- $(top_builddir)/src/applications/testing/libgnunettestingapi.la
++ libgnunettestingapi.la
+
+
+ pkgdata_DATA = \
+--- src/applications/fs/fsui/Makefile.am.orig 2010-04-06 15:02:21.375530243 +0000
++++ src/applications/fs/fsui/Makefile.am 2010-04-06 15:03:26.424279707 +0000
+@@ -37,7 +37,7 @@
+ fsui_loader_SOURCES = \
+ fsui-loader.c
+ fsui_loader_LDADD = \
+- $(top_builddir)/src/applications/fs/fsui/libgnunetfsui.la \
++ libgnunetfsui.la \
+ $(top_builddir)/src/applications/fs/ecrs/libgnunetecrs.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+@@ -59,14 +59,14 @@
+ basic_fsui_test.c
+ basic_fsui_test_LDADD = \
+ $(top_builddir)/src/applications/fs/ecrs/libgnunetecrs.la \
+- $(top_builddir)/src/applications/fs/fsui/libgnunetfsui.la \
++ libgnunetfsui.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ fsui_start_stop_test_SOURCES = \
+ fsui_start_stop_test.c
+ fsui_start_stop_test_LDADD = \
+ $(top_builddir)/src/applications/fs/ecrs/libgnunetecrs.la \
+- $(top_builddir)/src/applications/fs/fsui/libgnunetfsui.la \
++ libgnunetfsui.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ search_pause_resume_persistence_test_SOURCES = \
+@@ -80,42 +80,42 @@
+ search_ranking_test.c
+ search_ranking_test_LDADD = \
+ $(top_builddir)/src/applications/fs/ecrs/libgnunetecrs.la \
+- $(top_builddir)/src/applications/fs/fsui/libgnunetfsui.la \
++ libgnunetfsui.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ download_persistence_test_SOURCES = \
+ download_persistence_test.c
+ download_persistence_test_LDADD = \
+ $(top_builddir)/src/applications/fs/ecrs/libgnunetecrs.la \
+- $(top_builddir)/src/applications/fs/fsui/libgnunetfsui.la \
++ libgnunetfsui.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ recursive_download_test_SOURCES = \
+ recursive_download_test.c
+ recursive_download_test_LDADD = \
+ $(top_builddir)/src/applications/fs/ecrs/libgnunetecrs.la \
+- $(top_builddir)/src/applications/fs/fsui/libgnunetfsui.la \
++ libgnunetfsui.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ upload_unindex_persistence_test_SOURCES = \
+ upload_unindex_persistence_test.c
+ upload_unindex_persistence_test_LDADD = \
+ $(top_builddir)/src/applications/fs/ecrs/libgnunetecrs.la \
+- $(top_builddir)/src/applications/fs/fsui/libgnunetfsui.la \
++ libgnunetfsui.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ search_linked_download_persistence_test_SOURCES = \
+ search_linked_download_persistence_test.c
+ search_linked_download_persistence_test_LDADD = \
+ $(top_builddir)/src/applications/fs/ecrs/libgnunetecrs.la \
+- $(top_builddir)/src/applications/fs/fsui/libgnunetfsui.la \
++ libgnunetfsui.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ search_persistence_test_SOURCES = \
+ search_persistence_test.c
+ search_persistence_test_LDADD = \
+ $(top_builddir)/src/applications/fs/ecrs/libgnunetecrs.la \
+- $(top_builddir)/src/applications/fs/fsui/libgnunetfsui.la \
++ libgnunetfsui.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+
+@@ -123,6 +123,6 @@
+ recursive_download_persistence_test.c
+ recursive_download_persistence_test_LDADD = \
+ $(top_builddir)/src/applications/fs/ecrs/libgnunetecrs.la \
+- $(top_builddir)/src/applications/fs/fsui/libgnunetfsui.la \
++ libgnunetfsui.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+--- src/applications/dv_dht/tools/Makefile.am.orig 2010-04-06 15:04:16.738530159 +0000
++++ src/applications/dv_dht/tools/Makefile.am 2010-04-06 15:04:40.525280090 +0000
+@@ -24,7 +24,7 @@
+ gnunet_dvdht_query_SOURCES = \
+ dht-query.c
+ gnunet_dvdht_query_LDADD = \
+- $(top_builddir)/src/applications/dv_dht/tools/libgnunetdvdhtapi.la \
++ libgnunetdvdhtapi.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+
+@@ -34,7 +34,7 @@
+ $(top_builddir)/src/applications/stats/libgnunetstatsapi.la \
+ $(top_builddir)/src/applications/testing/libgnunettestingapi.la \
+ $(top_builddir)/src/applications/testing/libgnunetremoteapi.la \
+- $(top_builddir)/src/applications/dv_dht/tools/libgnunetdvdhtapi.la \
++ libgnunetdvdhtapi.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ check_PROGRAMS = \
+@@ -49,7 +49,7 @@
+ dv_dht_loopback_test_LDADD = \
+ $(top_builddir)/src/applications/stats/libgnunetstatsapi.la \
+ $(top_builddir)/src/applications/testing/libgnunettestingapi.la \
+- $(top_builddir)/src/applications/dv_dht/tools/libgnunetdvdhtapi.la \
++ libgnunetdvdhtapi.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ dv_dht_twopeer_test_SOURCES = \
+@@ -57,7 +57,7 @@
+ dv_dht_twopeer_test_LDADD = \
+ $(top_builddir)/src/applications/stats/libgnunetstatsapi.la \
+ $(top_builddir)/src/applications/testing/libgnunettestingapi.la \
+- $(top_builddir)/src/applications/dv_dht/tools/libgnunetdvdhtapi.la \
++ libgnunetdvdhtapi.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ dv_dht_multipeer_test_SOURCES = \
+@@ -65,7 +65,7 @@
+ dv_dht_multipeer_test_LDADD = \
+ $(top_builddir)/src/applications/stats/libgnunetstatsapi.la \
+ $(top_builddir)/src/applications/testing/libgnunettestingapi.la \
+- $(top_builddir)/src/applications/dv_dht/tools/libgnunetdvdhtapi.la \
++ libgnunetdvdhtapi.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ dv_dht_multi_topology_test_SOURCES = \
+@@ -74,7 +74,7 @@
+ $(top_builddir)/src/applications/stats/libgnunetstatsapi.la \
+ $(top_builddir)/src/applications/testing/libgnunettestingapi.la \
+ $(top_builddir)/src/applications/testing/libgnunetremoteapi.la \
+- $(top_builddir)/src/applications/dv_dht/tools/libgnunetdvdhtapi.la \
++ libgnunetdvdhtapi.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+ EXTRA_DIST = \
diff --git a/net-p2p/gnunet/gnunet-0.8.1.ebuild b/net-p2p/gnunet/gnunet-0.8.1.ebuild
index 57b9616911d2..8c196f120e85 100644
--- a/net-p2p/gnunet/gnunet-0.8.1.ebuild
+++ b/net-p2p/gnunet/gnunet-0.8.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.8.1.ebuild,v 1.1 2010/01/28 11:48:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.8.1.ebuild,v 1.2 2010/06/20 13:56:46 xarthisius Exp $
EAPI=2
-inherit eutils autotools
+inherit autotools eutils
S="${WORKDIR}/GNUnet-${PV}"
DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
@@ -13,7 +13,7 @@ SRC_URI="http://gnunet.org/download/GNUnet-${PV}.tar.gz"
#tests don't work
RESTRICT="test"
-IUSE="ipv6 mysql +sqlite ncurses nls gtk"
+IUSE="gtk mysql nls +sqlite"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
LICENSE="GPL-2"
SLOT="0"
@@ -27,7 +27,7 @@ DEPEND=">=dev-libs/libgcrypt-1.2.0
gtk? ( >=x11-libs/gtk+-2.6.10 )
sys-apps/sed
>=dev-scheme/guile-1.8.0
- ncurses? ( sys-libs/ncurses )
+ sys-libs/ncurses
mysql? ( >=virtual/mysql-4.0 )
sqlite? ( >=dev-db/sqlite-3.0.8 )
nls? ( sys-devel/gettext )"
@@ -59,31 +59,29 @@ src_prepare() {
sed -i "s:AC_DEFINE_UNQUOTED..HAVE_GTK.*:true:" configure.ac
fi
- AT_M4DIR="${S}/m4" eautoreconf
+ epatch "${FILESDIR}"/${PV}-asneeded.patch
+ epatch "${FILESDIR}"/${PV}-parallel-build.patch
+ eautoreconf
}
-src_compile() {
+src_configure() {
local myconf
use mysql || myconf="${myconf} --without-mysql"
econf \
$(use_with sqlite) \
- $(use_enable ipv6) \
$(use_enable nls) \
- $(use_enable ncurses) \
${myconf} || die "econf failed"
-
- emake -j1 || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" -j1 install || die "make install failed"
- dodoc AUTHORS ChangeLog INSTALL NEWS PLATFORMS README README.fr UPDATING
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS PLATFORMS README UPDATING || die
insinto /etc
- newins contrib/gnunet.root gnunet.conf
+ newins contrib/gnunet.conf gnunet.conf
docinto contrib
- dodoc contrib/*
+ dodoc contrib/* || die
newinitd "${FILESDIR}"/${PN}.initd gnunet
dodir /var/lib/gnunet
chown gnunetd:gnunetd "${D}"/var/lib/gnunet
@@ -93,7 +91,6 @@ pkg_postinst() {
# make sure permissions are ok
chown -R gnunetd:gnunetd "${ROOT}"/var/lib/gnunet
- use ipv6 && ewarn "ipv6 support is -very- experimental and prone to bugs"
einfo
einfo "To configure"
einfo " 1) Add user(s) to the gnunetd group"