summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-03-04 10:21:46 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-03-04 10:21:46 +0000
commitdc14ce8e9c9fff51782ce98bc1ac1331da67939a (patch)
tree17d568531bc6aae3a37441c7f62463d1223f8f5e /net-p2p
parentAdd ECL-2.0 to GPL-COMPATIBLE and OSI-APPROVED license groups (diff)
downloadgentoo-2-dc14ce8e9c9fff51782ce98bc1ac1331da67939a.tar.gz
gentoo-2-dc14ce8e9c9fff51782ce98bc1ac1331da67939a.tar.bz2
gentoo-2-dc14ce8e9c9fff51782ce98bc1ac1331da67939a.zip
Version bump wrt bug #446592.
(Portage version: 2.1.11.54/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/kmldonkey/ChangeLog9
-rw-r--r--net-p2p/kmldonkey/kmldonkey-2.0.7.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/net-p2p/kmldonkey/ChangeLog b/net-p2p/kmldonkey/ChangeLog
index a0a432267fd8..a84ff628b714 100644
--- a/net-p2p/kmldonkey/ChangeLog
+++ b/net-p2p/kmldonkey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/kmldonkey
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/kmldonkey/ChangeLog,v 1.45 2011/10/28 20:58:13 abcd Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/kmldonkey/ChangeLog,v 1.46 2013/03/04 10:21:46 kensington Exp $
+
+*kmldonkey-2.0.7 (04 Mar 2013)
+
+ 04 Mar 2013; Michael Palimaka <kensington@gentoo.org> +kmldonkey-2.0.7.ebuild:
+ Version bump wrt bug #446592.
28 Oct 2011; Jonathan Callen <abcd@gentoo.org> kmldonkey-2.0.2-r2.ebuild:
Bump to EAPI=4
diff --git a/net-p2p/kmldonkey/kmldonkey-2.0.7.ebuild b/net-p2p/kmldonkey/kmldonkey-2.0.7.ebuild
new file mode 100644
index 000000000000..105460029bed
--- /dev/null
+++ b/net-p2p/kmldonkey/kmldonkey-2.0.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/kmldonkey/kmldonkey-2.0.7.ebuild,v 1.1 2013/03/04 10:21:46 kensington Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Provides integration for the MLDonkey P2P software and KDE 4."
+HOMEPAGE="http://www.kde.org/"
+SRC_URI="https://api.opensuse.org/public/source/home:eduardhc/${PN}-kde4/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug plasma"
+
+DEPEND="plasma? ( $(add_kdebase_dep plasma-workspace) )"
+RDEPEND="${DEPEND}
+ net-p2p/mldonkey
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-base_src_configure
+}