summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-04-21 19:01:34 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-04-21 19:01:34 +0000
commitdadf879ee5f8ee3591bfb79ed0cfbc7ad3d966f6 (patch)
tree565e250b8b860ce96b7417e4e4cd532b749e526f /net-p2p
parentia64 + x86 stable (diff)
downloadgentoo-2-dadf879ee5f8ee3591bfb79ed0cfbc7ad3d966f6.tar.gz
gentoo-2-dadf879ee5f8ee3591bfb79ed0cfbc7ad3d966f6.tar.bz2
gentoo-2-dadf879ee5f8ee3591bfb79ed0cfbc7ad3d966f6.zip
Use desktop files instead of a hack, bug 175472
(Portage version: 2.1.2.4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittornado/ChangeLog6
-rw-r--r--net-p2p/bittornado/bittornado-0.3.15.ebuild26
-rw-r--r--net-p2p/bittornado/bittornado-0.3.18.ebuild28
-rw-r--r--net-p2p/bittornado/files/bittornado.desktop11
4 files changed, 27 insertions, 44 deletions
diff --git a/net-p2p/bittornado/ChangeLog b/net-p2p/bittornado/ChangeLog
index 15ae12ba0a1b..5328ea9b30c9 100644
--- a/net-p2p/bittornado/ChangeLog
+++ b/net-p2p/bittornado/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bittornado
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.62 2007/03/23 21:07:24 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.63 2007/04/21 19:01:34 armin76 Exp $
+
+ 21 Apr 2007; Raúl Porcel <armin76@gentoo.org> +files/bittornado.desktop,
+ bittornado-0.3.15.ebuild, bittornado-0.3.18.ebuild:
+ Use desktop files instead of a hack, bug 175472
23 Mar 2007; Timothy Redaelli <drizzt@gentoo.org>
bittornado-0.3.18.ebuild:
diff --git a/net-p2p/bittornado/bittornado-0.3.15.ebuild b/net-p2p/bittornado/bittornado-0.3.15.ebuild
index d08089f5d65c..098d1f63bb04 100644
--- a/net-p2p/bittornado/bittornado-0.3.15.ebuild
+++ b/net-p2p/bittornado/bittornado-0.3.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.15.ebuild,v 1.8 2007/02/24 11:36:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.15.ebuild,v 1.9 2007/04/21 19:01:34 armin76 Exp $
inherit distutils eutils
@@ -40,35 +40,19 @@ src_unpack() {
src_install() {
distutils_src_install
- dodir /etc
- cp -pPR /etc/mailcap ${D}/etc/
- MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
-
if use gtk; then
dodir ${PIXMAPLOC}
insinto ${PIXMAPLOC}
doins icons/*.ico icons/*.gif
- if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
- # replace bittorrent entry if it already exists
- einfo "updating bittorrent mime info"
- sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
- else
- # add bittorrent entry if it doesn't exist
- einfo "adding bittorrent mime info"
- echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
- fi
else
# get rid of any reference to the not-installed gui version
- sed -i '/btdownloadgui/d' ${D}/etc/mailcap
rm ${D}/usr/bin/*gui.py
fi
- insinto /usr/share/bittorrent
- doins ${FILESDIR}/favicon.ico
- insinto /etc/conf.d
- newins ${FILESDIR}/bttrack.conf bttrack
+ newicon ${FILESDIR}/favicon.ico ${PN}.ico
+ domenu ${FILESDIR}/bittornado.desktop
- exeinto /etc/init.d
- newexe ${FILESDIR}/bttrack.rc bttrack
+ newconfd ${FILESDIR}/bttrack.conf bttrack
+ newinitd ${FILESDIR}/bttrack.rc bttrack
}
diff --git a/net-p2p/bittornado/bittornado-0.3.18.ebuild b/net-p2p/bittornado/bittornado-0.3.18.ebuild
index ee5dd1035a57..cd2394fadd8d 100644
--- a/net-p2p/bittornado/bittornado-0.3.18.ebuild
+++ b/net-p2p/bittornado/bittornado-0.3.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.18.ebuild,v 1.8 2007/03/23 21:07:24 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.18.ebuild,v 1.9 2007/04/21 19:01:34 armin76 Exp $
inherit distutils eutils
@@ -40,34 +40,18 @@ src_unpack() {
src_install() {
distutils_src_install
- dodir /etc
- cp -pPR /etc/mailcap ${D}/etc/
- MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
-
if use gtk; then
dodir ${PIXMAPLOC}
insinto ${PIXMAPLOC}
doins icons/*.ico icons/*.gif
- if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
- # replace bittorrent entry if it already exists
- einfo "updating bittorrent mime info"
- sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
- else
- # add bittorrent entry if it doesn't exist
- einfo "adding bittorrent mime info"
- echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
- fi
else
# get rid of any reference to the not-installed gui version
- sed -i '/btdownloadgui/d' ${D}/etc/mailcap
rm ${D}/usr/bin/*gui.py
fi
- insinto /usr/share/bittorrent
- doins ${FILESDIR}/favicon.ico
- insinto /etc/conf.d
- newins ${FILESDIR}/bttrack.conf bttrack
+ newicon ${FILESDIR}/favicon.ico ${PN}.ico
+ domenu ${FILESDIR}/bittornado.desktop
- exeinto /etc/init.d
- newexe ${FILESDIR}/bttrack.rc bttrack
-}
+ newconfd ${FILESDIR}/bttrack.conf bttrack
+ newinitd ${FILESDIR}/bttrack.rc bttrack
+} \ No newline at end of file
diff --git a/net-p2p/bittornado/files/bittornado.desktop b/net-p2p/bittornado/files/bittornado.desktop
new file mode 100644
index 000000000000..cac072c0828a
--- /dev/null
+++ b/net-p2p/bittornado/files/bittornado.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=BitTornado BitTorrent Client
+Comment=TheShad0w's experimental BitTorrent client
+Exec=/usr/bin/btdownloadgui.py
+Icon=bittornado.ico
+Terminal=false
+Type=Application
+Categories=Application;Network
+MimeType=application/x-bittorrent; \ No newline at end of file