summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-09-21 14:22:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-09-21 14:22:20 +0000
commitd70efaa891608210be507aeac53c9a59bb568004 (patch)
treef1436a7646fba8c7afd4013adb17e5f0bd35cae2 /net-p2p
parentRestore Qt 4.x support using upstream patch wrt #485038 by Mike Gilbert (diff)
downloadgentoo-2-d70efaa891608210be507aeac53c9a59bb568004.tar.gz
gentoo-2-d70efaa891608210be507aeac53c9a59bb568004.tar.bz2
gentoo-2-d70efaa891608210be507aeac53c9a59bb568004.zip
old
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog8
-rw-r--r--net-p2p/transmission/transmission-2.81-r1.ebuild150
-rw-r--r--net-p2p/transmission/transmission-2.81.ebuild146
-rw-r--r--net-p2p/transmission/transmission-2.82-r1.ebuild105
-rw-r--r--net-p2p/transmission/transmission-2.82-r2.ebuild107
-rw-r--r--net-p2p/transmission/transmission-2.82.ebuild100
6 files changed, 7 insertions, 609 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index 518e925d5ad7..3445d3bde28d 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.243 2013/09/21 14:20:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.244 2013/09/21 14:22:20 ssuominen Exp $
+
+ 21 Sep 2013; Samuli Suominen <ssuominen@gentoo.org>
+ -transmission-2.81-r1.ebuild, -transmission-2.81.ebuild,
+ -transmission-2.82-r1.ebuild, -transmission-2.82-r2.ebuild,
+ -transmission-2.82.ebuild:
+ old
*transmission-2.82-r3 (21 Sep 2013)
diff --git a/net-p2p/transmission/transmission-2.81-r1.ebuild b/net-p2p/transmission/transmission-2.81-r1.ebuild
deleted file mode 100644
index ca2f58cd9301..000000000000
--- a/net-p2p/transmission/transmission-2.81-r1.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.81-r1.ebuild,v 1.1 2013/09/06 18:21:41 pacho Exp $
-
-EAPI=5
-inherit autotools eutils fdo-mime gnome2-utils qt4-r2 systemd user
-
-DESCRIPTION="A Fast, Easy and Free BitTorrent client"
-HOMEPAGE="http://www.transmissionbt.com/"
-SRC_URI="http://download.transmissionbt.com/${PN}/files/${P}.tar.xz"
-
-LICENSE="GPL-2 MIT"
-SLOT=0
-IUSE="ayatana gtk lightweight systemd qt4 xfs"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux"
-
-RDEPEND="
- >=dev-libs/libevent-2.0.10:=
- dev-libs/openssl:0=
- net-libs/libnatpmp:=
- >=net-libs/miniupnpc-1.6.20120509:=
- >=net-misc/curl-7.16.3:=[ssl]
- sys-libs/zlib:=
- gtk? (
- >=dev-libs/dbus-glib-0.100:=
- >=dev-libs/glib-2.36:2=
- >=x11-libs/gtk+-3.4:3=
- ayatana? ( >=dev-libs/libappindicator-0.4.90:3= )
- )
- systemd? ( sys-apps/systemd )
- qt4? (
- dev-qt/qtcore:4=
- dev-qt/qtgui:4=
- dev-qt/qtdbus:4=
- )"
-
-DEPEND="${RDEPEND}
- dev-libs/glib:2
- dev-util/intltool
- sys-devel/gettext
- virtual/os-headers
- virtual/pkgconfig
- xfs? ( sys-fs/xfsprogs )"
-
-REQUIRED_USE="ayatana? ( gtk )"
-
-DOCS="AUTHORS NEWS qt/README.txt"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_prepare() {
- sed -i -e '/CFLAGS/s:-ggdb3::' configure.ac || die
- use ayatana || { sed -i -e '/^LIBAPPINDICATOR_MINIMUM/s:=.*:=9999:' configure.ac || die; }
-
- # Pass our configuration dir to systemd unit file
- sed -i '/ExecStart/ s|$| -g /var/transmission/config|' daemon/transmission-daemon.service || die
-
- # http://trac.transmissionbt.com/ticket/4324
- sed -i -e 's|noinst\(_PROGRAMS = $(TESTS)\)|check\1|' lib${PN}/Makefile.am || die
-
- # fix for broken translations path
- epatch "${FILESDIR}"/${PN}-2.80-translations-path-fix.patch
-
- eautoreconf
-}
-
-src_configure() {
- export ac_cv_header_xfs_xfs_h=$(usex xfs)
-
- econf \
- --enable-external-natpmp \
- $(use_enable lightweight) \
- $(use_with systemd systemd-daemon) \
- $(use_with gtk)
-
- if use qt4; then
- pushd qt >/dev/null
- eqmake4 qtr.pro
- popd >/dev/null
- fi
-}
-
-src_compile() {
- emake
-
- if use qt4; then
- pushd qt >/dev/null
- emake
- lrelease translations/*.ts
- popd >/dev/null
- fi
-}
-
-src_install() {
- default
-
- rm -f "${ED}"/usr/share/${PN}/web/LICENSE
-
- newinitd "${FILESDIR}"/${PN}-daemon.initd.8 ${PN}-daemon
- newconfd "${FILESDIR}"/${PN}-daemon.confd.3 ${PN}-daemon
- systemd_dounit "${S}/daemon/transmission-daemon.service"
-
- keepdir /var/{${PN}/{config,downloads},log/${PN}}
- fowners -R ${PN}:${PN} /var/{${PN}/{,config,downloads},log/${PN}}
-
- if use qt4; then
- pushd qt >/dev/null
- emake INSTALL_ROOT="${ED}"/usr install
-
- domenu ${PN}-qt.desktop
-
- local res
- for res in 16 22 24 32 48 64 72 96 128 192 256; do
- doicon -s ${res} icons/hicolor/${res}x${res}/${PN}-qt.png
- done
- doicon -s scalable icons/hicolor/scalable/${PN}-qt.svg
-
- insinto /usr/share/qt4/translations
- doins translations/*.qm
- popd >/dev/null
- fi
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-
- elog "If you use ${PN}-daemon, please, set 'rpc-username' and"
- elog "'rpc-password' (in plain text, ${PN}-daemon will hash it on"
- elog "start) in settings.json file located at /var/${PN}/config or"
- elog "any other appropriate config directory."
- elog
- elog "Since µTP is enabled by default, ${PN} needs large kernel buffers for"
- elog "the UDP socket. You can append following lines into /etc/sysctl.conf:"
- elog " net.core.rmem_max = 4194304"
- elog " net.core.wmem_max = 1048576"
- elog "and run sysctl -p"
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/net-p2p/transmission/transmission-2.81.ebuild b/net-p2p/transmission/transmission-2.81.ebuild
deleted file mode 100644
index 196e160c11b4..000000000000
--- a/net-p2p/transmission/transmission-2.81.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.81.ebuild,v 1.3 2013/08/05 15:23:01 ssuominen Exp $
-
-EAPI=5
-inherit autotools eutils fdo-mime gnome2-utils qt4-r2 user
-
-DESCRIPTION="A Fast, Easy and Free BitTorrent client"
-HOMEPAGE="http://www.transmissionbt.com/"
-SRC_URI="http://download.transmissionbt.com/${PN}/files/${P}.tar.xz"
-
-LICENSE="GPL-2 MIT"
-SLOT=0
-IUSE="ayatana gtk lightweight systemd qt4 xfs"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux"
-
-RDEPEND="
- >=dev-libs/libevent-2.0.10:=
- dev-libs/openssl:0=
- net-libs/libnatpmp:=
- >=net-libs/miniupnpc-1.6.20120509:=
- >=net-misc/curl-7.16.3:=[ssl]
- sys-libs/zlib:=
- gtk? (
- >=dev-libs/dbus-glib-0.100:=
- >=dev-libs/glib-2.36:2=
- >=x11-libs/gtk+-3.4:3=
- ayatana? ( >=dev-libs/libappindicator-0.4.90:3= )
- )
- systemd? ( sys-apps/systemd )
- qt4? (
- dev-qt/qtcore:4=
- dev-qt/qtgui:4=
- dev-qt/qtdbus:4=
- )"
-
-DEPEND="${RDEPEND}
- dev-libs/glib:2
- dev-util/intltool
- sys-devel/gettext
- virtual/os-headers
- virtual/pkgconfig
- xfs? ( sys-fs/xfsprogs )"
-
-REQUIRED_USE="ayatana? ( gtk )"
-
-DOCS="AUTHORS NEWS qt/README.txt"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_prepare() {
- sed -i -e '/CFLAGS/s:-ggdb3::' configure.ac || die
- use ayatana || { sed -i -e '/^LIBAPPINDICATOR_MINIMUM/s:=.*:=9999:' configure.ac || die; }
-
- # http://trac.transmissionbt.com/ticket/4324
- sed -i -e 's|noinst\(_PROGRAMS = $(TESTS)\)|check\1|' lib${PN}/Makefile.am || die
-
- # fix for broken translations path
- epatch "${FILESDIR}"/${PN}-2.80-translations-path-fix.patch
-
- eautoreconf
-}
-
-src_configure() {
- export ac_cv_header_xfs_xfs_h=$(usex xfs)
-
- econf \
- --enable-external-natpmp \
- $(use_enable lightweight) \
- $(use_with systemd systemd-daemon) \
- $(use_with gtk)
-
- if use qt4; then
- pushd qt >/dev/null
- eqmake4 qtr.pro
- popd >/dev/null
- fi
-}
-
-src_compile() {
- emake
-
- if use qt4; then
- pushd qt >/dev/null
- emake
- lrelease translations/*.ts
- popd >/dev/null
- fi
-}
-
-src_install() {
- default
-
- rm -f "${ED}"/usr/share/${PN}/web/LICENSE
-
- newinitd "${FILESDIR}"/${PN}-daemon.initd.8 ${PN}-daemon
- newconfd "${FILESDIR}"/${PN}-daemon.confd.3 ${PN}-daemon
-
- keepdir /var/{${PN}/{config,downloads},log/${PN}}
- fowners -R ${PN}:${PN} /var/{${PN}/{,config,downloads},log/${PN}}
-
- if use qt4; then
- pushd qt >/dev/null
- emake INSTALL_ROOT="${ED}"/usr install
-
- domenu ${PN}-qt.desktop
-
- local res
- for res in 16 22 24 32 48 64 72 96 128 192 256; do
- doicon -s ${res} icons/hicolor/${res}x${res}/${PN}-qt.png
- done
- doicon -s scalable icons/hicolor/scalable/${PN}-qt.svg
-
- insinto /usr/share/qt4/translations
- doins translations/*.qm
- popd >/dev/null
- fi
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-
- elog "If you use ${PN}-daemon, please, set 'rpc-username' and"
- elog "'rpc-password' (in plain text, ${PN}-daemon will hash it on"
- elog "start) in settings.json file located at /var/${PN}/config or"
- elog "any other appropriate config directory."
- elog
- elog "Since µTP is enabled by default, ${PN} needs large kernel buffers for"
- elog "the UDP socket. You can append following lines into /etc/sysctl.conf:"
- elog " net.core.rmem_max = 4194304"
- elog " net.core.wmem_max = 1048576"
- elog "and run sysctl -p"
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/net-p2p/transmission/transmission-2.82-r1.ebuild b/net-p2p/transmission/transmission-2.82-r1.ebuild
deleted file mode 100644
index 05bce7300b80..000000000000
--- a/net-p2p/transmission/transmission-2.82-r1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.82-r1.ebuild,v 1.1 2013/09/06 18:21:41 pacho Exp $
-
-EAPI=5
-inherit autotools eutils fdo-mime gnome2-utils systemd user
-
-DESCRIPTION="A Fast, Easy and Free BitTorrent client"
-HOMEPAGE="http://www.transmissionbt.com/"
-SRC_URI="http://download.transmissionbt.com/${PN}/files/${P}.tar.xz"
-
-LICENSE="GPL-2 MIT"
-SLOT=0
-IUSE="ayatana gtk lightweight systemd xfs"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux"
-
-RDEPEND=">=dev-libs/libevent-2.0.10:=
- dev-libs/openssl:0=
- net-libs/libnatpmp:=
- >=net-libs/miniupnpc-1.6.20120509:=
- >=net-misc/curl-7.16.3:=[ssl]
- sys-libs/zlib:=
- gtk? (
- >=dev-libs/dbus-glib-0.100:=
- >=dev-libs/glib-2.32:2=
- >=x11-libs/gtk+-3.4:3=
- ayatana? ( >=dev-libs/libappindicator-0.4.90:3= )
- )
- systemd? ( sys-apps/systemd )"
-DEPEND="${RDEPEND}
- dev-libs/glib:2
- dev-util/intltool
- sys-devel/gettext
- virtual/os-headers
- virtual/pkgconfig
- xfs? ( sys-fs/xfsprogs )"
-
-REQUIRED_USE="ayatana? ( gtk )"
-
-DOCS="AUTHORS NEWS"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_prepare() {
- sed -i -e '/CFLAGS/s:-ggdb3::' configure.ac || die
- use ayatana || { sed -i -e '/^LIBAPPINDICATOR_MINIMUM/s:=.*:=9999:' configure.ac || die; }
-
- # Pass our configuration dir to systemd unit file
- sed -i '/ExecStart/ s|$| -g /var/transmission/config|' daemon/transmission-daemon.service || die
-
- # http://trac.transmissionbt.com/ticket/4324
- sed -i -e 's|noinst\(_PROGRAMS = $(TESTS)\)|check\1|' lib${PN}/Makefile.am || die
- eautoreconf
-}
-
-src_configure() {
- export ac_cv_header_xfs_xfs_h=$(usex xfs)
-
- econf \
- --enable-external-natpmp \
- $(use_enable lightweight) \
- $(use_with systemd systemd-daemon) \
- $(use_with gtk)
-}
-
-src_install() {
- default
-
- rm -f "${ED}"/usr/share/${PN}/web/LICENSE
-
- newinitd "${FILESDIR}"/${PN}-daemon.initd.8 ${PN}-daemon
- newconfd "${FILESDIR}"/${PN}-daemon.confd.3 ${PN}-daemon
- systemd_dounit "${S}/daemon/transmission-daemon.service"
-
- keepdir /var/{${PN}/{config,downloads},log/${PN}}
- fowners -R ${PN}:${PN} /var/{${PN}/{,config,downloads},log/${PN}}
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-
- elog "If you use ${PN}-daemon, please, set 'rpc-username' and"
- elog "'rpc-password' (in plain text, ${PN}-daemon will hash it on"
- elog "start) in settings.json file located at /var/${PN}/config or"
- elog "any other appropriate config directory."
- elog
- elog "Since µTP is enabled by default, ${PN} needs large kernel buffers for"
- elog "the UDP socket. You can append following lines into /etc/sysctl.conf:"
- elog " net.core.rmem_max = 4194304"
- elog " net.core.wmem_max = 1048576"
- elog "and run sysctl -p"
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/net-p2p/transmission/transmission-2.82-r2.ebuild b/net-p2p/transmission/transmission-2.82-r2.ebuild
deleted file mode 100644
index eda894620c1c..000000000000
--- a/net-p2p/transmission/transmission-2.82-r2.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.82-r2.ebuild,v 1.1 2013/09/07 12:10:02 ssuominen Exp $
-
-EAPI=5
-inherit autotools eutils fdo-mime gnome2-utils systemd user
-
-DESCRIPTION="A Fast, Easy and Free BitTorrent client"
-HOMEPAGE="http://www.transmissionbt.com/"
-SRC_URI="http://download.transmissionbt.com/${PN}/files/${P}.tar.xz"
-
-LICENSE="GPL-2 MIT"
-SLOT=0
-IUSE="ayatana gtk lightweight systemd xfs"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux"
-
-RDEPEND=">=dev-libs/libevent-2.0.10:=
- dev-libs/openssl:0=
- net-libs/libnatpmp:=
- >=net-libs/miniupnpc-1.6.20120509:=
- >=net-misc/curl-7.16.3:=[ssl]
- sys-libs/zlib:=
- gtk? (
- >=dev-libs/dbus-glib-0.100:=
- >=dev-libs/glib-2.32:2=
- >=x11-libs/gtk+-3.4:3=
- ayatana? ( >=dev-libs/libappindicator-0.4.90:3= )
- )
- systemd? ( sys-apps/systemd )"
-DEPEND="${RDEPEND}
- dev-libs/glib:2
- dev-util/intltool
- sys-devel/gettext
- virtual/os-headers
- virtual/pkgconfig
- xfs? ( sys-fs/xfsprogs )"
-
-REQUIRED_USE="ayatana? ( gtk )"
-
-DOCS="AUTHORS NEWS"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_prepare() {
- sed -i -e '/CFLAGS/s:-ggdb3::' configure.ac || die
-
- # Trick to avoid automagic dependency
- use ayatana || { sed -i -e '/^LIBAPPINDICATOR_MINIMUM/s:=.*:=9999:' configure.ac || die; }
-
- # Pass our configuration dir to systemd unit file
- sed -i '/ExecStart/ s|$| -g /var/lib/transmission/config|' daemon/transmission-daemon.service || die
-
- # http://trac.transmissionbt.com/ticket/4324
- sed -i -e 's|noinst\(_PROGRAMS = $(TESTS)\)|check\1|' lib${PN}/Makefile.am || die
- eautoreconf
-}
-
-src_configure() {
- export ac_cv_header_xfs_xfs_h=$(usex xfs)
-
- econf \
- --enable-external-natpmp \
- $(use_enable lightweight) \
- $(use_with systemd systemd-daemon) \
- $(use_with gtk)
-}
-
-src_install() {
- default
-
- rm -f "${ED}"/usr/share/${PN}/web/LICENSE
-
- newinitd "${FILESDIR}"/${PN}-daemon.initd.9 ${PN}-daemon
- newconfd "${FILESDIR}"/${PN}-daemon.confd.4 ${PN}-daemon
- systemd_dounit daemon/${PN}-daemon.service
-
- keepdir /var/{lib/${PN}/{config,downloads},log/${PN}}
- fowners -R ${PN}:${PN} /var/{lib/${PN}/{,config,downloads},log/${PN}}
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-
- elog "If you use ${PN}-daemon, please, set 'rpc-username' and"
- elog "'rpc-password' (in plain text, ${PN}-daemon will hash it on"
- elog "start) in settings.json file located at /var/${PN}/config or"
- elog "any other appropriate config directory."
- elog
- elog "Since µTP is enabled by default, ${PN} needs large kernel buffers for"
- elog "the UDP socket. You can append following lines into /etc/sysctl.conf:"
- elog " net.core.rmem_max = 4194304"
- elog " net.core.wmem_max = 1048576"
- elog "and run sysctl -p"
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/net-p2p/transmission/transmission-2.82.ebuild b/net-p2p/transmission/transmission-2.82.ebuild
deleted file mode 100644
index 572c063267ed..000000000000
--- a/net-p2p/transmission/transmission-2.82.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.82.ebuild,v 1.1 2013/09/06 11:49:29 ssuominen Exp $
-
-EAPI=5
-inherit autotools eutils fdo-mime gnome2-utils user
-
-DESCRIPTION="A Fast, Easy and Free BitTorrent client"
-HOMEPAGE="http://www.transmissionbt.com/"
-SRC_URI="http://download.transmissionbt.com/${PN}/files/${P}.tar.xz"
-
-LICENSE="GPL-2 MIT"
-SLOT=0
-IUSE="ayatana gtk lightweight systemd xfs"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux"
-
-RDEPEND=">=dev-libs/libevent-2.0.10:=
- dev-libs/openssl:0=
- net-libs/libnatpmp:=
- >=net-libs/miniupnpc-1.6.20120509:=
- >=net-misc/curl-7.16.3:=[ssl]
- sys-libs/zlib:=
- gtk? (
- >=dev-libs/dbus-glib-0.100:=
- >=dev-libs/glib-2.32:2=
- >=x11-libs/gtk+-3.4:3=
- ayatana? ( >=dev-libs/libappindicator-0.4.90:3= )
- )
- systemd? ( sys-apps/systemd )"
-DEPEND="${RDEPEND}
- dev-libs/glib:2
- dev-util/intltool
- sys-devel/gettext
- virtual/os-headers
- virtual/pkgconfig
- xfs? ( sys-fs/xfsprogs )"
-
-REQUIRED_USE="ayatana? ( gtk )"
-
-DOCS="AUTHORS NEWS"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_prepare() {
- sed -i -e '/CFLAGS/s:-ggdb3::' configure.ac || die
- use ayatana || { sed -i -e '/^LIBAPPINDICATOR_MINIMUM/s:=.*:=9999:' configure.ac || die; }
- # http://trac.transmissionbt.com/ticket/4324
- sed -i -e 's|noinst\(_PROGRAMS = $(TESTS)\)|check\1|' lib${PN}/Makefile.am || die
- eautoreconf
-}
-
-src_configure() {
- export ac_cv_header_xfs_xfs_h=$(usex xfs)
-
- econf \
- --enable-external-natpmp \
- $(use_enable lightweight) \
- $(use_with systemd systemd-daemon) \
- $(use_with gtk)
-}
-
-src_install() {
- default
-
- rm -f "${ED}"/usr/share/${PN}/web/LICENSE
-
- newinitd "${FILESDIR}"/${PN}-daemon.initd.8 ${PN}-daemon
- newconfd "${FILESDIR}"/${PN}-daemon.confd.3 ${PN}-daemon
-
- keepdir /var/{${PN}/{config,downloads},log/${PN}}
- fowners -R ${PN}:${PN} /var/{${PN}/{,config,downloads},log/${PN}}
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-
- elog "If you use ${PN}-daemon, please, set 'rpc-username' and"
- elog "'rpc-password' (in plain text, ${PN}-daemon will hash it on"
- elog "start) in settings.json file located at /var/${PN}/config or"
- elog "any other appropriate config directory."
- elog
- elog "Since µTP is enabled by default, ${PN} needs large kernel buffers for"
- elog "the UDP socket. You can append following lines into /etc/sysctl.conf:"
- elog " net.core.rmem_max = 4194304"
- elog " net.core.wmem_max = 1048576"
- elog "and run sysctl -p"
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}