summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-03-20 12:59:26 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-03-20 12:59:26 +0000
commitd178356be72938e5f3815db48d260438edeaadb7 (patch)
treeac3e7446b2604244cd8c0f76cfb33b8e7a81008d /net-p2p
parentBump LeechCraft to 0.5.60, thank to 0xd34df00d (diff)
downloadgentoo-2-d178356be72938e5f3815db48d260438edeaadb7.tar.gz
gentoo-2-d178356be72938e5f3815db48d260438edeaadb7.tar.bz2
gentoo-2-d178356be72938e5f3815db48d260438edeaadb7.zip
Bump LeechCraft to 0.5.60, thank to 0xd34df00d
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/leechcraft-eiskaltdcpp/ChangeLog8
-rw-r--r--net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.60.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/net-p2p/leechcraft-eiskaltdcpp/ChangeLog b/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
index a20f59a84cc3..69dfcb00ddf5 100644
--- a/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
+++ b/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/leechcraft-eiskaltdcpp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/ChangeLog,v 1.7 2012/02/09 11:26:55 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/ChangeLog,v 1.8 2012/03/20 12:59:26 maksbotan Exp $
+
+*leechcraft-eiskaltdcpp-0.5.60 (20 Mar 2012)
+
+ 20 Mar 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-eiskaltdcpp-0.5.60.ebuild:
+ Bump LeechCraft to 0.5.60, thank to 0xd34df00d
*leechcraft-eiskaltdcpp-0.5.0 (09 Feb 2012)
diff --git a/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.60.ebuild b/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.60.ebuild
new file mode 100644
index 000000000000..9cd70fb02f76
--- /dev/null
+++ b/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.60.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.60.ebuild,v 1.1 2012/03/20 12:59:26 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="EiskaltDC++ ported to LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +emoticons examples javascript lua pcre spell sqlite upnp"
+
+RDEPEND="~net-misc/leechcraft-core-${PV}
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/openssl-0.9.8
+ virtual/libiconv
+ sys-devel/gettext
+ lua? ( >=dev-lang/lua-5.1 )
+ upnp? ( net-libs/miniupnpc )
+ javascript? (
+ x11-libs/qt-script
+ x11-libs/qtscriptgenerator
+ )
+ spell? ( app-text/aspell )
+ sqlite? ( x11-libs/qt-sql:4[sqlite] )
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ virtual/leechcraft-task-show
+ !!net-p2p/eiskaltdcpp"
+DEPEND="~net-misc/leechcraft-core-${PV}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use lua LUA_SCRIPT)"
+ "$(cmake-utils_use lua WITH_LUASCRIPTS)"
+ "$(cmake-utils_use javascript USE_JS)"
+ "$(cmake-utils_use spell USE_ASPELL)"
+ "$(cmake-utils_use sqlite USE_QT_SQLITE)"
+ "$(cmake-utils_use upnp USE_MINIUPNP)"
+ -DLOCAL_MINIUPNP="0"
+ "$(cmake-utils_use emoticons WITH_EMOTICONS)"
+ "$(cmake-utils_use examples WITH_EXAMPLES)"
+ "$(cmake-utils_use pcre PERL_REGEX)"
+ )
+
+ cmake-utils_src_configure
+}