summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-08 13:36:18 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-08 13:36:18 +0000
commitd17533297291ad9752d9388ea80de61f9ee3c733 (patch)
tree0f8c5019b5af1ad46e825f762ba5f94accbb9bc2 /net-p2p
parentSync up with nss from mozilla overlay (diff)
downloadgentoo-2-d17533297291ad9752d9388ea80de61f9ee3c733.tar.gz
gentoo-2-d17533297291ad9752d9388ea80de61f9ee3c733.tar.bz2
gentoo-2-d17533297291ad9752d9388ea80de61f9ee3c733.zip
Version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ncdc/ChangeLog8
-rw-r--r--net-p2p/ncdc/metadata.xml12
-rw-r--r--net-p2p/ncdc/ncdc-1.10.ebuild30
-rw-r--r--net-p2p/ncdc/ncdc-9999.ebuild13
4 files changed, 55 insertions, 8 deletions
diff --git a/net-p2p/ncdc/ChangeLog b/net-p2p/ncdc/ChangeLog
index 5eb0bc4949d5..273900c51da5 100644
--- a/net-p2p/ncdc/ChangeLog
+++ b/net-p2p/ncdc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/ncdc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ChangeLog,v 1.14 2012/05/04 06:33:33 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ChangeLog,v 1.15 2012/05/08 13:36:18 xmw Exp $
+
+*ncdc-1.10 (08 May 2012)
+
+ 08 May 2012; Michael Weber <xmw@gentoo.org> +ncdc-1.10.ebuild,
+ ncdc-9999.ebuild, metadata.xml:
+ Version bump
04 May 2012; Jeff Horelick <jdhore@gentoo.org> ncdc-1.9.ebuild,
ncdc-9999.ebuild:
diff --git a/net-p2p/ncdc/metadata.xml b/net-p2p/ncdc/metadata.xml
index 59acc2cc580e..5581e51b07d2 100644
--- a/net-p2p/ncdc/metadata.xml
+++ b/net-p2p/ncdc/metadata.xml
@@ -2,8 +2,14 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
-<email>xmw@gentoo.org</email>
-<name>Michael Weber</name>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
</maintainer>
+<upstream>
+ <maintainer status="active">
+ <email>projects@yorhel.nl</email>
+ </maintainer>
+ <changelog>http://dev.yorhel.nl/ncdc/changes</changelog>
+ <doc lang="en">http://dev.yorhel.nl/ncdc/man</doc>
+</upstream>
</pkgmetadata>
-
diff --git a/net-p2p/ncdc/ncdc-1.10.ebuild b/net-p2p/ncdc/ncdc-1.10.ebuild
new file mode 100644
index 000000000000..fad6a5b2d0b0
--- /dev/null
+++ b/net-p2p/ncdc/ncdc-1.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-1.10.ebuild,v 1.1 2012/05/08 13:36:18 xmw Exp $
+
+EAPI=4
+
+DESCRIPTION="ncurses directconnect client"
+HOMEPAGE="http://dev.yorhel.nl/ncdc"
+SRC_URI="http://dev.yorhel.nl/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="app-arch/bzip2
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ net-libs/gnutls
+ sys-libs/gdbm
+ sys-libs/ncurses:5"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ --enable-db-upgrade
+}
diff --git a/net-p2p/ncdc/ncdc-9999.ebuild b/net-p2p/ncdc/ncdc-9999.ebuild
index 563d6cb1d820..f076124f1bbf 100644
--- a/net-p2p/ncdc/ncdc-9999.ebuild
+++ b/net-p2p/ncdc/ncdc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-9999.ebuild,v 1.5 2012/05/04 06:33:33 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-9999.ebuild,v 1.6 2012/05/08 13:36:18 xmw Exp $
EAPI=4
@@ -10,7 +10,6 @@ inherit autotools base git-2
DESCRIPTION="ncurses directconnect client"
HOMEPAGE="http://dev.yorhel.nl/ncdc"
-SRC_URI=""
LICENSE="MIT"
SLOT="0"
@@ -19,10 +18,9 @@ IUSE=""
RDEPEND="app-arch/bzip2
dev-db/sqlite:3
- dev-lang/perl
dev-libs/glib:2
dev-libs/libxml2:2
- net-libs/glib-networking
+ net-libs/gnutls
sys-libs/gdbm
sys-libs/ncurses:5"
DEPEND="${RDEPEND}
@@ -32,3 +30,10 @@ DEPEND="${RDEPEND}
src_prepare() {
eautoreconf
}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ --enable-db-upgrade \
+ --enable-git-version
+}