summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-11-05 16:21:32 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-11-05 16:21:32 +0000
commitccc0cdea424f155b81b7df3ac75018aaa7a2771b (patch)
treece81ac00d970808c461adfb436398b93304682a1 /net-p2p
parentVersion bump wrt #291968, add missing lzma-utils dep wrt #274754 (diff)
downloadgentoo-2-ccc0cdea424f155b81b7df3ac75018aaa7a2771b.tar.gz
gentoo-2-ccc0cdea424f155b81b7df3ac75018aaa7a2771b.tar.bz2
gentoo-2-ccc0cdea424f155b81b7df3ac75018aaa7a2771b.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux ia64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.5.5.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index cefcbbc78895..9b3d35a9ea56 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.60 2009/09/30 22:49:40 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.61 2009/11/05 16:21:32 armin76 Exp $
+
+*qbittorrent-1.5.5 (05 Nov 2009)
+
+ 05 Nov 2009; Raúl Porcel <armin76@gentoo.org> +qbittorrent-1.5.5.ebuild:
+ Version bump
*qbittorrent-1.5.3 (30 Sep 2009)
diff --git a/net-p2p/qbittorrent/qbittorrent-1.5.5.ebuild b/net-p2p/qbittorrent/qbittorrent-1.5.5.ebuild
new file mode 100644
index 000000000000..56490eb8eda1
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-1.5.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.5.5.ebuild,v 1.1 2009/11/05 16:21:32 armin76 Exp $
+
+EAPI="2"
+inherit eutils qt4 multilib
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# boost version so that we always have thread support
+DEPEND=" x11-libs/qt-gui:4
+ >=net-libs/rb_libtorrent-0.14.6
+ >=dev-libs/boost-1.34.1
+ dev-libs/zziplib
+ net-misc/curl
+ dev-cpp/commoncpp2"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.3"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4_src_prepare
+}
+
+src_configure() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr || die "configure failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}