summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-16 00:05:18 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-16 00:05:18 +0000
commitc52ef056d8871e6fef0ab6c43f6b146a8377f8e7 (patch)
tree0a5be3bb8296bd2cd0a029a2004f28f2af859fba /net-p2p
parentVersion bump, bugfixes including personal status messages, adds voice clip su... (diff)
downloadgentoo-2-c52ef056d8871e6fef0ab6c43f6b146a8377f8e7.tar.gz
gentoo-2-c52ef056d8871e6fef0ab6c43f6b146a8377f8e7.tar.bz2
gentoo-2-c52ef056d8871e6fef0ab6c43f6b146a8377f8e7.zip
Fix build with gcc-4.3. Bug 251535. Patch snatched from http://bugs.debian.org/455302 .
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitstormlite/ChangeLog9
-rw-r--r--net-p2p/bitstormlite/bitstormlite-0.2p.ebuild12
-rw-r--r--net-p2p/bitstormlite/files/bitstormlite-0.2p-gcc43.patch54
3 files changed, 71 insertions, 4 deletions
diff --git a/net-p2p/bitstormlite/ChangeLog b/net-p2p/bitstormlite/ChangeLog
index 654b68f0344b..3d26126d07f2 100644
--- a/net-p2p/bitstormlite/ChangeLog
+++ b/net-p2p/bitstormlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bitstormlite
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/ChangeLog,v 1.9 2008/04/13 14:46:21 betelgeuse Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/ChangeLog,v 1.10 2009/02/16 00:05:16 loki_val Exp $
+
+ 16 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/bitstormlite-0.2p-gcc43.patch, bitstormlite-0.2p.ebuild:
+ Fix build with gcc-4.3. Bug 251535. Patch snatched from
+ http://bugs.debian.org/455302 .
13 Apr 2008; Petteri Räty <betelgeuse@gentoo.org>
bitstormlite-0.2p.ebuild:
diff --git a/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild b/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild
index 843e7eecd21b..dca9af14a949 100644
--- a/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild
+++ b/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild,v 1.2 2008/04/13 14:46:21 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild,v 1.3 2009/02/16 00:05:16 loki_val Exp $
+
+inherit eutils
DESCRIPTION="A light BitTorrent client based on c++ and gtk+."
HOMEPAGE="http://sourceforge.net/projects/bbom/"
@@ -17,6 +19,12 @@ DEPEND="dev-util/pkgconfig
S="${WORKDIR}/BitStormLite-${PV}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
}
diff --git a/net-p2p/bitstormlite/files/bitstormlite-0.2p-gcc43.patch b/net-p2p/bitstormlite/files/bitstormlite-0.2p-gcc43.patch
new file mode 100644
index 000000000000..26bafa192c04
--- /dev/null
+++ b/net-p2p/bitstormlite/files/bitstormlite-0.2p-gcc43.patch
@@ -0,0 +1,54 @@
+--- a/src/Socket.cpp
++++ b/src/Socket.cpp
+@@ -31,6 +31,8 @@
+ #include <arpa/inet.h>
+ #include "Socket.h"
+
++#include <cstring>
++
+ CSocket::CSocket()
+ : _reactor(NULL)
+ , _handle(-1)
+--- a/src/bdict.h
++++ b/src/bdict.h
+@@ -31,6 +31,8 @@
+ #include <map>
+ #include "bobject.h"
+
++#include <cstring>
++
+ class CBDict:public CBObject
+ {
+ public:
+--- a/src/binteger.h
++++ b/src/binteger.h
+@@ -31,6 +31,8 @@
+ #include <stdio.h>
+ #include "bobject.h"
+
++#include <cstdlib>
++
+ class CBInteger:public CBObject
+ {
+ public:
+--- a/src/bstring.h
++++ b/src/bstring.h
+@@ -27,6 +27,7 @@
+ #define _BSTRING_H_
+
+ #include<string>
++#include<cstdlib>
+
+ class CBString:public CBObject
+ {
+--- a/src/utils.h
++++ b/src/utils.h
+@@ -44,6 +44,8 @@
+ #include <glib.h>
+ #include "sha1.h"
+
++#include <cstring>
++
+ #define _(string) gettext(string)
+ #define N(string) string
+