summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-07-01 19:31:45 +0000
committerPacho Ramos <pacho@gentoo.org>2014-07-01 19:31:45 +0000
commitc522b10cc9edfdf3e7547e1d8dde9fce58e9804f (patch)
tree3ac2e3ae8fe9014fc3cacfa668f911ae78d0628d /net-p2p
parentAdd unit file (#513620 by StalkerNOVA) (diff)
downloadgentoo-2-c522b10cc9edfdf3e7547e1d8dde9fce58e9804f.tar.gz
gentoo-2-c522b10cc9edfdf3e7547e1d8dde9fce58e9804f.tar.bz2
gentoo-2-c522b10cc9edfdf3e7547e1d8dde9fce58e9804f.zip
Add unit file (#513296 by Michael Cook)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog8
-rw-r--r--net-p2p/rtorrent/files/rtorrentd_at.service15
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild58
3 files changed, 80 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index f521050ef7ff..647606f2d50b 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.185 2014/06/29 16:06:24 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.186 2014/07/01 19:31:42 pacho Exp $
+
+*rtorrent-0.9.4-r1 (01 Jul 2014)
+
+ 01 Jul 2014; Pacho Ramos <pacho@gentoo.org> +files/rtorrentd_at.service,
+ +rtorrent-0.9.4-r1.ebuild:
+ Add unit file (#513296 by Michael Cook)
*rtorrent-0.9.4 (29 Jun 2014)
diff --git a/net-p2p/rtorrent/files/rtorrentd_at.service b/net-p2p/rtorrent/files/rtorrentd_at.service
new file mode 100644
index 000000000000..704d48951e8a
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrentd_at.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=rTorrent
+requires=network.target local-fs.target
+
+[Service]
+Type=forking
+RemainAfterExit=yes
+KillMode=none
+User=%I
+ExecStart=/usr/bin/screen -d -m -S rtorrentd /usr/bin/rtorrent
+ExecStop=/usr/bin/screen -S rtorrentd -X quit
+WorkingDirectory=/home/%I/
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild b/net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..77504a23eae6
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild,v 1.1 2014/07/01 19:31:42 pacho Exp $
+
+EAPI=5
+
+inherit eutils systemd
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="daemon debug ipv6 selinux test xmlrpc"
+
+COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
+ >=dev-libs/libsigc++-2.2.2:2
+ >=net-misc/curl-7.19.1
+ sys-libs/ncurses
+ selinux? ( sec-policy/selinux-rtorrent )
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+RDEPEND="${COMMON_DEPEND}
+ daemon? ( app-misc/screen )"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-util/cppunit )
+ virtual/pkgconfig"
+
+DOCS=( doc/rtorrent.rc )
+
+src_prepare() {
+ # bug #358271
+ epatch "${FILESDIR}"/${PN}-0.9.1-ncurses.patch
+
+ # upstream forgot to include
+ cp "${FILESDIR}"/rtorrent.1 "${S}"/doc/ || die
+}
+
+src_configure() {
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with xmlrpc xmlrpc-c)
+}
+
+src_install() {
+ default
+ doman doc/rtorrent.1
+
+ if use daemon; then
+ newinitd "${FILESDIR}/rtorrentd.init" rtorrentd
+ newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd
+ systemd_newunit "${FILESDIR}/rtorrentd_at.service" "rtorrentd@.service"
+ fi
+}