summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-29 16:02:56 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-29 16:02:56 +0000
commitbe5b6a39ea282b3a8fcc491d8159765f0929468b (patch)
treec682c0a11922b5a68d05a1439dcd9166e5d61d99 /net-p2p
parentMarked ~hppa (bug #211756). (diff)
downloadgentoo-2-be5b6a39ea282b3a8fcc491d8159765f0929468b.tar.gz
gentoo-2-be5b6a39ea282b3a8fcc491d8159765f0929468b.tar.bz2
gentoo-2-be5b6a39ea282b3a8fcc491d8159765f0929468b.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/ChangeLog7
-rw-r--r--net-p2p/deluge/deluge-0.5.8.5.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index dc9b085fd340..6b41eae24390 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.57 2008/02/14 12:18:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.58 2008/02/29 16:02:56 armin76 Exp $
+
+*deluge-0.5.8.5 (29 Feb 2008)
+
+ 29 Feb 2008; Raúl Porcel <armin76@gentoo.org> +deluge-0.5.8.5.ebuild:
+ Version bump
*deluge-0.5.8.4 (14 Feb 2008)
diff --git a/net-p2p/deluge/deluge-0.5.8.5.ebuild b/net-p2p/deluge/deluge-0.5.8.5.ebuild
new file mode 100644
index 000000000000..6b804f426850
--- /dev/null
+++ b/net-p2p/deluge/deluge-0.5.8.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-0.5.8.5.ebuild,v 1.1 2008/02/29 16:02:56 armin76 Exp $
+
+inherit eutils distutils flag-o-matic
+
+DESCRIPTION="BitTorrent client in Python and PyGTK."
+HOMEPAGE="http://deluge-torrent.org/"
+SRC_URI="http://download.deluge-torrent.org/source/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="libnotify"
+
+S="${WORKDIR}"/${PN}-torrent-${PV}
+
+DEPEND=">=dev-lang/python-2.3
+ dev-libs/boost"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2
+ dev-python/pyxdg
+ dev-python/dbus-python
+ gnome-base/librsvg
+ libnotify? ( dev-python/notify-python )"
+
+pkg_setup() {
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "dev-libs/boost has to be built with threads USE-flag."
+ die "Missing threads USE-flag for dev-libs/boost"
+ fi
+
+ filter-ldflags -Wl,--as-needed
+}
+
+pkg_postinst() {
+ elog
+ elog "If after upgrading it doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ elog "Please note that Deluge is still in it's early stages"
+ elog "of development. Use it carefully and feel free to submit bugs"
+ elog "in upstream page."
+ elog
+}