summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-08-31 07:39:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-08-31 07:39:27 +0000
commitbdba8b19ef297e51a219ab264cade910450f2d7e (patch)
treef905733242a291b97a1a8234121ce2fbbaf830e4 /net-p2p
parentVersion bump, thanks to Daniel Webert and CJ Kucera, bug #144926 and #145384. (diff)
downloadgentoo-2-bdba8b19ef297e51a219ab264cade910450f2d7e.tar.gz
gentoo-2-bdba8b19ef297e51a219ab264cade910450f2d7e.tar.bz2
gentoo-2-bdba8b19ef297e51a219ab264cade910450f2d7e.zip
Version bump, thanks to Daniel Webert and CJ Kucera, bug #144926 and #145384.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.6.13
-rw-r--r--net-p2p/rtorrent/rtorrent-0.6.1.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 19a287d6c12e..7d274584d079 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.52 2006/07/21 00:47:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.53 2006/08/31 07:39:27 flameeyes Exp $
+
+*rtorrent-0.6.1 (31 Aug 2006)
+
+ 31 Aug 2006; Diego Pettenò <flameeyes@gentoo.org> +rtorrent-0.6.1.ebuild:
+ Version bump, thanks to Daniel Webert and CJ Kucera, bug #144926 and #145384.
21 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> -rtorrent-0.4.3.ebuild:
Drop old version.
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.6.1 b/net-p2p/rtorrent/files/digest-rtorrent-0.6.1
new file mode 100644
index 000000000000..951b8e340ff3
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.6.1
@@ -0,0 +1,3 @@
+MD5 587b02e12a397f68bf91d6be20c46ccc rtorrent-0.6.1.tar.gz 411058
+RMD160 71a2e4cf5522d0e3a42e1d3293e4d8ff960252b1 rtorrent-0.6.1.tar.gz 411058
+SHA256 b27e4863e25d35f0a4c672cd4048a0627845e4507bb2da5a13979ea7bbbcb20f rtorrent-0.6.1.tar.gz 411058
diff --git a/net-p2p/rtorrent/rtorrent-0.6.1.ebuild b/net-p2p/rtorrent/rtorrent-0.6.1.ebuild
new file mode 100644
index 000000000000..37fefb8617d5
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.6.1.ebuild,v 1.1 2006/08/31 07:39:27 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=net-libs/libtorrent-0.10.0
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ replace-flags -Os -O2
+
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}