summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-07-12 15:16:26 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-07-12 15:16:26 +0000
commitb7c33933cc014eb85556ffdb449b1f53cb751a74 (patch)
tree3cdb7d86781df4b2cefdbed691085460bcfd2c00 /net-p2p
parentamd64 stable, bug #231571 (diff)
downloadgentoo-2-b7c33933cc014eb85556ffdb449b1f53cb751a74.tar.gz
gentoo-2-b7c33933cc014eb85556ffdb449b1f53cb751a74.tar.bz2
gentoo-2-b7c33933cc014eb85556ffdb449b1f53cb751a74.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.1.0_beta3.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index a7b56f2e8463..baeeb38ae9d7 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.36 2008/06/03 10:44:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.37 2008/07/12 15:16:26 armin76 Exp $
+
+*qbittorrent-1.1.0_beta3 (12 Jul 2008)
+
+ 12 Jul 2008; Raúl Porcel <armin76@gentoo.org>
+ +qbittorrent-1.1.0_beta3.ebuild:
+ Version bump
*qbittorrent-1.1.0_beta1 (03 Jun 2008)
diff --git a/net-p2p/qbittorrent/qbittorrent-1.1.0_beta3.ebuild b/net-p2p/qbittorrent/qbittorrent-1.1.0_beta3.ebuild
new file mode 100644
index 000000000000..49933b448bfa
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-1.1.0_beta3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.1.0_beta3.ebuild,v 1.1 2008/07/12 15:16:26 armin76 Exp $
+
+EAPI="1"
+
+inherit eutils qt4 multilib
+
+MY_P="${P/_/}"
+
+DESCRIPTION="BitTorrent client in C++ and Qt."
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="|| ( x11-libs/qt-gui:4 >=x11-libs/qt-4.3:4 )
+ >=net-libs/rb_libtorrent-0.13.1
+ dev-libs/boost
+ net-misc/curl
+ dev-cpp/commoncpp2"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.3"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! built_with_use --missing true "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_compile() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libtorrent-inc=/usr/include \
+ --with-libtorrent-lib=/usr/$(get_libdir) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}