summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-03-31 12:30:36 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-03-31 12:30:36 +0000
commitb3d29a877d4038ee39dd93253bacf38dc5e09fee (patch)
tree51630ab55ba844a5633ff8e420c14e97eb4cce63 /net-p2p
parentStable on alpha. (diff)
downloadgentoo-2-b3d29a877d4038ee39dd93253bacf38dc5e09fee.tar.gz
gentoo-2-b3d29a877d4038ee39dd93253bacf38dc5e09fee.tar.bz2
gentoo-2-b3d29a877d4038ee39dd93253bacf38dc5e09fee.zip
Version bump, bug #86708
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent/ChangeLog8
-rw-r--r--net-p2p/bittorrent/bittorrent-4.0.1.ebuild73
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-4.0.11
3 files changed, 81 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 223b43f807d5..235063f9b0b4 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.43 2005/03/24 19:21:16 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.44 2005/03/31 12:30:36 sekretarz Exp $
+
+*bittorrent-4.0.1 (31 Mar 2005)
+
+ 31 Mar 2005; Karol Wojtaszek <sekretarz@gentoo.org>
+ +bittorrent-4.0.1.ebuild:
+ Version bump
24 Mar 2005; Bryan Østergaard <kloeri@gentoo.org>
bittorrent-4.0.0.ebuild:
diff --git a/net-p2p/bittorrent/bittorrent-4.0.1.ebuild b/net-p2p/bittorrent/bittorrent-4.0.1.ebuild
new file mode 100644
index 000000000000..61a1f33c24e4
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-4.0.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.0.1.ebuild,v 1.1 2005/03/31 12:30:36 sekretarz Exp $
+
+inherit distutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://www.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~sparc ~alpha"
+IUSE="X"
+
+RDEPEND="X? ( >=x11-libs/gtk+-2.4* \
+ >=dev-python/pygtk-2.4*)
+ >=dev-lang/python-2.3
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+PROVIDE="virtual/bittorrent"
+
+DOCS="credits.txt"
+PYTHON_MODULE="BitTorrent"
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dohtml redirdonate.html
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+
+ insinto /usr/share/bittorrent
+ doins ${FILESDIR}/favicon.ico
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/bttrack.conf bttrack
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bttrack.rc bttrack
+}
+
+pkg_postinst() {
+ einfo "BitTorrent has changed to the BitTorrent Open Source License"
+ einfo ">> http://www.bittorrent.com/license/"
+ distutils_pkg_postinst
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-4.0.1 b/net-p2p/bittorrent/files/digest-bittorrent-4.0.1
new file mode 100644
index 000000000000..fa89579baaaa
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-4.0.1
@@ -0,0 +1 @@
+MD5 e890d856d43b3d0af14b28714bc5801a BitTorrent-4.0.1.tar.gz 154427