summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-05-25 23:41:59 +0000
committerJon Hood <squinky86@gentoo.org>2004-05-25 23:41:59 +0000
commitb344fcd4b8368aecdc2dfe7f8503ad3afd7f52ce (patch)
tree33924674de89b760ebe3af36f193a67baeb18c1e /net-p2p
parentInitial import - closes bug 49875 (Manifest recommit) (diff)
downloadgentoo-2-b344fcd4b8368aecdc2dfe7f8503ad3afd7f52ce.tar.gz
gentoo-2-b344fcd4b8368aecdc2dfe7f8503ad3afd7f52ce.tar.bz2
gentoo-2-b344fcd4b8368aecdc2dfe7f8503ad3afd7f52ce.zip
version bump, closes #45855
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/ChangeLog8
-rw-r--r--net-p2p/amule/Manifest2
-rw-r--r--net-p2p/amule/amule-2.0.0_rc3.ebuild72
-rw-r--r--net-p2p/amule/files/digest-amule-2.0.0_rc31
4 files changed, 82 insertions, 1 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index 9920bed7f7e1..04eb196e82d6 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.19 2004/05/12 18:00:03 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.20 2004/05/25 23:41:59 squinky86 Exp $
+
+*amule-2.0.0_rc3 (25 May 2004)
+
+ 25 May 2004; Jon Hood <squinky86@gentoo.org> +amule-2.0.0_rc3.ebuild:
+ version bump, closes #45855; thanks to Giacomo Perale <ghepeu@virgilio.it>
+ for the ebuild
12 May 2004; Jon Hood <squinky86@gentoo.org> amule-1.2.6.ebuild:
putting back into ~amd64 since zlib dependency is still in ~arch
diff --git a/net-p2p/amule/Manifest b/net-p2p/amule/Manifest
index 9afde7558183..f0bef9df3298 100644
--- a/net-p2p/amule/Manifest
+++ b/net-p2p/amule/Manifest
@@ -1,6 +1,8 @@
+MD5 672aa579da12e0fe255e790a02c8c07d amule-2.0.0_rc3.ebuild 2044
MD5 5dd86500aef9d60b600653027424aff8 amule-1.2.6.ebuild 1038
MD5 5870be80977e4ef8c18a2f79db5bd77f amule-1.1.0.ebuild 996
MD5 f422e4d1562739fd553c503acb7541c1 ChangeLog 2711
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
+MD5 2fb2652f4ff91f2244ff07cccd31d5d2 files/digest-amule-2.0.0_rc3 68
MD5 1f788e567786e2aefb362559593e827a files/digest-amule-1.1.0 65
MD5 a301972585e39355d61f9dcc8daaab86 files/digest-amule-1.2.6 65
diff --git a/net-p2p/amule/amule-2.0.0_rc3.ebuild b/net-p2p/amule/amule-2.0.0_rc3.ebuild
new file mode 100644
index 000000000000..27438331f738
--- /dev/null
+++ b/net-p2p/amule/amule-2.0.0_rc3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+MY_P=${P/m/M}
+MY_P=${MY_P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="aNOTHER wxWindows based eMule P2P Client"
+HOMEPAGE="http://www.amule.org"
+SRC_URI="http://download.berlios.de/${PN}/${MY_P}.tar.bz2"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug nls stats remote"
+EXTRA_ECONF="--disable-optimise"
+
+# optimizations disabled for better stability
+# new USE "noamulestats" disables aMule GUI statistics (wxCas) (require libgd)
+# new USE "noamuleremote" disables remote control utilities: webserver,
+# web client, amulecmd text client
+
+
+DEPEND=">=x11-libs/wxGTK-2.4.2
+ >=net-misc/curl-7.11.0
+ >=dev-libs/crypto++-5.1
+ >=sys-libs/zlib-1.2.1
+ stats? ( >=media-libs/libgd-2.0.22 )"
+
+pkg_setup() {
+
+ # GTK2 is unstable and not supported by aMule developers
+ if wx-config --cppflags | grep gtk2 >& /dev/null; then
+ einfo "Compiling ${PN} against wxGTK2 is not supported."
+ die "wxGTK must be re-emerged with USE=-gtk2."
+ fi
+
+ # aMule doesn't compile against unicoded wxGTK at all.
+ if wx-config --cppflags | grep gtk2u >& /dev/null; then
+ einfo "${PN} will not build if wxGTK was compiled"
+ einfo "with unicode support. If you are using a version of"
+ einfo "wxGTK <= 2.4.2, you must set USE=-gtk2. In newer versions,"
+ einfo "you must set USE=-unicode."
+ die "wxGTK must be re-emerged without unicode suport"
+ fi
+
+}
+
+src_compile() {
+
+ use remote || EXTRA_ECONF="${EXTRA_ECONF} --disable-amulecmd \
+ --disable-amulecmdgui \
+ --disable-webserver \
+ --disable-webservergui" \
+ || EXTRA_ECONF="${EXTRA_ECONF} --enable-amulecmd \
+ --enable-amulecmdgui \
+ --enable-webserver \
+ --enable-webservergui"
+
+ #workaround for broken configure (doesn't recognize --enable-wxcas)
+ use stats || EXTRA_ECONF="${EXTRA_ECONF} --disable-wxcas"
+
+ econf `use_enable nls` \
+ `use_enable debug` || die
+
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
diff --git a/net-p2p/amule/files/digest-amule-2.0.0_rc3 b/net-p2p/amule/files/digest-amule-2.0.0_rc3
new file mode 100644
index 000000000000..0adc1a6d5b04
--- /dev/null
+++ b/net-p2p/amule/files/digest-amule-2.0.0_rc3
@@ -0,0 +1 @@
+MD5 9c56b982e89bff7fc10af57bbb57b7db aMule-2.0.0rc3.tar.bz2 2283194