summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-19 19:01:49 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-19 19:01:49 +0000
commita6822f84ca68cf26f7d92b5347746ea91ee87118 (patch)
tree59b16886f9bd6fe6de262b89fda721c18cc91f23 /net-p2p
parentBumb (diff)
downloadgentoo-2-a6822f84ca68cf26f7d92b5347746ea91ee87118.tar.gz
gentoo-2-a6822f84ca68cf26f7d92b5347746ea91ee87118.tar.bz2
gentoo-2-a6822f84ca68cf26f7d92b5347746ea91ee87118.zip
Bumb
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.4.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 78bdef0283a5..166795efbd88 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.126 2008/10/04 23:44:24 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.127 2008/11/19 19:01:49 loki_val Exp $
+
+*rtorrent-0.8.4 (19 Nov 2008)
+
+ 19 Nov 2008; Peter Alfredsen <loki_val@gentoo.org> +rtorrent-0.8.4.ebuild:
+ Bumb
04 Oct 2008; Peter Alfredsen <loki_val@gentoo.org> rtorrent-0.7.9.ebuild,
rtorrent-0.8.2-r3.ebuild, rtorrent-0.8.3.ebuild:
diff --git a/net-p2p/rtorrent/rtorrent-0.8.4.ebuild b/net-p2p/rtorrent/rtorrent-0.8.4.ebuild
new file mode 100644
index 000000000000..5e8f4bbffcf5
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.8.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.4.ebuild,v 1.1 2008/11/19 19:01:49 loki_val Exp $
+
+inherit base eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 xmlrpc"
+
+RDEPEND=">=net-libs/libtorrent-0.12.${PV##*.}
+ >=dev-libs/libsigc++-2.2.2
+ >=net-misc/curl-7.19.1
+ sys-libs/ncurses
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-0.8.2-gcc34.patch" )
+
+src_compile() {
+ replace-flags -Os -O2
+ append-flags -fno-strict-aliasing
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ econf $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with xmlrpc xmlrpc-c) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}
+
+pkg_postinst() {
+ elog "rtorrent now supports a configuration file."
+ elog "A sample configuration file for rtorrent can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+ elog ""
+ ewarn "If you're upgrading from rtorrent <0.8.0, you will have to delete your"
+ ewarn "session directory or run the fixSession080-c.py script from this address:"
+ ewarn "http://rssdler.googlecode.com/files/fixSession080-c.py"
+ ewarn "See http://libtorrent.rakshasa.no/wiki/LibTorrentKnownIssues for more info."
+}