summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-12-20 16:41:26 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-12-20 16:41:26 +0000
commita1991d3d50a379f4b35c8e2fa77cefe9b74f7177 (patch)
tree1c5e12077e7345b86f0013c575b2da8ae56553b4 /net-p2p
parenthppa stable #72440 (Manifest recommit) (diff)
downloadgentoo-2-a1991d3d50a379f4b35c8e2fa77cefe9b74f7177.tar.gz
gentoo-2-a1991d3d50a379f4b35c8e2fa77cefe9b74f7177.tar.bz2
gentoo-2-a1991d3d50a379f4b35c8e2fa77cefe9b74f7177.zip
Fixes #71378.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus/ChangeLog12
-rw-r--r--net-p2p/azureus/azureus-2.2.0.0-r1.ebuild70
-rw-r--r--net-p2p/azureus/azureus-2.2.0.0.ebuild64
-rw-r--r--net-p2p/azureus/files/azureus-gentoo.sh61
-rw-r--r--net-p2p/azureus/files/build.xml2
-rw-r--r--net-p2p/azureus/files/digest-azureus-2.2.0.0-r1 (renamed from net-p2p/azureus/files/digest-azureus-2.2.0.0)0
6 files changed, 101 insertions, 108 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index e4266b2ab91f..51747778a40d 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.1 2004/11/15 10:29:24 sejo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.2 2004/12/20 16:41:26 karltk Exp $
+
+*azureus-2.2.0.0-r1 (20 Dec 2004)
+
+ 20 Dec 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+ files/azureus-gentoo.sh, files/build.xml, +azureus-2.2.0.0-r1.ebuild,
+ -azureus-2.2.0.0.ebuild:
+ Rewrote startup script. Reindented ebuild. Requires properly SLOTed version
+ of dev-java/swt. Modified build.xml script. Should fix #71378.
+
+*azureus-2.2.0.0-r1 (20 Dec 2004)
15 Nov 2004; <SeJo@gentoo.org> :
initial add of ebuild
diff --git a/net-p2p/azureus/azureus-2.2.0.0-r1.ebuild b/net-p2p/azureus/azureus-2.2.0.0-r1.ebuild
new file mode 100644
index 000000000000..132e99e0c6db
--- /dev/null
+++ b/net-p2p/azureus/azureus-2.2.0.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.2.0.0-r1.ebuild,v 1.1 2004/12/20 16:41:26 karltk Exp $
+
+DESCRIPTION="Azureus - Java BitTorrent Client"
+HOMEPAGE="http://azureus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/azureus/Azureus_${PV}_source.zip
+ mirror://gentoo/seda-20040224.zip"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND="virtual/libc
+ >=dev-java/swt-3.0
+ >=app-arch/unzip-5.0"
+RDEPEND="virtual/libc
+ >=dev-java/swt-3.0-r2
+ >=dev-java/log4j-1.2.8
+ >=dev-java/commons-cli-1.0
+ >=dev-java/systray4j-2.4"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ local PROGRAM_DIR="/usr/lib/${PN}"
+
+ mkdir ${S} && cd ${S}
+ unpack ${A}
+ cp ${FILESDIR}/build.xml ${S} || die "cp build.xml failed"
+
+ #removing osx files and entries
+ cp -f ${FILESDIR}/SWTThread.java \
+ ${S}/org/gudy/azureus2/ui/swt/mainwindow/SWTThread.java \
+ || die "cp SWTThread.java failed!"
+
+ # copying the shell to run the app
+ cp ${FILESDIR}/azureus-gentoo.sh ${S}/azureus \
+ || die "cp azureus-gentoo.sh filed"
+
+ # Set runtime settings in the startup script
+ sed -i "s:##PROGRAM_DIR##:${PROGRAM_DIR}:" ${S}/azureus \
+ || die "sed azureus program dir failed !"
+ rm -fr org/gudy/azureus2/ui/swt/osx org/gudy/azureus2/ui/swt/test
+}
+
+src_compile() {
+ # Figure out correct boot classpath
+ if [ ! -z "$(java-config --java-version | grep IBM)" ] ; then
+ # IBM JRE
+ ant_extra_opts="-Dbootclasspath=$(java-config --jdk-home)/jre/lib/core.jar:$(java-config --jdk-home)/jre/lib/xml.jar:$(java-config --jdk-home)/jre/lib/graphics.jar"
+ else
+ # Sun derived JREs (Blackdown, Sun)
+ ant_extra_opts="-Dbootclasspath=$(java-config --jdk-home)/jre/lib/rt.jar"
+ fi
+ ant -q -q \
+ -buildfile build.xml ${ant_extra_opts} jar \
+ || die "ant build failed"
+}
+
+src_install() {
+ local PROGRAM_DIR="/usr/lib/${PN}"
+
+ insinto ${PROGRAM_DIR}
+ doins *.jar || die "doins jar failed"
+ dobin azureus || die "dobin /usr/bin/azureus failed"
+ insinto /usr/share/pixmaps
+ doins "${FILESDIR}/azureus.png"
+ insinto /usr/share/applications
+ doins "${FILESDIR}/azureus.desktop"
+ dodoc seda-README.txt
+}
diff --git a/net-p2p/azureus/azureus-2.2.0.0.ebuild b/net-p2p/azureus/azureus-2.2.0.0.ebuild
deleted file mode 100644
index f3fd32f0d28a..000000000000
--- a/net-p2p/azureus/azureus-2.2.0.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.2.0.0.ebuild,v 1.1 2004/11/15 10:29:24 sejo Exp $
-
-DESCRIPTION="Azureus - Java BitTorrent Client"
-HOMEPAGE="http://azureus.sourceforge.net/"
-SRC_URI="mirror://sourceforge/azureus/Azureus_${PV}_source.zip
- mirror://gentoo/seda-20040224.zip"
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~ppc"
-IUSE=""
-DEPEND="virtual/libc
- >=dev-java/swt-3.0
- >=app-arch/unzip-5.0"
-RDEPEND="virtual/libc
- >=dev-java/swt-3.0
- >=dev-java/log4j-1.2.8
- >=dev-java/commons-cli-1.0
- >=dev-java/systray4j-2.4"
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- PROGRAM_DIR="/usr/lib/${PN}"
- mkdir ${S} && cd ${S}
- unpack ${A}
- cp ${FILESDIR}/build.xml ${S} || die "cp build.xml failed"
- #removing osx files and entries
- cp -f ${FILESDIR}/SWTThread.java \
- ${S}/org/gudy/azureus2/ui/swt/mainwindow/SWTThread.java \
- || die "cp SWTThread.java failed!"
- # copying the shell to run the app
- cp ${FILESDIR}/azureus-gentoo.sh ${S}/azureus \
- || die "cp azureus-gentoo.sh filed"
- # Set runtime settings in the startup script
- sed -i "s:##PROGRAM_DIR##:${PROGRAM_DIR}:" ${S}/azureus \
- || die "sed azureus program dir failed !"
- rm -fr org/gudy/azureus2/ui/swt/osx org/gudy/azureus2/ui/swt/test
-}
-
-src_compile() {
- # Figure out correct boot classpath
- if [ ! -z "$(java-config --java-version | grep IBM)" ] ; then
- # IBM JRE
- ant_extra_opts="-Dbootclasspath=$(java-config --jdk-home)/jre/lib/core.jar:$(java-config --jdk-home)/jre/lib/xml.jar:$(java-config --jdk-home)/jre/lib/graphics.jar"
- else
- # Sun derived JREs (Blackdown, Sun)
- ant_extra_opts="-Dbootclasspath=$(java-config --jdk-home)/jre/lib/rt.jar"
- fi
- ant -q -q \
- -buildfile build.xml ${ant_extra_opts} jar \
- || die "ant build failed"
-}
-
-src_install() {
- insinto ${PROGRAM_DIR}
- doins *.jar || die "doins jar failed"
- dobin azureus || die "dobin /usr/bin/azureus failed"
- insinto /usr/share/pixmaps
- doins "${FILESDIR}/azureus.png"
- insinto /usr/share/applications
- doins "${FILESDIR}/azureus.desktop"
- dodoc seda-README.txt
-}
diff --git a/net-p2p/azureus/files/azureus-gentoo.sh b/net-p2p/azureus/files/azureus-gentoo.sh
index b85c48417809..8bad6978cd8c 100644
--- a/net-p2p/azureus/files/azureus-gentoo.sh
+++ b/net-p2p/azureus/files/azureus-gentoo.sh
@@ -1,21 +1,28 @@
-#!/bin/sh
+#! /bin/bash
+#
+# Copyright (c) 2004, Jochen Maes <sejo@gentoo.org>
+# Copyright (c) 2004, Karl Trygve Kalleberg <karltk@gentoo.org>
+# Copyright (c) 2004, Gentoo Foundation
+#
+# Licensed under the GNU General Public License, v2
-PROGRAM_DIR=##PROGRAM_DIR## # directory where all the files were extracted
+azudir=/usr/lib/azureus
+dotazudir=${HOME}/.Azureus
+gentoocfg=${dotazudir}/gentoo.config
-AZ_CONFIG="${HOME}/.Azureus/gentoo.config"
-if [ -f ~/.Azureus/gentoo.config ]; then
- . ~/.Azureus/gentoo.config
+if [ -f ${gentoocfg} ] ; then
+ . ${gentoocfg}
else
- if [ ! -e ~/.Azureus ]; then
- mkdir ~/.Azureus
- echo "Creating ~/.Azureus..."
+ if [ ! -e ${dotazudir} ] ; then
+ mkdir ${dotazudir}
+ echo "Creating ${dotazudir}"
fi
# Setup defaults
UI_OPTIONS="--ui=swt"
# Create the config file
- cat > ${AZ_CONFIG} <<END
+ cat > ${gentoocfg} <<END
# User Interface options:
# web - web based
# web2 - web based
@@ -29,37 +36,7 @@ END
fi
-MSG0="ERROR:\nYou must edit this script and change PROGRAM_DIR to point to where you installed Azureus"
-MSG1="Attempting to start Azureus..."
-
-AZDIR=./
-if [ ! -e id.azureus.dir.file ]; then
- AZDIR=$PROGRAM_DIR
- if [ ! -d $AZDIR ]; then
- echo $MSG0 >&2
- exit -1
- fi
-fi
+cd ${dotazudir}
-cd ${AZDIR}
-echo $MSG1
-
-# This should work as long as your classpath is setup right...
-#JARS=`ls *.jar | grep -v Azureus2`
-#for FILE in $JARS; do CLASSPATH="${FILE}:${CLASSPATH}"; done
-#java -cp $CLASSPATH -Djava.library.path="/usr/lib:${AZDIR}" -jar Azureus2.jar ${UI_OPTIONS} "$1"
-
-# Try this if the above doesn't work
-for FILE in *.jar; do CLASSPATH="${FILE}:${CLASSPATH}"; done
-java -cp $CLASSPATH -Djava.library.path="/usr/share/swt/lib:${AZDIR}" org.gudy.azureus2.ui.swt.Main "$1"
-
-if [ $? -ne 0 ]; then
- echo "If you recieved an error about a missing java class, you need to setup"
- echo "your classpath correctly."
- echo "This should do the trick (as root):"
- echo "java-config --add-system-classpath=junit,log4j,commons-cli-1,systray4j,swt"
- echo "env-update && source /etc/profile"
- echo
- echo "Currently, your classpath (including azureus additions) is:"
- echo "${CLASSPATH}"
-fi
+CLASSPATH=$(java-config -p junit,log4j,commons-cli-1,systray4j,swt-3):${azudir}/azureus.jar:${azudir}/seda.jar
+java -cp $CLASSPATH -Djava.library.path=/usr/lib org.gudy.azureus2.ui.swt.Main "$1"
diff --git a/net-p2p/azureus/files/build.xml b/net-p2p/azureus/files/build.xml
index b0f7d850c9b6..e1a91cff85c5 100644
--- a/net-p2p/azureus/files/build.xml
+++ b/net-p2p/azureus/files/build.xml
@@ -5,7 +5,7 @@
<classpath>
<pathelement location="."/>
<pathelement location="/usr/share/commons-cli-1/lib/commons-cli.jar"/>
- <pathelement location="/usr/share/swt/lib/swt.jar"/>
+ <pathelement location="/usr/share/swt-3/lib/swt.jar"/>
<pathelement location="seda.jar"/>
</classpath>
</javac>
diff --git a/net-p2p/azureus/files/digest-azureus-2.2.0.0 b/net-p2p/azureus/files/digest-azureus-2.2.0.0-r1
index 483f1b88554d..483f1b88554d 100644
--- a/net-p2p/azureus/files/digest-azureus-2.2.0.0
+++ b/net-p2p/azureus/files/digest-azureus-2.2.0.0-r1