summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-09-15 10:57:13 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-09-15 10:57:13 +0000
commit9f500f1ef3a18353a5e291643520993ea67c2998 (patch)
treed8f4ddbc3b5a259117dd5ad63cb865b4ff43d7a8 /net-p2p
parentCleanup (diff)
downloadgentoo-2-9f500f1ef3a18353a5e291643520993ea67c2998.tar.gz
gentoo-2-9f500f1ef3a18353a5e291643520993ea67c2998.tar.bz2
gentoo-2-9f500f1ef3a18353a5e291643520993ea67c2998.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r7 i686)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog9
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.1.4.ebuild (renamed from net-p2p/qbittorrent/qbittorrent-1.2.0_beta5.ebuild)2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.2.0_beta6.ebuild57
3 files changed, 66 insertions, 2 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 12ac241a8911..2b8001aa8d72 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.44 2008/08/26 10:03:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.45 2008/09/15 10:57:13 armin76 Exp $
+
+*qbittorrent-1.2.0_beta6 (15 Sep 2008)
+*qbittorrent-1.1.4 (15 Sep 2008)
+
+ 15 Sep 2008; Raúl Porcel <armin76@gentoo.org> +qbittorrent-1.1.4.ebuild,
+ -qbittorrent-1.2.0_beta5.ebuild, +qbittorrent-1.2.0_beta6.ebuild:
+ Version bump
*qbittorrent-1.2.0_beta5 (26 Aug 2008)
*qbittorrent-1.1.3 (26 Aug 2008)
diff --git a/net-p2p/qbittorrent/qbittorrent-1.2.0_beta5.ebuild b/net-p2p/qbittorrent/qbittorrent-1.1.4.ebuild
index 9d4d42ffabb8..b614775e16fa 100644
--- a/net-p2p/qbittorrent/qbittorrent-1.2.0_beta5.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.2.0_beta5.ebuild,v 1.1 2008/08/26 10:03:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.1.4.ebuild,v 1.1 2008/09/15 10:57:13 armin76 Exp $
EAPI="1"
diff --git a/net-p2p/qbittorrent/qbittorrent-1.2.0_beta6.ebuild b/net-p2p/qbittorrent/qbittorrent-1.2.0_beta6.ebuild
new file mode 100644
index 000000000000..2a5d3e7bab9b
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-1.2.0_beta6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.2.0_beta6.ebuild,v 1.1 2008/09/15 10:57:13 armin76 Exp $
+
+EAPI="1"
+
+inherit eutils qt4 multilib
+
+MY_P="${P/_/}"
+
+DESCRIPTION="BitTorrent client in C++ and Qt."
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3*:4 )
+ >=net-libs/rb_libtorrent-0.13.1
+ dev-libs/boost
+ net-misc/curl
+ dev-cpp/commoncpp2"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.3"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! built_with_use --missing true "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+}
+
+src_compile() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libtorrent-inc=/usr/include \
+ --with-libtorrent-lib=/usr/$(get_libdir) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}