summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-04-23 20:12:29 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-04-23 20:12:29 +0000
commit942bc0b7f8dba94d7001fb2420e4c485eda36cf0 (patch)
tree9621d22b7ca65185f842f2c0dca63ffa1f2ea9db /net-p2p
parentUnmask dev-util/cmake-2.8.10.2 now I've fixed it (diff)
downloadgentoo-2-942bc0b7f8dba94d7001fb2420e4c485eda36cf0.tar.gz
gentoo-2-942bc0b7f8dba94d7001fb2420e4c485eda36cf0.tar.bz2
gentoo-2-942bc0b7f8dba94d7001fb2420e4c485eda36cf0.zip
Version bump. Switch to fork in https://github.com/ShanaTsunTsunLove/torrentinfo since upstream is dead. Bug #466328. Thanks to Nikoli <nikoli@lavabit.com> for the ebuild
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/torrentinfo/ChangeLog13
-rw-r--r--net-p2p/torrentinfo/metadata.xml12
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.4.ebuild26
3 files changed, 46 insertions, 5 deletions
diff --git a/net-p2p/torrentinfo/ChangeLog b/net-p2p/torrentinfo/ChangeLog
index 44763ebadbbd..a64d4c8e7bb5 100644
--- a/net-p2p/torrentinfo/ChangeLog
+++ b/net-p2p/torrentinfo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/torrentinfo
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/ChangeLog,v 1.6 2010/10/10 19:07:07 arfrever Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/ChangeLog,v 1.7 2013/04/23 20:12:29 hwoarang Exp $
+
+*torrentinfo-1.8.4 (23 Apr 2013)
+
+ 23 Apr 2013; Markos Chandras <hwoarang@gentoo.org> +torrentinfo-1.8.4.ebuild,
+ metadata.xml:
+ Version bump. Switch to fork in
+ https://github.com/ShanaTsunTsunLove/torrentinfo since upstream is dead. Bug
+ #466328. Thanks to Nikoli <nikoli@lavabit.com> for the ebuild
10 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
torrentinfo-1.0.2.ebuild:
@@ -30,4 +38,3 @@
Initial commit for torrentinfo. Thanks to Avuton Olrich <avuton@gmail.com>
for
the initial ebuild. Fixes bug 253799
-
diff --git a/net-p2p/torrentinfo/metadata.xml b/net-p2p/torrentinfo/metadata.xml
index 7d3738d1efc9..1036172fa48c 100644
--- a/net-p2p/torrentinfo/metadata.xml
+++ b/net-p2p/torrentinfo/metadata.xml
@@ -1,9 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+<herd>proxy-maintaienrs</herd>
<maintainer>
-<email>hwoarang@gentoo.org</email>
-<name>Markos Chandras</name>
+<email>nikoli@lavabit.com</email>
+<name>Nikoli</name>
</maintainer>
+<upstream>
+<maintainer>
+<email>fuuzetsu@fuuzetsu.co.uk</email>
+<name>Mateusz Kowalczyk</name>
+</maintainer>
+<bugs-to>https://github.com/ShanaTsunTsunLove/torrentinfo/issues</bugs-to>
+</upstream>
</pkgmetadata>
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.4.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.4.ebuild
new file mode 100644
index 000000000000..cab07519b63b
--- /dev/null
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/torrentinfo-1.8.4.ebuild,v 1.1 2013/04/23 20:12:29 hwoarang Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="A torrent file parser"
+HOMEPAGE="https://github.com/ShanaTsunTsunLove/torrentinfo"
+SRC_URI="https://github.com/ShanaTsunTsunLove/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests -v test/tests.py || die "Tests fail with ${EPYTHON}"
+}