summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-27 14:05:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-27 14:05:29 +0000
commit8df2f4dbea2d2f3dec53daca04734dc21b13cc03 (patch)
tree21bb6f20af82b18da591f2325a6a95ac5804e5b9 /net-p2p
parentppc stable #273249 (diff)
downloadgentoo-2-8df2f4dbea2d2f3dec53daca04734dc21b13cc03.tar.gz
gentoo-2-8df2f4dbea2d2f3dec53daca04734dc21b13cc03.tar.bz2
gentoo-2-8df2f4dbea2d2f3dec53daca04734dc21b13cc03.zip
Bump as requested by Scarabeus
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog7
-rw-r--r--net-p2p/ktorrent/ktorrent-3.2.4.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 6b904e5be6f5..dbda5b9f5747 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.129 2009/08/29 10:35:18 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.130 2009/09/27 14:05:29 patrick Exp $
+
+*ktorrent-3.2.4 (27 Sep 2009)
+
+ 27 Sep 2009; Patrick Lauer <patrick@gentoo.org> +ktorrent-3.2.4.ebuild:
+ Bump as requested by Scarabeus
*ktorrent-3.2.3-r1 (29 Aug 2009)
diff --git a/net-p2p/ktorrent/ktorrent-3.2.4.ebuild b/net-p2p/ktorrent/ktorrent-3.2.4.ebuild
new file mode 100644
index 000000000000..cf9015c68f73
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-3.2.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-3.2.4.ebuild,v 1.1 2009/09/27 14:05:29 patrick Exp $
+
+EAPI="2"
+
+KDE_LINGUAS="ar be bg ca cs da de el en_GB es et fr ga gl hi it ja
+ km lt lv nb nds nl nn oc pl pt pt_BR ro ru se sk sl sr sv
+ tr uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer +mediaplayer plasma rss +scanfolder +search +stats +upnp webinterface +zeroconf"
+
+COMMONDEPEND="app-crypt/qca:2
+ dev-libs/gmp
+ mediaplayer? ( >=media-libs/taglib-1.5 )
+ plasma? ( >=kde-base/libtaskmanager-${KDE_MINIMAL} )
+ rss? (
+ dev-libs/boost
+ >=kde-base/kdepimlibs-${KDE_MINIMAL}
+ )"
+DEPEND="${COMMONDEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${COMMONDEPEND}
+ infowidget? ( >=dev-libs/geoip-1.4.4 )
+ ipfilter? ( >=kde-base/kdebase-kioslaves-${KDE_MINIMAL} )
+ kross? ( >=kde-base/krosspython-${KDE_MINIMAL} )"
+
+src_prepare() {
+ if ! use plasma; then
+ sed -i \
+ -e "s:add_subdirectory(plasma):#nada:g" \
+ CMakeLists.txt || die "Failed to make plasmoid optional"
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DENABLE_DHT_SUPPORT=ON
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
+ $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)"
+ kde4-base_src_configure
+}