summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-01-17 19:58:44 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-01-17 19:58:44 +0000
commit898f1cad67d77fe26d0f4a44363d5693532061de (patch)
treea6513e6efa4c40f00e52c3c8719b06aa42d6f204 /net-p2p
parentEAPI bump (diff)
downloadgentoo-2-898f1cad67d77fe26d0f4a44363d5693532061de.tar.gz
gentoo-2-898f1cad67d77fe26d0f4a44363d5693532061de.tar.bz2
gentoo-2-898f1cad67d77fe26d0f4a44363d5693532061de.zip
Version bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.1.5.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index ed35888ecc6b..bef258dbe5d4 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.223 2014/01/01 11:44:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.224 2014/01/17 19:58:44 hwoarang Exp $
+
+*qbittorrent-3.1.5 (17 Jan 2014)
+
+ 17 Jan 2014; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-3.1.5.ebuild:
+ Version bump
*qbittorrent-3.1.4 (01 Jan 2014)
diff --git a/net-p2p/qbittorrent/qbittorrent-3.1.5.ebuild b/net-p2p/qbittorrent/qbittorrent-3.1.5.ebuild
new file mode 100644
index 000000000000..23f3ade271ce
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.1.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.1.5.ebuild,v 1.1 2014/01/17 19:58:44 hwoarang Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1 qt4-r2
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus +X geoip"
+
+# python-2 is a runtime dep only, for the search engine (see INSTALL file)
+CDEPEND="dev-libs/boost
+ dev-qt/qtcore:4
+ >=net-libs/rb_libtorrent-0.16.3
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904
+ X? ( dev-qt/qtgui:4 )
+ dbus? ( dev-qt/qtdbus:4 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+ use X || myconf+=" --disable-gui"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-qtsingleapplication=system \
+ --with-libboost-inc=/usr/include/boost \
+ ${myconf} || die "configure failed"
+ eqmake4
+}