summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-04-22 17:50:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-04-22 17:50:25 +0000
commit7f684cba5bb9e81b2666577c382821f24fce5eb5 (patch)
treed2ffb7e4c302d2871101f2eaab3bfc110f9e1ef4 /net-p2p
parentRefactor ebuild to use python functions correctly. Fixes bug #312665 (diff)
downloadgentoo-2-7f684cba5bb9e81b2666577c382821f24fce5eb5.tar.gz
gentoo-2-7f684cba5bb9e81b2666577c382821f24fce5eb5.tar.bz2
gentoo-2-7f684cba5bb9e81b2666577c382821f24fce5eb5.zip
Refactor ebuild to use python functions correctly. Fixes bug #315867
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/torrentinfo/ChangeLog6
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/net-p2p/torrentinfo/ChangeLog b/net-p2p/torrentinfo/ChangeLog
index 48e108f8cdd2..60f356f2271f 100644
--- a/net-p2p/torrentinfo/ChangeLog
+++ b/net-p2p/torrentinfo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/torrentinfo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/ChangeLog,v 1.4 2010/04/19 16:56:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/ChangeLog,v 1.5 2010/04/22 17:50:25 hwoarang Exp $
+
+ 22 Apr 2010; Markos Chandras <hwoarang@gentoo.org>
+ torrentinfo-1.0.2.ebuild:
+ Refactor ebuild to use python functions correctly. Fixes bug #315867
19 Apr 2010; Markos Chandras <hwoarang@gentoo.org>
torrentinfo-1.0.2.ebuild:
diff --git a/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild b/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild
index 89818846a13a..16c97a3ddd69 100644
--- a/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild
+++ b/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild,v 1.4 2010/04/19 16:56:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild,v 1.5 2010/04/22 17:50:25 hwoarang Exp $
PYTHON_DEPEND="2:2.6"
-inherit distutils
+inherit python distutils
DESCRIPTION="A torrent file parser"
HOMEPAGE="http://vrai.net/project.php?project=torrentinfo"
@@ -14,3 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+
+pkg_setup() {
+ python_set_active_version 2
+}