summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-05-07 19:38:36 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-05-07 19:38:36 +0000
commit78897bd5adfec8b1e4366c522323ddcbde1e8f1f (patch)
tree36ae0f1c5458af38e26382f65a4def13c817de89 /net-p2p
parentVersion bump. (diff)
downloadgentoo-2-78897bd5adfec8b1e4366c522323ddcbde1e8f1f.tar.gz
gentoo-2-78897bd5adfec8b1e4366c522323ddcbde1e8f1f.tar.bz2
gentoo-2-78897bd5adfec8b1e4366c522323ddcbde1e8f1f.zip
Version bump. Switch to xz tarballs
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.1.9.2.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 4efd9316e0fd..1515b29c264e 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.228 2014/04/20 08:59:31 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.229 2014/05/07 19:38:36 hwoarang Exp $
+
+*qbittorrent-3.1.9.2 (07 May 2014)
+
+ 07 May 2014; Markos Chandras <hwoarang@gentoo.org>
+ +qbittorrent-3.1.9.2.ebuild:
+ Version bump. Switch to xz tarballs
20 Apr 2014; Ben de Groot <yngwin@gentoo.org> metadata.xml:
Stepping down as maintainer since I no longer use this package
diff --git a/net-p2p/qbittorrent/qbittorrent-3.1.9.2.ebuild b/net-p2p/qbittorrent/qbittorrent-3.1.9.2.ebuild
new file mode 100644
index 000000000000..71084d584880
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.1.9.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.1.9.2.ebuild,v 1.1 2014/05/07 19:38:36 hwoarang Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1 qt4-r2
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus +X geoip"
+
+# python-2 is a runtime dep only, for the search engine (see INSTALL file)
+CDEPEND="dev-libs/boost
+ dev-qt/qtcore:4
+ >=net-libs/rb_libtorrent-0.16.3
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904[X?]
+ X? ( dev-qt/qtgui:4 )
+ dbus? ( dev-qt/qtdbus:4 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+ use X || myconf+=" --disable-gui"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-qtsingleapplication=system \
+ --with-libboost-inc=/usr/include/boost \
+ ${myconf} || die "configure failed"
+ eqmake4
+}