summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-06-06 10:09:51 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-06-06 10:09:51 +0000
commit77d04a0dc4485f749a8595c6e87b76224b1fed6b (patch)
tree2ea2591533e4ab9cfa39c3026f5e153066bf4198 /net-p2p
parentVersion bump (diff)
downloadgentoo-2-77d04a0dc4485f749a8595c6e87b76224b1fed6b.tar.gz
gentoo-2-77d04a0dc4485f749a8595c6e87b76224b1fed6b.tar.bz2
gentoo-2-77d04a0dc4485f749a8595c6e87b76224b1fed6b.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/valknut/ChangeLog7
-rw-r--r--net-p2p/valknut/valknut-0.3.14a.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/net-p2p/valknut/ChangeLog b/net-p2p/valknut/ChangeLog
index 19b473a3dff1..03fcc14edb64 100644
--- a/net-p2p/valknut/ChangeLog
+++ b/net-p2p/valknut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/valknut
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/valknut/ChangeLog,v 1.58 2008/06/06 05:59:41 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/valknut/ChangeLog,v 1.59 2008/06/06 10:09:51 armin76 Exp $
+
+*valknut-0.3.14a (06 Jun 2008)
+
+ 06 Jun 2008; Raúl Porcel <armin76@gentoo.org> +valknut-0.3.14a.ebuild:
+ Version bump
06 Jun 2008; Markus Rothe <corsair@gentoo.org> valknut-0.3.13.ebuild:
Stable on ppc64; bug #225029
diff --git a/net-p2p/valknut/valknut-0.3.14a.ebuild b/net-p2p/valknut/valknut-0.3.14a.ebuild
new file mode 100644
index 000000000000..991952fc83f7
--- /dev/null
+++ b/net-p2p/valknut/valknut-0.3.14a.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/valknut/valknut-0.3.14a.ebuild,v 1.1 2008/06/06 10:09:51 armin76 Exp $
+
+inherit qt3
+
+DESCRIPTION="Qt based client for DirectConnect"
+HOMEPAGE="http://sourceforge.net/projects/wxdcgui/"
+SRC_URI="mirror://sourceforge/wxdcgui/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="ssl"
+
+RDEPEND="$(qt_min_version 3)
+ >=dev-libs/libxml2-2.4.22
+ ~net-p2p/dclib-${PV}
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_with ssl) \
+ --with-libdc=/usr \
+ --with-qt-dir=${QTDIR} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}