summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-07-25 21:22:32 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-07-25 21:22:32 +0000
commit6dcaedaf79e7041c70cb2dfe7240e4dc29c8187d (patch)
treef8e39653c26efbd04776feb7582ed52381365c72 /net-p2p
parentAdded back Jikes support. (diff)
downloadgentoo-2-6dcaedaf79e7041c70cb2dfe7240e4dc29c8187d.tar.gz
gentoo-2-6dcaedaf79e7041c70cb2dfe7240e4dc29c8187d.tar.bz2
gentoo-2-6dcaedaf79e7041c70cb2dfe7240e4dc29c8187d.zip
Fixed compile problems with enabled ekg2, thanks Marcin Kryczek <aye@gentoo.pl> in bug #100120
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mldonkey/ChangeLog7
-rw-r--r--net-p2p/mldonkey/files/mldonkey-2.6.0-gtk2-gentoo.patch10
-rw-r--r--net-p2p/mldonkey/mldonkey-2.6.0.ebuild20
3 files changed, 29 insertions, 8 deletions
diff --git a/net-p2p/mldonkey/ChangeLog b/net-p2p/mldonkey/ChangeLog
index be369140f4cc..4862fcc8d1ee 100644
--- a/net-p2p/mldonkey/ChangeLog
+++ b/net-p2p/mldonkey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/mldonkey
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/ChangeLog,v 1.84 2005/07/24 09:16:51 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/ChangeLog,v 1.85 2005/07/25 21:22:32 sekretarz Exp $
+
+ 25 Jul 2005; <sekretarz@gentoo.org>
+ +files/mldonkey-2.6.0-gtk2-gentoo.patch, mldonkey-2.6.0.ebuild:
+ Fixed compile problems with enabled ekg2, thanks Marcin Kryczek
+ <aye@gentoo.pl> in bug #100120
24 Jul 2005; <sekretarz@gentoo.org> mldonkey-2.6.0.ebuild:
Turned off batch configure option, cought by Phil
diff --git a/net-p2p/mldonkey/files/mldonkey-2.6.0-gtk2-gentoo.patch b/net-p2p/mldonkey/files/mldonkey-2.6.0-gtk2-gentoo.patch
new file mode 100644
index 000000000000..d7a1521d95aa
--- /dev/null
+++ b/net-p2p/mldonkey/files/mldonkey-2.6.0-gtk2-gentoo.patch
@@ -0,0 +1,10 @@
+--- src/gtk2/chat/chat_art.ml.orig 2005-07-25 15:56:52.000000000 +0200
++++ src/gtk2/chat/chat_art.ml 2005-07-25 15:57:33.000000000 +0200
+@@ -22,6 +22,7 @@
+ (* Icons ressources of mlchat *)
+ (* *)
+ (**********************************************************************************)
++open CommonGlobals
+
+ let table = [
+ "icon_settings", (Menu_settings_svg.t, "");
diff --git a/net-p2p/mldonkey/mldonkey-2.6.0.ebuild b/net-p2p/mldonkey/mldonkey-2.6.0.ebuild
index aacd190373e6..73d9d3715f7e 100644
--- a/net-p2p/mldonkey/mldonkey-2.6.0.ebuild
+++ b/net-p2p/mldonkey/mldonkey-2.6.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/mldonkey-2.6.0.ebuild,v 1.2 2005/07/24 09:16:51 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/mldonkey-2.6.0.ebuild,v 1.3 2005/07/25 21:22:32 sekretarz Exp $
inherit eutils
-IUSE="X gtk2 gd"
+IUSE="gtk2 gd gtk"
DESCRIPTION="mldonkey is a new client to access the eDonkey network. It is written in Objective-Caml, and comes with its own GTK GUI, an HTTP interface and a telnet interface."
HOMEPAGE="http://www.nongnu.org/mldonkey/"
@@ -19,7 +19,7 @@ RDEPEND="dev-lang/perl
>=dev-lang/ocaml-3.08.3
gtk2? ( >=gnome-base/librsvg-2.4.0
>=dev-ml/lablgtk-2.4 )
- X? ( !gtk2? ( =dev-ml/lablgtk-1.2.7* ) )
+ gtk? ( !gtk2? ( =dev-ml/lablgtk-1.2.7* ) )
gd? ( >=media-libs/gd-2.0.28 )"
DEPEND="${RDEPEND}
@@ -47,10 +47,14 @@ src_unpack() {
cd ${S}
export WANT_AUTOCONF=2.5
cd config; autoconf; cd ..
+ use gtk2 && epatch ${FILESDIR}/${P}-gtk2-gentoo.patch
}
src_compile() {
-
+ myconf="";
+ if use gtk || use gkt2; then
+ myconf="--enable-gui"
+ fi;
econf \
--sysconfdir=/etc/mldonkey \
--sharedstatedir=/var/mldonkey \
@@ -59,8 +63,8 @@ src_compile() {
--disable-batch \
--enable-pthread \
`use_enable gtk2` \
- `use_enable X gui` \
- `use_enable gd` || die "Configure Failed!"
+ `use_enable gd` \
+ ${myconf} || die "Configure Failed!"
export OCAMLRUNPARAM="l=256M"
emake || die "Make Failed"
@@ -68,7 +72,9 @@ src_compile() {
src_install() {
dobin mlnet
- use gtk && dobin mlchat mlgui mlguistarter mlim mlnet+gui
+ if use gtk || use gtk2; then
+ dobin mlchat mlgui mlguistarter mlim mlnet+gui
+ fi
dobin ${FILESDIR}/mldonkey
dodoc ChangeLog Copying.txt Developers.txt Install.txt