summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-11-06 21:37:52 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-11-06 21:37:52 +0000
commit6b9214341600ff8ce208fc7a265f52e1dd0de467 (patch)
treeec3afde6c7c77e9e1cb50397f873035a6e4659ae /net-p2p
parentlibltdl is only a native dep, so dropped needless MULTILIB_USEDEP flags; also... (diff)
downloadgentoo-2-6b9214341600ff8ce208fc7a265f52e1dd0de467.tar.gz
gentoo-2-6b9214341600ff8ce208fc7a265f52e1dd0de467.tar.bz2
gentoo-2-6b9214341600ff8ce208fc7a265f52e1dd0de467.zip
Version bump. Bug #528226
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.1.11.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 21dbd47b87bc..bcf293acf66e 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.235 2014/10/19 00:23:31 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.236 2014/11/06 21:37:52 hwoarang Exp $
+
+*qbittorrent-3.1.11 (06 Nov 2014)
+
+ 06 Nov 2014; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-3.1.11.ebuild:
+ Version bump. Bug #528226
19 Oct 2014; Davide Pesavento <pesa@gentoo.org> qbittorrent-3.1.10.ebuild,
qbittorrent-3.1.9.2-r1.ebuild, qbittorrent-9999.ebuild:
diff --git a/net-p2p/qbittorrent/qbittorrent-3.1.11.ebuild b/net-p2p/qbittorrent/qbittorrent-3.1.11.ebuild
new file mode 100644
index 000000000000..c2de6547ab55
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.1.11.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.1.11.ebuild,v 1.1 2014/11/06 21:37:52 hwoarang Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1 qt4-r2
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+MY_P=${P/_}
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="dbus debug geoip +X"
+
+# geoip and python are runtime deps only (see INSTALL file)
+CDEPEND="
+ dev-libs/boost:=
+ dev-qt/qtcore:4
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[X?]
+ >=net-libs/rb_libtorrent-0.16.17
+ dbus? ( dev-qt/qtdbus:4 )
+ X? ( dev-qt/qtgui:4 )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ geoip? ( dev-libs/geoip )
+"
+
+S=${WORKDIR}/${MY_P}
+DOCS=(AUTHORS Changelog README.md TODO)
+
+src_configure() {
+ # Custom configure script, econf fails
+ local myconf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --with-libboost-inc="${EPREFIX}/usr/include/boost"
+ --with-qtsingleapplication=system
+ $(use dbus || echo --disable-qt-dbus)
+ $(use debug && echo --enable-debug)
+ $(use geoip || echo --disable-geoip-database)
+ $(use X || echo --disable-gui)
+ )
+
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die "configure failed"
+ eqmake4
+}