summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2011-01-18 23:58:04 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2011-01-18 23:58:04 +0000
commit6056fd7bc9387611cb68758128378490fbe4e3fc (patch)
tree743003536faa521b08a84073d85aea29872bbe91 /net-p2p
parentMoved from sunrise overlay. Thanks to Nathan Phillip Brink (ohnobinki) <ohnob... (diff)
downloadgentoo-2-6056fd7bc9387611cb68758128378490fbe4e3fc.tar.gz
gentoo-2-6056fd7bc9387611cb68758128378490fbe4e3fc.tar.bz2
gentoo-2-6056fd7bc9387611cb68758128378490fbe4e3fc.zip
Fix potential buffer overflow in identity application (#339355)
Fix bugs #351872 and #351658 (Use flag names, mysql support fix) (Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gnunet/ChangeLog10
-rw-r--r--net-p2p/gnunet/files/0.8.1-Fix-buffer-overflow.patch29
-rw-r--r--net-p2p/gnunet/gnunet-0.8.1-r2.ebuild (renamed from net-p2p/gnunet/gnunet-0.8.1-r1.ebuild)29
-rw-r--r--net-p2p/gnunet/metadata.xml8
4 files changed, 57 insertions, 19 deletions
diff --git a/net-p2p/gnunet/ChangeLog b/net-p2p/gnunet/ChangeLog
index 7b05636c5f66..0fae1ca8533f 100644
--- a/net-p2p/gnunet/ChangeLog
+++ b/net-p2p/gnunet/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/gnunet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.69 2011/01/14 00:52:11 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.70 2011/01/18 23:58:04 sochotnicky Exp $
+
+*gnunet-0.8.1-r2 (18 Jan 2011)
+
+ 18 Jan 2011; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +files/0.8.1-Fix-buffer-overflow.patch, -gnunet-0.8.1-r1.ebuild,
+ +gnunet-0.8.1-r2.ebuild, metadata.xml:
+ Fix potential buffer overflow in identity application (#339355)
+ Fix bugs #351872 and #351658 (Use flag names, mysql support fix)
*gnunet-0.8.1-r1 (14 Jan 2011)
diff --git a/net-p2p/gnunet/files/0.8.1-Fix-buffer-overflow.patch b/net-p2p/gnunet/files/0.8.1-Fix-buffer-overflow.patch
new file mode 100644
index 000000000000..b41a360a87f8
--- /dev/null
+++ b/net-p2p/gnunet/files/0.8.1-Fix-buffer-overflow.patch
@@ -0,0 +1,29 @@
+From d029cce1691ba78310763059c35ed08596ebf74f Mon Sep 17 00:00:00 2001
+From: Stanislav Ochotnicky <sochotnicky@gmail.com>
+Date: Sat, 15 Jan 2011 21:02:52 +0100
+Subject: [PATCH] Fix buffer overflow
+
+memset function was called incorrectly with address of a pointer
+instead of address where pointer was pointing
+
+See https://bugs.gentoo.org/show_bug.cgi?id=339355 for details
+---
+ src/applications/identity/identity.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/applications/identity/identity.c b/src/applications/identity/identity.c
+index 063c463..6d3cf65 100644
+--- a/src/applications/identity/identity.c
++++ b/src/applications/identity/identity.c
+@@ -423,7 +423,7 @@ getPeerIdentity (const GNUNET_RSA_PublicKey * pubKey,
+ GNUNET_PeerIdentity * result)
+ {
+ if (pubKey == NULL)
+- memset (&result, 0, sizeof (GNUNET_PeerIdentity));
++ memset (result, 0, sizeof (GNUNET_PeerIdentity));
+ else
+ GNUNET_hash (pubKey, sizeof (GNUNET_RSA_PublicKey), &result->hashPubKey);
+ }
+--
+1.7.3.4
+
diff --git a/net-p2p/gnunet/gnunet-0.8.1-r1.ebuild b/net-p2p/gnunet/gnunet-0.8.1-r2.ebuild
index dbe0c707c732..5651181543b7 100644
--- a/net-p2p/gnunet/gnunet-0.8.1-r1.ebuild
+++ b/net-p2p/gnunet/gnunet-0.8.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.8.1-r1.ebuild,v 1.1 2011/01/14 00:52:11 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.8.1-r2.ebuild,v 1.1 2011/01/18 23:58:04 sochotnicky Exp $
EAPI=2
@@ -13,7 +13,7 @@ SRC_URI="http://gnunet.org/download/GNUnet-${PV}.tar.gz"
#tests don't work
RESTRICT="test"
-IUSE="nls +sqlite mysql c-ares adns +setup dialog gtk qt esmtp microhttpd"
+IUSE="nls +sqlite mysql ares adns +setup ncurses gtk qt4 smtp microhttpd"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
LICENSE="GPL-2"
SLOT="0"
@@ -28,14 +28,14 @@ DEPEND=">=dev-libs/libgcrypt-1.2.0
mysql? ( >=virtual/mysql-4.0 )
!sqlite? ( !mysql? ( >=dev-db/sqlite-3.0.8 ) )
setup? ( >=dev-scheme/guile-1.8.0
- dialog? ( dev-util/dialog )
+ ncurses? ( dev-util/dialog )
gtk? ( >=x11-libs/gtk+-2.6.10
gnome-base/libglade )
- qt? ( x11-libs/qt-gui )
+ qt4? ( x11-libs/qt-gui )
)
adns? ( net-libs/adns )
- c-ares? ( net-dns/c-ares )
- esmtp? ( net-libs/libesmtp )
+ ares? ( net-dns/c-ares )
+ smtp? ( net-libs/libesmtp )
!ppc? ( !ppc64? ( !sparc? ( microhttpd? ( net-libs/libmicrohttpd ) ) ) )
nls? ( sys-devel/gettext )"
@@ -47,9 +47,9 @@ pkg_preinst() {
}
src_prepare() {
- if ! use setup && ( use dialog || use gtk || use qt ); then
+ if ! use setup && ( use ncurses || use gtk || use qt4 ); then
ewarn
- ewarn "You chose NOT to install setup utility. Ignoring setup frontends (dialog, gtk, qt)."
+ ewarn "You chose NOT to install setup utility. Ignoring setup frontends (ncurses, gtk, qt4)."
ewarn
fi
@@ -74,6 +74,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PV}-asneeded.patch
epatch "${FILESDIR}"/${PV}-parallel-build.patch
+ epatch "${FILESDIR}"/${PV}-Fix-buffer-overflow.patch
eautoreconf
}
@@ -90,17 +91,17 @@ src_configure() {
fi
fi
- # doesn't work for --with-qt so use_with is unusable
- use qt || myconf="${myconf} --without-qt"
+ # doesn't work for --with-qt4 so use_with is unusable
+ use qt4 || myconf="${myconf} --without-qt"
+ use mysql || myconf="${myconf} --without-mysql"
econf \
$(use_enable nls) \
- $(use_with mysql) \
$(use_with gtk x) \
- $(use_with dialog) \
+ $(use_with ncurses dialog) \
$(use_with adns) \
- $(use_with c-ares) \
- $(use_with esmtp) \
+ $(use_with ares c-ares) \
+ $(use_with smtp esmtp) \
$(use_with microhttpd) \
$(use_with setup guile) \
${myconf} || die "econf failed"
diff --git a/net-p2p/gnunet/metadata.xml b/net-p2p/gnunet/metadata.xml
index 0072b675e988..3db195b8358c 100644
--- a/net-p2p/gnunet/metadata.xml
+++ b/net-p2p/gnunet/metadata.xml
@@ -4,13 +4,13 @@
<herd>net-p2p</herd>
<longdescription>GNUnet is a framework for secure peer-to-peer networking that does not use any centralized or otherwise trusted services</longdescription>
<use>
- <flag name="c-ares">enable asynchronous dns support through c-ares library</flag>
- <flag name="esmtp">enable SMTP support</flag>
+ <flag name="ares">enable asynchronous dns support through <pkg>net-dns/c-ares</pkg> library</flag>
+ <flag name="smtp">enable SMTP support using <pkg>net-libs/libesmtp</pkg></flag>
<flag name="microhttpd">enable embedded http server support</flag>
<flag name="setup">enable setup wizard</flag>
- <flag name="dialog">enable ncurses dialog setup wizard</flag>
+ <flag name="ncurses">enable ncurses setup wizard using <pkg>dev-util/dialog</pkg></flag>
<flag name="gtk">enable gtk setup wizard</flag>
- <flag name="qt">enable qt setup wizard</flag>
+ <flag name="qt4">enable qt4 setup wizard</flag>
<flag name="sqlite">enable sqlite database backend</flag>
<flag name="mysql">enable mysql database backend</flag>
</use>