summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-23 09:44:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-23 09:44:31 +0000
commit5f3ca5d8e9562840165f5c71d952802ac11d000c (patch)
treea3f1b3bb3d997c4b97977b64997b69b9ea41e1ab /net-p2p
parentVersion bump (new versioning scheme). (diff)
downloadgentoo-2-5f3ca5d8e9562840165f5c71d952802ac11d000c.tar.gz
gentoo-2-5f3ca5d8e9562840165f5c71d952802ac11d000c.tar.bz2
gentoo-2-5f3ca5d8e9562840165f5c71d952802ac11d000c.zip
Version bump.
(Portage version: 2.1_rc2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.5.33
-rw-r--r--net-p2p/rtorrent/rtorrent-0.5.3.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index aa1464da8663..6599644e70e5 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.45 2006/05/19 16:46:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.46 2006/05/23 09:44:31 flameeyes Exp $
+
+*rtorrent-0.5.3 (23 May 2006)
+
+ 23 May 2006; Diego Pettenò <flameeyes@gentoo.org> +rtorrent-0.5.3.ebuild:
+ Version bump.
*rtorrent-0.5.2 (19 May 2006)
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.5.3 b/net-p2p/rtorrent/files/digest-rtorrent-0.5.3
new file mode 100644
index 000000000000..3de834d899d4
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.5.3
@@ -0,0 +1,3 @@
+MD5 5fe1fad0fe72ccb99d83d09a566f8732 rtorrent-0.5.3.tar.gz 413437
+RMD160 31fa79315389acea557b201f5d389fe882957df9 rtorrent-0.5.3.tar.gz 413437
+SHA256 3848813275416a05cb209b891683c07271b0a47bd0f9fc877d3fa0cf58d0f051 rtorrent-0.5.3.tar.gz 413437
diff --git a/net-p2p/rtorrent/rtorrent-0.5.3.ebuild b/net-p2p/rtorrent/rtorrent-0.5.3.ebuild
new file mode 100644
index 000000000000..cac0b0d2aab4
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.5.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.5.3.ebuild,v 1.1 2006/05/23 09:44:31 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=net-libs/libtorrent-0.9.0
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ replace-flags -Os -O2
+
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}