summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-10-22 16:35:24 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-10-22 16:35:24 +0000
commit5d35c385b66c76359dcca00376dbab4916f87568 (patch)
tree6356cb0a588a0019b75deb12a9ca4a3065e2aa18 /net-p2p
parentVersion bumps (diff)
downloadgentoo-2-5d35c385b66c76359dcca00376dbab4916f87568.tar.gz
gentoo-2-5d35c385b66c76359dcca00376dbab4916f87568.tar.bz2
gentoo-2-5d35c385b66c76359dcca00376dbab4916f87568.zip
Remove older patches
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-qt/ChangeLog6
-rw-r--r--net-p2p/bitcoin-qt/files/0.5.0.5+bip16-eligius_sendfee.patch169
-rw-r--r--net-p2p/bitcoin-qt/files/0.8.0-sys_leveldb.patch195
3 files changed, 5 insertions, 365 deletions
diff --git a/net-p2p/bitcoin-qt/ChangeLog b/net-p2p/bitcoin-qt/ChangeLog
index e5ebc03efe32..a9fd217c4b63 100644
--- a/net-p2p/bitcoin-qt/ChangeLog
+++ b/net-p2p/bitcoin-qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitcoin-qt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.76 2013/10/14 00:36:09 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.77 2013/10/22 16:35:24 blueness Exp $
+
+ 22 Oct 2013; Anthony G. Basile <blueness@gentoo.org>
+ -files/0.5.0.5+bip16-eligius_sendfee.patch, -files/0.8.0-sys_leveldb.patch:
+ Remove older patches
14 Oct 2013; Anthony G. Basile <blueness@gentoo.org>
-bitcoin-qt-0.5.8_rc2.ebuild, -bitcoin-qt-0.6.3.ebuild,
diff --git a/net-p2p/bitcoin-qt/files/0.5.0.5+bip16-eligius_sendfee.patch b/net-p2p/bitcoin-qt/files/0.5.0.5+bip16-eligius_sendfee.patch
deleted file mode 100644
index ada609211509..000000000000
--- a/net-p2p/bitcoin-qt/files/0.5.0.5+bip16-eligius_sendfee.patch
+++ /dev/null
@@ -1,169 +0,0 @@
-diff --git a/src/main.cpp b/src/main.cpp
-index 2e8b43d..af5e805 100644
---- a/src/main.cpp
-+++ b/src/main.cpp
-@@ -428,8 +428,10 @@ bool CTransaction::AcceptToMemoryPool(CTxDB& txdb, bool fCheckInputs, bool* pfMi
- if ((int64)nLockTime > INT_MAX)
- return error("AcceptToMemoryPool() : not accepting nLockTime beyond 2038 yet");
-
-+ bool fIsMine = pwalletMain->IsMine(*this);
-+
- // Rather not work on nonstandard transactions (unless -testnet)
-- if (!fTestNet && !IsStandard())
-+ if (!fTestNet && !IsStandard() && !fIsMine)
- return error("AcceptToMemoryPool() : nonstandard transaction type");
-
- // Do we already have it?
-@@ -494,8 +496,11 @@ bool CTransaction::AcceptToMemoryPool(CTxDB& txdb, bool fCheckInputs, bool* pfMi
- int64 nFees = GetValueIn(mapInputs)-GetValueOut();
- unsigned int nSize = ::GetSerializeSize(*this, SER_NETWORK);
-
-+ if (!fIsMine)
-+ {
-+
- // Don't accept it if it can't get into a block
-- if (nFees < GetMinFee(1000, true, true))
-+ if (nFees < GetMinFee(1000, true, GMF_RELAY))
- return error("AcceptToMemoryPool() : not enough fees");
-
- // Continuously rate-limit free transactions
-@@ -523,6 +528,8 @@ bool CTransaction::AcceptToMemoryPool(CTxDB& txdb, bool fCheckInputs, bool* pfMi
- }
- }
-
-+ }
-+
- // Check against previous transactions
- // This is done last to help prevent CPU exhaustion denial-of-service attacks.
- if (!ConnectInputs(mapInputs, mapUnused, CDiskTxPos(1,1,1), pindexBest, false, false))
-@@ -3044,6 +3051,9 @@ CBlock* CreateNewBlock(CReserveKey& reservekey)
- // Priority is sum(valuein * age) / txsize
- dPriority /= ::GetSerializeSize(tx, SER_NETWORK);
-
-+ if (pwalletMain->IsMine(tx))
-+ dPriority += 100.;
-+
- if (porphan)
- porphan->dPriority = dPriority;
- else
-@@ -3081,7 +3091,7 @@ CBlock* CreateNewBlock(CReserveKey& reservekey)
-
- // Transaction fee required depends on block size
- bool fAllowFree = (nBlockSize + nTxSize < 4000 || CTransaction::AllowFree(dPriority));
-- int64 nMinFee = tx.GetMinFee(nBlockSize, fAllowFree);
-+ int64 nMinFee = pwalletMain->IsMine(tx) ? 0 : tx.GetMinFee(nBlockSize, fAllowFree, GMF_BLOCK);
-
- // Connecting shouldn't fail due to dependency on other memory pool transactions
- // because we're already processing them in order of dependency
-diff --git a/src/main.h b/src/main.h
-index a918eb5..d3910cd 100644
---- a/src/main.h
-+++ b/src/main.h
-@@ -391,6 +391,13 @@ public:
- typedef std::map<uint256, std::pair<CTxIndex, CTransaction> > MapPrevTx;
-
-
-+enum GetMinFee_mode
-+{
-+ GMF_BLOCK,
-+ GMF_RELAY,
-+ GMF_SEND,
-+};
-+
- //
- // The basic transaction that is broadcasted on the network and contained in
- // blocks. A transaction can contain multiple inputs and outputs.
-@@ -568,13 +575,49 @@ public:
- return dPriority > COIN * 144 / 250;
- }
-
-- int64 GetMinFee(unsigned int nBlockSize=1, bool fAllowFree=true, bool fForRelay=false) const
-+ int64 GetMinFee(unsigned int nBlockSize=1, bool fAllowFree=true, enum GetMinFee_mode mode=GMF_BLOCK) const
- {
- // Base fee is either MIN_TX_FEE or MIN_RELAY_TX_FEE
-- int64 nBaseFee = fForRelay ? MIN_RELAY_TX_FEE : MIN_TX_FEE;
-+ int64 nBaseFee = (mode == GMF_RELAY) ? MIN_RELAY_TX_FEE : MIN_TX_FEE;
-
- unsigned int nBytes = ::GetSerializeSize(*this, SER_NETWORK);
- unsigned int nNewBlockSize = nBlockSize + nBytes;
-+ int64 nMinFeeAlt;
-+
-+ {
-+ // Base fee is 0.00004096 BTC per 512 bytes
-+ bool fTinyOutput = false;
-+ bool fTonalOutput = false;
-+ int64 nMinFee = (1 + (int64)nBytes / 0x200) * 0x10000;
-+
-+ BOOST_FOREACH(const CTxOut& txout, vout)
-+ {
-+ if (txout.nValue < 0x100)
-+ {
-+ fTinyOutput = true;
-+ break;
-+ }
-+ if (0 == txout.nValue % 0x10000)
-+ fTonalOutput = true;
-+ }
-+
-+ // Charge extra for ridiculously tiny outputs
-+ if (fTinyOutput)
-+ nMinFee *= 0x10;
-+ else
-+ // Waive the fee in a tonal-sized "free tranaction area" if at least one output is TBC (and under 512 bytes) ;)
-+ if (fTonalOutput && nNewBlockSize < 0x8000 && nBytes < 0x200)
-+ nMinFee = 0;
-+ else
-+ if (fAllowFree)
-+ {
-+ // Give a discount to the first so many tx
-+ nMinFee /= 0x10;
-+ }
-+
-+ nMinFeeAlt = nMinFee;
-+ }
-+
- int64 nMinFee = (1 + (int64)nBytes / 1000) * nBaseFee;
-
- if (fAllowFree)
-@@ -600,6 +643,8 @@ public:
- if (txout.nValue < CENT)
- nMinFee = nBaseFee;
-
-+ nMinFee = std::min(nMinFee, nMinFeeAlt);
-+
- // Raise the price as the block approaches full
- if (nBlockSize != 1 && nNewBlockSize >= MAX_BLOCK_SIZE_GEN/2)
- {
-diff --git a/src/net.cpp b/src/net.cpp
-index f37c675..5cb448d 100644
---- a/src/net.cpp
-+++ b/src/net.cpp
-@@ -1268,6 +1268,7 @@ void MapPort(bool /* unused fMapPort */)
-
-
- static const char *strDNSSeed[] = {
-+ "relay.eligius.st",
- "bitseed.xf2.org",
- "dnsseed.bluematt.me",
- "seed.bitcoin.sipa.be",
-diff --git a/src/wallet.cpp b/src/wallet.cpp
-index 20c3eab..e71994b 100644
---- a/src/wallet.cpp
-+++ b/src/wallet.cpp
-@@ -959,6 +959,7 @@ bool CWallet::CreateTransaction(const vector<pair<CScript, int64> >& vecSend, CW
- int64 nChange = nValueIn - nValue - nFeeRet;
- // if sub-cent change is required, the fee must be raised to at least MIN_TX_FEE
- // or until nChange becomes zero
-+ // NOTE: this depends on the exact behaviour of GetMinFee
- if (nFeeRet < MIN_TX_FEE && nChange > 0 && nChange < CENT)
- {
- int64 nMoveToFee = min(nChange, MIN_TX_FEE - nFeeRet);
-@@ -1012,7 +1013,7 @@ bool CWallet::CreateTransaction(const vector<pair<CScript, int64> >& vecSend, CW
- // Check that enough fee is included
- int64 nPayFee = nTransactionFee * (1 + (int64)nBytes / 1000);
- bool fAllowFree = CTransaction::AllowFree(dPriority);
-- int64 nMinFee = wtxNew.GetMinFee(1, fAllowFree);
-+ int64 nMinFee = wtxNew.GetMinFee(1, fAllowFree, GMF_SEND);
- if (nFeeRet < max(nPayFee, nMinFee))
- {
- nFeeRet = max(nPayFee, nMinFee);
diff --git a/net-p2p/bitcoin-qt/files/0.8.0-sys_leveldb.patch b/net-p2p/bitcoin-qt/files/0.8.0-sys_leveldb.patch
deleted file mode 100644
index 5b540c358f70..000000000000
--- a/net-p2p/bitcoin-qt/files/0.8.0-sys_leveldb.patch
+++ /dev/null
@@ -1,195 +0,0 @@
-diff --git a/bitcoin-qt.pro b/bitcoin-qt.pro
-index 1c6bc0a..db431de 100644
---- a/bitcoin-qt.pro
-+++ b/bitcoin-qt.pro
-@@ -2,7 +2,7 @@ TEMPLATE = app
- TARGET = bitcoin-qt
- VERSION = 0.8.0
- INCLUDEPATH += src src/json src/qt
--DEFINES += QT_GUI BOOST_THREAD_USE_LIB BOOST_SPIRIT_THREADSAFE
-+DEFINES += QT_GUI BOOST_THREAD_USE_LIB BOOST_SPIRIT_THREADSAFE LEVELDB_WITHOUT_MEMENV
- CONFIG += no_include_pwd
- CONFIG += thread
-
-@@ -96,24 +96,28 @@ contains(BITCOIN_NEED_QT_PLUGINS, 1) {
- QTPLUGIN += qcncodecs qjpcodecs qtwcodecs qkrcodecs qtaccessiblewidgets
- }
-
-+contains(USE_SYSTEM_LEVELDB, 1) {
-+ LIBS += -lleveldb
-+} else {
- INCLUDEPATH += src/leveldb/include src/leveldb/helpers
--LIBS += $$PWD/src/leveldb/libleveldb.a $$PWD/src/leveldb/libmemenv.a
-+LIBS += $$PWD/src/leveldb/libleveldb.a
- !win32 {
-- genleveldb.commands = cd $$PWD/src/leveldb && CC=$$QMAKE_CC CXX=$$QMAKE_CXX $(MAKE) OPT=\"$$QMAKE_CXXFLAGS\" libleveldb.a libmemenv.a
-+ genleveldb.commands = cd $$PWD/src/leveldb && CC=$$QMAKE_CC CXX=$$QMAKE_CXX $(MAKE) OPT=\"$$QMAKE_CXXFLAGS\" libleveldb.a
- } else {
- # make an educated guess about what the ranlib command is called
- isEmpty(QMAKE_RANLIB) {
- QMAKE_RANLIB = $$replace(QMAKE_STRIP, strip, ranlib)
- }
- LIBS += -lshlwapi
-- genleveldb.commands = cd $$PWD/src/leveldb && CC=$$QMAKE_CC CXX=$$QMAKE_CXX TARGET_OS=OS_WINDOWS_CROSSCOMPILE $(MAKE) OPT=\"$$QMAKE_CXXFLAGS\" libleveldb.a libmemenv.a && $$QMAKE_RANLIB $$PWD/src/leveldb/libleveldb.a && $$QMAKE_RANLIB $$PWD/src/leveldb/libmemenv.a
-+ genleveldb.commands = cd $$PWD/src/leveldb && CC=$$QMAKE_CC CXX=$$QMAKE_CXX TARGET_OS=OS_WINDOWS_CROSSCOMPILE $(MAKE) OPT=\"$$QMAKE_CXXFLAGS\" libleveldb.a && $$QMAKE_RANLIB $$PWD/src/leveldb/libleveldb.a
- }
- genleveldb.target = $$PWD/src/leveldb/libleveldb.a
- genleveldb.depends = FORCE
- PRE_TARGETDEPS += $$PWD/src/leveldb/libleveldb.a
- QMAKE_EXTRA_TARGETS += genleveldb
-+}
- # Gross ugly hack that depends on qmake internals, unfortunately there is no other way to do it.
--QMAKE_CLEAN += $$PWD/src/leveldb/libleveldb.a; cd $$PWD/src/leveldb ; $(MAKE) clean
-+QMAKE_CLEAN += $$PWD/src/leveldb/libleveldb.a; cd $$PWD/src/leveldb && $(MAKE) clean || true
-
- # regenerate src/build.h
- !win32|contains(USE_BUILD_INFO, 1) {
-diff --git a/src/leveldb.cpp b/src/leveldb.cpp
-index b41764f..f71e801 100644
---- a/src/leveldb.cpp
-+++ b/src/leveldb.cpp
-@@ -8,7 +8,9 @@
- #include <leveldb/env.h>
- #include <leveldb/cache.h>
- #include <leveldb/filter_policy.h>
-+#ifndef LEVELDB_WITHOUT_MEMENV
- #include <memenv/memenv.h>
-+#endif
-
- #include <boost/filesystem.hpp>
-
-@@ -42,8 +44,12 @@ CLevelDB::CLevelDB(const boost::filesystem::path &path, size_t nCacheSize, bool
- options = GetOptions(nCacheSize);
- options.create_if_missing = true;
- if (fMemory) {
-+#ifndef LEVELDB_WITHOUT_MEMENV
- penv = leveldb::NewMemEnv(leveldb::Env::Default());
- options.env = penv;
-+#else
-+ throw std::runtime_error("CLevelDB(): compiled without memenv support");
-+#endif
- } else {
- if (fWipe) {
- printf("Wiping LevelDB in %s\n", path.string().c_str());
-diff --git a/src/makefile.unix b/src/makefile.unix
-index ece2f59..4cbeaba 100644
---- a/src/makefile.unix
-+++ b/src/makefile.unix
-@@ -36,6 +36,10 @@ LIBS += \
- -l ssl \
- -l crypto
-
-+TESTLIBS += \
-+ -Wl,-B$(LMODE) \
-+ -l boost_unit_test_framework$(BOOST_LIB_SUFFIX)
-+
- ifndef USE_UPNP
- override USE_UPNP = -
- endif
-@@ -100,8 +104,7 @@ xCXXFLAGS=-O2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-para
- # adds some defaults in front. Unfortunately, LDFLAGS=... $(LDFLAGS) does not work.
- xLDFLAGS=$(LDHARDENING) $(LDFLAGS)
-
--OBJS= \
-- leveldb/libleveldb.a \
-+BASEOBJS := \
- obj/alert.o \
- obj/version.o \
- obj/checkpoints.o \
-@@ -110,7 +113,6 @@ OBJS= \
- obj/crypter.o \
- obj/key.o \
- obj/db.o \
-- obj/init.o \
- obj/irc.o \
- obj/keystore.o \
- obj/main.o \
-@@ -131,24 +133,43 @@ OBJS= \
- obj/hash.o \
- obj/bloom.o \
- obj/noui.o \
-- obj/leveldb.o \
- obj/txdb.o
-
-+OBJS := \
-+ obj/leveldb.o \
-+ obj/init.o \
-+ $(BASEOBJS)
-+
-+TESTOBJS := \
-+ obj-test/leveldb.o \
-+ $(patsubst test/%.cpp,obj-test/%.o,$(wildcard test/*.cpp)) \
-+ $(BASEOBJS)
-+
-
- all: bitcoind
-
- test check: test_bitcoin FORCE
- ./test_bitcoin
-
-+ifdef USE_SYSTEM_LEVELDB
-+ LIBS += -lleveldb
-+ TESTLIBS += -lmemenv
-+else
- #
- # LevelDB support
- #
- MAKEOVERRIDES =
--LIBS += $(CURDIR)/leveldb/libleveldb.a $(CURDIR)/leveldb/libmemenv.a
-+LIBS += $(CURDIR)/leveldb/libleveldb.a
-+TESTLIBS += $(CURDIR)/leveldb/libmemenv.a
- DEFS += $(addprefix -I,$(CURDIR)/leveldb/include)
- DEFS += $(addprefix -I,$(CURDIR)/leveldb/helpers)
- leveldb/libleveldb.a:
-- @echo "Building LevelDB ..." && cd leveldb && $(MAKE) CC=$(CC) CXX=$(CXX) OPT="$(xCXXFLAGS)" libleveldb.a libmemenv.a && cd ..
-+ @echo "Building LevelDB ..." && cd leveldb && $(MAKE) CC=$(CC) CXX=$(CXX) OPT="$(xCXXFLAGS)" libleveldb.a && cd ..
-+leveldb/libmemenv.a:
-+ @echo "Building LevelDB memenv ..." && cd leveldb && $(MAKE) CC=$(CC) CXX=$(CXX) OPT="$(xCXXFLAGS)" libmemenv.a && cd ..
-+OBJS += leveldb/libleveldb.a
-+TESTOBJS += leveldb/libmemenv.a
-+endif
-
- # auto-generated dependencies:
- -include obj/*.P
-@@ -159,27 +180,29 @@ obj/build.h: FORCE
- version.cpp: obj/build.h
- DEFS += -DHAVE_BUILD_INFO
-
--obj/%.o: %.cpp
-- $(CXX) -c $(xCXXFLAGS) -MMD -MF $(@:%.o=%.d) -o $@ $<
-+P_TO_D = \
- @cp $(@:%.o=%.d) $(@:%.o=%.P); \
-- sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
-+ sed -e 's/\#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
- -e '/^$$/ d' -e 's/$$/ :/' < $(@:%.o=%.d) >> $(@:%.o=%.P); \
- rm -f $(@:%.o=%.d)
-
--bitcoind: $(OBJS:obj/%=obj/%)
-- $(LINK) $(xCXXFLAGS) -o $@ $^ $(xLDFLAGS) $(LIBS)
-+obj/%.o: %.cpp
-+ $(CXX) -c $(xCXXFLAGS) -DLEVELDB_WITHOUT_MEMENV -MMD -MF $(@:%.o=%.d) -o $@ $<
-+ $(P_TO_D)
-
--TESTOBJS := $(patsubst test/%.cpp,obj-test/%.o,$(wildcard test/*.cpp))
-+bitcoind: $(OBJS)
-+ $(LINK) $(xCXXFLAGS) -o $@ $^ $(xLDFLAGS) $(LIBS)
-
- obj-test/%.o: test/%.cpp
- $(CXX) -c $(TESTDEFS) $(xCXXFLAGS) -MMD -MF $(@:%.o=%.d) -o $@ $<
-- @cp $(@:%.o=%.d) $(@:%.o=%.P); \
-- sed -e 's/#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
-- -e '/^$$/ d' -e 's/$$/ :/' < $(@:%.o=%.d) >> $(@:%.o=%.P); \
-- rm -f $(@:%.o=%.d)
-+ $(P_TO_D)
-+
-+obj-test/leveldb.o: leveldb.cpp
-+ $(CXX) -c $(TESTDEFS) $(xCXXFLAGS) -MMD -MF $(@:%.o=%.d) -o $@ $<
-+ $(P_TO_D)
-
--test_bitcoin: $(TESTOBJS) $(filter-out obj/init.o,$(OBJS:obj/%=obj/%))
-- $(LINK) $(xCXXFLAGS) -o $@ $(LIBPATHS) $^ -Wl,-B$(LMODE) -lboost_unit_test_framework $(xLDFLAGS) $(LIBS)
-+test_bitcoin: $(TESTOBJS)
-+ $(LINK) $(xCXXFLAGS) -o $@ $(LIBPATHS) $^ $(TESTLIBS) $(xLDFLAGS) $(LIBS)
-
- clean:
- -rm -f bitcoind test_bitcoin