summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-04-19 15:49:36 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-04-19 15:49:36 +0000
commit5954d4356183e098e597ed3fb2f24e00089c26e9 (patch)
treef1dcb6df0709831fbbf67834ea71f5588ea8f142 /net-p2p
parentFix missing depend (and building with) libical-0.44 wrt #316013 by Andrew Fri... (diff)
downloadgentoo-2-5954d4356183e098e597ed3fb2f24e00089c26e9.tar.gz
gentoo-2-5954d4356183e098e597ed3fb2f24e00089c26e9.tar.bz2
gentoo-2-5954d4356183e098e597ed3fb2f24e00089c26e9.zip
Version bump wrt bug #316115
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.6.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 3be8cc403838..b6806378beb9 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.81 2010/04/12 19:14:05 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.82 2010/04/19 15:49:36 hwoarang Exp $
+
+*qbittorrent-2.2.6 (19 Apr 2010)
+
+ 19 Apr 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qbittorrent-2.2.6.ebuild:
+ Version bump wrt bug #316115
12 Apr 2010; Ben de Groot <yngwin@gentoo.org> -qbittorrent-2.1.2.ebuild:
Remove obsolete version. Newer ebuilds have several fixes.
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.6.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.6.ebuild
new file mode 100644
index 000000000000..2109d8480d82
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.2.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.6.ebuild,v 1.1 2010/04/19 15:49:36 hwoarang Exp $
+
+EAPI="2"
+inherit confutils qt4-r2 versionator
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ >=dev-libs/boost-1.34.1"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ >=dev-lang/python-2.3
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}