summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-11-22 02:15:38 +0000
committerJon Hood <squinky86@gentoo.org>2006-11-22 02:15:38 +0000
commit538b9b7c4262431b1b60d06369736d20fe1fc225 (patch)
treed3d9f7b7098ea684f35b3caaca4bcb2c5c2ab6af /net-p2p
parentVersion bump, bug #143427. Remove old version. (diff)
downloadgentoo-2-538b9b7c4262431b1b60d06369736d20fe1fc225.tar.gz
gentoo-2-538b9b7c4262431b1b60d06369736d20fe1fc225.tar.bz2
gentoo-2-538b9b7c4262431b1b60d06369736d20fe1fc225.zip
Version bump. Remove old version. Bug #151105.
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittornado/ChangeLog8
-rw-r--r--net-p2p/bittornado/bittornado-0.3.17.ebuild74
-rw-r--r--net-p2p/bittornado/files/digest-bittornado-0.3.173
3 files changed, 84 insertions, 1 deletions
diff --git a/net-p2p/bittornado/ChangeLog b/net-p2p/bittornado/ChangeLog
index d86b9bc57152..a5fbbb5af146 100644
--- a/net-p2p/bittornado/ChangeLog
+++ b/net-p2p/bittornado/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bittornado
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.52 2006/10/20 23:37:14 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.53 2006/11/22 02:15:38 squinky86 Exp $
+
+*bittornado-0.3.17 (22 Nov 2006)
+
+ 22 Nov 2006; Jon Hood <squinky86@gentoo.org> -bittornado-0.3.12.ebuild,
+ +bittornado-0.3.17.ebuild:
+ Version bump. Remove old version. Bug #151105.
20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
bittornado-0.3.15.ebuild:
diff --git a/net-p2p/bittornado/bittornado-0.3.17.ebuild b/net-p2p/bittornado/bittornado-0.3.17.ebuild
new file mode 100644
index 000000000000..76f6eec9a7fd
--- /dev/null
+++ b/net-p2p/bittornado/bittornado-0.3.17.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.17.ebuild,v 1.1 2006/11/22 02:15:38 squinky86 Exp $
+
+inherit distutils eutils
+
+MY_PN="BitTornado"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="TheShad0w's experimental BitTorrent client"
+HOMEPAGE="http://www.bittornado.com/"
+SRC_URI="http://download2.bittornado.com/download/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk"
+
+RDEPEND="gtk? ( >=dev-python/wxpython-2.4 )
+ >=dev-lang/python-2.1
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ >=sys-apps/sed-4.0.5"
+PROVIDE="virtual/bittorrent"
+
+S="${WORKDIR}/${MY_PN}-CVS"
+PIXMAPLOC="/usr/share/pixmaps/bittornado"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fixes wrong icons path
+ sed -i "s:os.path.abspath(os.path.dirname(os.path.realpath(sys.argv\[0\]))):\"${PIXMAPLOC}/\":" btdownloadgui.py
+ # fixes a bug with < wxpython-2.5 which is not yet available in portage
+ epatch ${FILESDIR}/${PN}-wxpython-pre2.5-fix.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir /etc
+ cp -pPR ${ROOT}/etc/mailcap ${D}/etc/
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use gtk; then
+ dodir ${PIXMAPLOC}
+ insinto ${PIXMAPLOC}
+ doins icons/*.ico icons/*.gif
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ rm ${D}/usr/bin/*gui.py
+ fi
+ insinto /usr/share/bittorrent
+ doins ${FILESDIR}/favicon.ico
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/bttrack.conf bttrack
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bttrack.rc bttrack
+}
+
diff --git a/net-p2p/bittornado/files/digest-bittornado-0.3.17 b/net-p2p/bittornado/files/digest-bittornado-0.3.17
new file mode 100644
index 000000000000..718dbf9e9517
--- /dev/null
+++ b/net-p2p/bittornado/files/digest-bittornado-0.3.17
@@ -0,0 +1,3 @@
+MD5 5b74b21df4fc521e7eea3843defd976d BitTornado-0.3.17.tar.gz 194718
+RMD160 2ae8f00496263ee8e1f1a21b7d4a2124a61082f8 BitTornado-0.3.17.tar.gz 194718
+SHA256 67ea8a64bc3867d9dbbe9dc8f4c15bb9b605f4bf246aeb1782a44b861de50294 BitTornado-0.3.17.tar.gz 194718