summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-31 07:29:27 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-31 07:29:27 +0000
commit51432a15c668b382564096ce1957ff9facbecd66 (patch)
tree53c96fdd4e49cd016e37e41cc7151b323eaa1f2c /net-p2p
parentChanged to use USE of readline, zlib and pam. (diff)
downloadgentoo-2-51432a15c668b382564096ce1957ff9facbecd66.tar.gz
gentoo-2-51432a15c668b382564096ce1957ff9facbecd66.tar.bz2
gentoo-2-51432a15c668b382564096ce1957ff9facbecd66.zip
Version bump
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/dclib/ChangeLog7
-rw-r--r--net-p2p/dclib/dclib-0.2.8.ebuild33
-rw-r--r--net-p2p/dclib/files/dclib-0.2.8-gcc.patch10
-rw-r--r--net-p2p/dclib/files/digest-dclib-0.2.81
-rw-r--r--net-p2p/qt-dcgui/ChangeLog7
-rw-r--r--net-p2p/qt-dcgui/files/digest-qt-dcgui-0.2.81
-rw-r--r--net-p2p/qt-dcgui/qt-dcgui-0.2.8.ebuild38
7 files changed, 95 insertions, 2 deletions
diff --git a/net-p2p/dclib/ChangeLog b/net-p2p/dclib/ChangeLog
index 2dce113e4341..22739472e239 100644
--- a/net-p2p/dclib/ChangeLog
+++ b/net-p2p/dclib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/dclib
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/ChangeLog,v 1.19 2003/03/14 17:04:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/ChangeLog,v 1.20 2003/03/31 07:29:27 aliz Exp $
+
+*dclib-0.2.8 (31 Mar 2003)
+
+ 31 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> dclib-0.2.8.ebuild :
+ Version bump.
*dclib-0.2.7 (14 Mar 2003)
diff --git a/net-p2p/dclib/dclib-0.2.8.ebuild b/net-p2p/dclib/dclib-0.2.8.ebuild
new file mode 100644
index 000000000000..ba72617c8171
--- /dev/null
+++ b/net-p2p/dclib/dclib-0.2.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/dclib-0.2.8.ebuild,v 1.1 2003/03/31 07:29:27 aliz Exp $
+
+inherit gcc eutils
+
+DESCRIPTION="Library for the Qt client for DirectConnect"
+HOMEPAGE="http://dc.ketelhot.de/"
+SRC_URI="http://download.berlios.de/dcgui/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=sys-apps/bzip2-1.0.2
+ >=dev-libs/libxml2-2.4.22"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ [ `gcc-major-version` == 2 ] && epatch ${FILESDIR}/${P}-gcc2.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}
diff --git a/net-p2p/dclib/files/dclib-0.2.8-gcc.patch b/net-p2p/dclib/files/dclib-0.2.8-gcc.patch
new file mode 100644
index 000000000000..9554a2d050f0
--- /dev/null
+++ b/net-p2p/dclib/files/dclib-0.2.8-gcc.patch
@@ -0,0 +1,10 @@
+--- dclib/cthread.cpp.orig 2002-12-19 19:01:57.000000000 -0500
++++ dclib/cthread.cpp 2002-12-19 19:02:09.000000000 -0500
+@@ -16,6 +16,7 @@
+ ***************************************************************************/
+
+ #include <stdio.h>
++#define __USE_POSIX199309
+ #include <time.h>
+ #include <errno.h>
+
diff --git a/net-p2p/dclib/files/digest-dclib-0.2.8 b/net-p2p/dclib/files/digest-dclib-0.2.8
new file mode 100644
index 000000000000..df29941dd102
--- /dev/null
+++ b/net-p2p/dclib/files/digest-dclib-0.2.8
@@ -0,0 +1 @@
+MD5 2ce612d764e773b30a6b69e07747adf4 dclib-0.2.8.tar.bz2 473633
diff --git a/net-p2p/qt-dcgui/ChangeLog b/net-p2p/qt-dcgui/ChangeLog
index 3a2d458c8ebb..d936a2612a05 100644
--- a/net-p2p/qt-dcgui/ChangeLog
+++ b/net-p2p/qt-dcgui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qt-dcgui
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qt-dcgui/ChangeLog,v 1.20 2003/03/20 13:30:27 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qt-dcgui/ChangeLog,v 1.21 2003/03/31 07:29:27 aliz Exp $
+
+*qt-dcgui-0.2.8 (31 Mar 2003)
+
+ 31 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> qt-dcgui-0.2.8.ebuild :
+ Version bump.
*qt-dcgui-0.2.7-r1 (20 Mar 2003)
diff --git a/net-p2p/qt-dcgui/files/digest-qt-dcgui-0.2.8 b/net-p2p/qt-dcgui/files/digest-qt-dcgui-0.2.8
new file mode 100644
index 000000000000..ef461489de3b
--- /dev/null
+++ b/net-p2p/qt-dcgui/files/digest-qt-dcgui-0.2.8
@@ -0,0 +1 @@
+MD5 5824987e2c99e36c593e4902d2f2f4ca dcgui-0.2.8.tar.bz2 689403
diff --git a/net-p2p/qt-dcgui/qt-dcgui-0.2.8.ebuild b/net-p2p/qt-dcgui/qt-dcgui-0.2.8.ebuild
new file mode 100644
index 000000000000..9fa8a32dc7d4
--- /dev/null
+++ b/net-p2p/qt-dcgui/qt-dcgui-0.2.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qt-dcgui/qt-dcgui-0.2.8.ebuild,v 1.1 2003/03/31 07:29:27 aliz Exp $
+
+inherit kde-functions
+need-qt 3
+
+IUSE="ssl"
+
+MY_P=${P/qt-/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Qt based client for DirectConnect"
+HOMEPAGE="http://dc.ketelhot.de/"
+SRC_URI="http://download.berlios.de/dcgui/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+
+newdepend ">=dev-libs/libxml2-2.4.22
+ =net-p2p/dclib-${PV}*
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ econf \
+ --with-gnu-ld \
+ `use_with ssl` \
+ --with-libdc=/usr \
+ --with-qt-dir=/usr/qt/3 \
+ || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}