summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2007-01-11 17:33:01 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2007-01-11 17:33:01 +0000
commit4f0268b791d3fb502018736c9ddf91855bbf0651 (patch)
treefad52f2da266f5b4ffe0953d6c1980a5296980b6 /net-p2p
parentStable on sparc (diff)
downloadgentoo-2-4f0268b791d3fb502018736c9ddf91855bbf0651.tar.gz
gentoo-2-4f0268b791d3fb502018736c9ddf91855bbf0651.tar.bz2
gentoo-2-4f0268b791d3fb502018736c9ddf91855bbf0651.zip
Bump to 2.1_rc1 and remove vulnerable version 2.1_beta1. Bug 161416
(Portage version: 2.1.2_rc4-r3)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog10
-rw-r--r--net-p2p/ktorrent/files/digest-ktorrent-2.1_rc13
-rw-r--r--net-p2p/ktorrent/ktorrent-2.1_rc1.ebuild48
3 files changed, 59 insertions, 2 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 9a4869c08255..e8115a7226be 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/ktorrent
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.30 2006/11/23 14:14:37 deathwing00 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.31 2007/01/11 17:33:01 masterdriverz Exp $
+
+*ktorrent-2.1_rc1 (11 Jan 2007)
+
+ 11 Jan 2007; Charlie Shepherd <masterdriverz@gentoo.org>
+ -ktorrent-2.1_beta1.ebuild, +ktorrent-2.1_rc1.ebuild:
+ Bump to 2.1_rc1 and remove vulnerable version 2.1_beta1. Bug 161416
*ktorrent-2.1_beta1 (23 Nov 2006)
diff --git a/net-p2p/ktorrent/files/digest-ktorrent-2.1_rc1 b/net-p2p/ktorrent/files/digest-ktorrent-2.1_rc1
new file mode 100644
index 000000000000..41804364eec6
--- /dev/null
+++ b/net-p2p/ktorrent/files/digest-ktorrent-2.1_rc1
@@ -0,0 +1,3 @@
+MD5 d9f1e71d311139061a8687357b6fc3b7 ktorrent-2.1rc1.tar.gz 3296618
+RMD160 517e975bb318ef7f432a2e6b68c25e0232ffb940 ktorrent-2.1rc1.tar.gz 3296618
+SHA256 0934cd564784bd89fe85d8b5a9909ceda41a3a84cc2831861d5e45b2d3ce0120 ktorrent-2.1rc1.tar.gz 3296618
diff --git a/net-p2p/ktorrent/ktorrent-2.1_rc1.ebuild b/net-p2p/ktorrent/ktorrent-2.1_rc1.ebuild
new file mode 100644
index 000000000000..1aacefb21c89
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-2.1_rc1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-2.1_rc1.ebuild,v 1.1 2007/01/11 17:33:01 masterdriverz Exp $
+
+inherit kde
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kdeenablefinal"
+
+DEPEND="dev-libs/gmp"
+
+need-kde 3.4
+
+LANGS="bg br ca cs cy da de el en_GB es et eu fr ga gl hu it ja km lt
+mk ms nb nl pa pl pt pt_BR ru rw sk sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${MY_P}/translations"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ rm -f ${S}/configure
+ sed -i -e "s:SUBDIRS=.*:SUBDIRS=${MAKE_LANGS}:" Makefile.am
+}
+
+
+src_compile(){
+ local myconf="--enable-knetwork"
+ kde_src_compile
+}
+