summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2010-04-12 21:16:21 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2010-04-12 21:16:21 +0000
commit483f638a015bc9374b50509552dcfa4aaac892f5 (patch)
tree5fbb76d6725abfe8f2d1b4ade5878d92201237b3 /net-p2p
parentClean up old revisions. (diff)
downloadgentoo-2-483f638a015bc9374b50509552dcfa4aaac892f5.tar.gz
gentoo-2-483f638a015bc9374b50509552dcfa4aaac892f5.tar.bz2
gentoo-2-483f638a015bc9374b50509552dcfa4aaac892f5.zip
Version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/ChangeLog8
-rw-r--r--net-p2p/deluge/deluge-1.2.3.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index dc034d5fe976..11e30a2874ba 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.145 2010/04/12 20:50:57 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.146 2010/04/12 21:16:21 sochotnicky Exp $
+
+*deluge-1.2.3 (12 Apr 2010)
+
+ 12 Apr 2010; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +deluge-1.2.3.ebuild:
+ Version bump
*deluge-1.2.2-r1 (12 Apr 2010)
diff --git a/net-p2p/deluge/deluge-1.2.3.ebuild b/net-p2p/deluge/deluge-1.2.3.ebuild
new file mode 100644
index 000000000000..c4d7a4489503
--- /dev/null
+++ b/net-p2p/deluge/deluge-1.2.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.2.3.ebuild,v 1.1 2010/04/12 21:16:21 sochotnicky Exp $
+
+EAPI="2"
+
+inherit eutils distutils flag-o-matic python
+
+DESCRIPTION="BitTorrent client with a client/server model."
+HOMEPAGE="http://deluge-torrent.org/"
+SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="gtk libnotify webinterface"
+
+DEPEND=">=virtual/python-2.5
+ || ( app-arch/xz-utils app-arch/lzma-utils )
+ >=net-libs/rb_libtorrent-0.14.9[python]
+ dev-python/setuptools"
+RDEPEND="${DEPEND}
+ dev-python/chardet
+ dev-python/pyopenssl
+ dev-python/pyxdg
+ || ( >=virtual/python-2.6 dev-python/simplejson )
+ >=dev-python/twisted-8.1
+ >=dev-python/twisted-web-8.1
+ gtk? (
+ dev-python/pygame
+ dev-python/pygobject
+ >=dev-python/pygtk-2.12
+ gnome-base/librsvg
+ libnotify? ( dev-python/notify-python )
+ )
+ webinterface? ( dev-python/mako )"
+
+pkg_setup() {
+ append-ldflags $(no-as-needed)
+}
+
+src_install() {
+ distutils_src_install
+ newinitd "${FILESDIR}"/deluged.init deluged
+ newconfd "${FILESDIR}"/deluged.conf deluged
+}
+
+pkg_postinst() {
+ elog
+ elog "If after upgrading it doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ elog "To start the daemon either run 'deluged' as user"
+ elog "or modify /etc/conf.d/deluged and run"
+ elog "/etc/init.d/deluged start as root"
+ elog "You can still use deluge the old way"
+ elog
+ elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
+ elog
+}