summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-19 21:56:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-19 21:56:18 +0000
commit3d4cfe856a6e99c0234a87d7d14ee81b99d8fff5 (patch)
tree36b2f01daf11d9c76b712bb3484d379b39434600 /net-p2p
parentFixed SRC_URI. (diff)
downloadgentoo-2-3d4cfe856a6e99c0234a87d7d14ee81b99d8fff5.tar.gz
gentoo-2-3d4cfe856a6e99c0234a87d7d14ee81b99d8fff5.tar.bz2
gentoo-2-3d4cfe856a6e99c0234a87d7d14ee81b99d8fff5.zip
Fix building with -Wl,--as-needed wrt #248147.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitstormlite/ChangeLog6
-rw-r--r--net-p2p/bitstormlite/bitstormlite-0.2p.ebuild10
-rw-r--r--net-p2p/bitstormlite/files/bitstormlite-0.2p-asneeded.patch13
3 files changed, 24 insertions, 5 deletions
diff --git a/net-p2p/bitstormlite/ChangeLog b/net-p2p/bitstormlite/ChangeLog
index c6b560b4597b..6d3e15d8dc57 100644
--- a/net-p2p/bitstormlite/ChangeLog
+++ b/net-p2p/bitstormlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitstormlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/ChangeLog,v 1.11 2009/07/25 19:53:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/ChangeLog,v 1.12 2009/12/19 21:56:17 ssuominen Exp $
+
+ 19 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+ bitstormlite-0.2p.ebuild, +files/bitstormlite-0.2p-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #248147.
25 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
bitstormlite-0.2p.ebuild, +files/bitstormlite-0.2p-gcc44.patch:
diff --git a/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild b/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild
index 471d6913535e..ca6ca20b699b 100644
--- a/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild
+++ b/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild,v 1.4 2009/07/25 19:53:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitstormlite/bitstormlite-0.2p.ebuild,v 1.5 2009/12/19 21:56:17 ssuominen Exp $
EAPI=2
-inherit eutils
+inherit autotools eutils
DESCRIPTION="A light BitTorrent client based on c++ and gtk+."
HOMEPAGE="http://sourceforge.net/projects/bbom/"
@@ -23,9 +23,11 @@ S=${WORKDIR}/BitStormLite-${PV}
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-gcc44.patch
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die
}
diff --git a/net-p2p/bitstormlite/files/bitstormlite-0.2p-asneeded.patch b/net-p2p/bitstormlite/files/bitstormlite-0.2p-asneeded.patch
new file mode 100644
index 000000000000..17cf559c9efd
--- /dev/null
+++ b/net-p2p/bitstormlite/files/bitstormlite-0.2p-asneeded.patch
@@ -0,0 +1,13 @@
+diff -ur BitStormLite-0.2p.orig/src/Makefile.am BitStormLite-0.2p/src/Makefile.am
+--- BitStormLite-0.2p.orig/src/Makefile.am 2007-09-20 15:01:06.000000000 +0300
++++ BitStormLite-0.2p/src/Makefile.am 2009-12-19 23:55:38.000000000 +0200
+@@ -4,8 +4,7 @@
+ localedir = $(datadir)/locale
+ INCLUDES = $(GTK_CFLAGS) -DLOCALEDIR=\"$(localedir)\"
+
+-bitstormlite_LDFLAGS = -lpthread $(GTK_LIBS) `curl-config --libs`
+-bitstormlite_LDADD = $(LIBINTL)
++bitstormlite_LDADD = -lpthread $(LIBINTL) $(GTK_LIBS) -lcurl
+
+ bitstormlite_SOURCES = bdict.cpp\
+ BitSet.cpp\