summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-04-04 15:26:28 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-04-04 15:26:28 +0000
commit2eeeb96cfaff7f7e64d6fa0c08ebf36bb30950d7 (patch)
treee2a7e3f221fde220c4f1ced3f32f450d87a5f746 /net-p2p
parentversion 4.3.12 (diff)
downloadgentoo-2-2eeeb96cfaff7f7e64d6fa0c08ebf36bb30950d7.tar.gz
gentoo-2-2eeeb96cfaff7f7e64d6fa0c08ebf36bb30950d7.tar.bz2
gentoo-2-2eeeb96cfaff7f7e64d6fa0c08ebf36bb30950d7.zip
version bump
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mnet/mnet-0.6.1.207.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-p2p/mnet/mnet-0.6.1.207.ebuild b/net-p2p/mnet/mnet-0.6.1.207.ebuild
new file mode 100644
index 000000000000..2411472677ac
--- /dev/null
+++ b/net-p2p/mnet/mnet-0.6.1.207.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mnet/mnet-0.6.1.207.ebuild,v 1.1 2003/04/04 15:26:28 hannes Exp $
+
+IUSE="gtk"
+S=${WORKDIR}/${PN}
+DESCRIPTION="Mnet is a universal file space. It is formed by an emergent network of autonomous nodes which self-organize to make the network robust and efficient."
+SRC_URI="mirror://sourceforge/${PN}/${P/m/M}-STABLE-src.tar.bz2"
+HOMEPAGE="http://mnet.sourceforge.net/"
+
+DEPEND="dev-lang/python"
+RDEPEND="virtual/glibc
+ dev-lang/python
+ gtk? ( dev-python/wxPython )"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+SLOT="0"
+
+src_compile() {
+ EXTSRCDIR="${WORKDIR}/extsrc/" MNETDIR="${S}" make build
+}
+
+src_install() {
+ dodoc COPYING CREDITS ChangeLog overview.txt hackerdocs/*
+ dobin Mnet.sh
+ rm Mnet.sh COPYING CREDITS ChangeLog overview.txt hackerdocs/*
+ dodir /usr/share/mnet
+ cp -r ${S}/* ${D}/usr/share/mnet
+ insinto /etc/env.d
+ doins ${FILESDIR}/96mnet
+}
+
+pkg_postinst() {
+ einfo "If this is the first time Mnet is merged, please run 'env-update'"
+ einfo "and 'source /etc/profile', otherwise execute 'Mnet.sh'"
+}