summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-27 00:26:39 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-27 00:26:39 +0000
commit2e294c9207c572726bf9707f0fc7ca35bd50ea47 (patch)
tree5fcb3cd6a2d596551f6f7b05e52be68a4424a360 /net-p2p
parent[dev-vcs/fossil] Version bump. Removed old version. (diff)
downloadgentoo-2-2e294c9207c572726bf9707f0fc7ca35bd50ea47.tar.gz
gentoo-2-2e294c9207c572726bf9707f0fc7ca35bd50ea47.tar.bz2
gentoo-2-2e294c9207c572726bf9707f0fc7ca35bd50ea47.zip
Version bump
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.4.2.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 8222d3275aa8..823dc6c11a89 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.111 2010/09/26 17:07:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.112 2010/09/27 00:26:39 tampakrap Exp $
+
+*qbittorrent-2.4.2 (27 Sep 2010)
+
+ 27 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qbittorrent-2.4.2.ebuild:
+ Version bump
*qbittorrent-2.4.1 (26 Sep 2010)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.4.2.ebuild b/net-p2p/qbittorrent/qbittorrent-2.4.2.ebuild
new file mode 100644
index 000000000000..23c3765311da
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.4.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.4.2.ebuild,v 1.1 2010/09/27 00:26:39 tampakrap Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python confutils qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}