summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-10-29 01:46:15 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-10-29 01:46:15 +0000
commit2ae68cc71991ac6056b4a178a5989eceece50bac (patch)
treee5b4fec4ab4ee2c3cf0ce212ac8c157ad6190dd1 /net-p2p
parentVersion bumps, bug #435216 (diff)
downloadgentoo-2-2ae68cc71991ac6056b4a178a5989eceece50bac.tar.gz
gentoo-2-2ae68cc71991ac6056b4a178a5989eceece50bac.tar.bz2
gentoo-2-2ae68cc71991ac6056b4a178a5989eceece50bac.zip
Workaround for bug #440034
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xD0455535)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoind/ChangeLog6
-rw-r--r--net-p2p/bitcoind/bitcoind-0.6.3.ebuild5
-rw-r--r--net-p2p/bitcoind/bitcoind-0.6.4_rc3.ebuild5
-rw-r--r--net-p2p/bitcoind/bitcoind-0.7.0.ebuild5
4 files changed, 17 insertions, 4 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index ecfd6ecee629..82924424fde4 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.48 2012/10/29 01:31:05 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.49 2012/10/29 01:46:15 blueness Exp $
+
+ 29 Oct 2012; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.6.3.ebuild,
+ bitcoind-0.6.4_rc3.ebuild, bitcoind-0.7.0.ebuild:
+ Workaround for bug #440034
*bitcoind-0.4.8_rc4 (29 Oct 2012)
*bitcoind-0.5.7_rc4 (29 Oct 2012)
diff --git a/net-p2p/bitcoind/bitcoind-0.6.3.ebuild b/net-p2p/bitcoind/bitcoind-0.6.3.ebuild
index 282602430836..5db806b51c52 100644
--- a/net-p2p/bitcoind/bitcoind-0.6.3.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.3.ebuild,v 1.5 2012/10/21 00:03:53 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.3.ebuild,v 1.6 2012/10/29 01:46:15 blueness Exp $
EAPI="4"
@@ -73,6 +73,9 @@ src_compile() {
OPTS+=(USE_UPNP=)
fi
+ # Workaround for bug #440034
+ share/genbuild.sh src/obj/build.h
+
cd src || die
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
}
diff --git a/net-p2p/bitcoind/bitcoind-0.6.4_rc3.ebuild b/net-p2p/bitcoind/bitcoind-0.6.4_rc3.ebuild
index 7035968a787f..40da80b8353d 100644
--- a/net-p2p/bitcoind/bitcoind-0.6.4_rc3.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.6.4_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.4_rc3.ebuild,v 1.1 2012/10/08 18:04:56 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.4_rc3.ebuild,v 1.2 2012/10/29 01:46:15 blueness Exp $
EAPI="4"
@@ -73,6 +73,9 @@ src_compile() {
OPTS+=(USE_UPNP=)
fi
+ # Workaround for bug #440034
+ share/genbuild.sh src/obj/build.h
+
cd src || die
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
}
diff --git a/net-p2p/bitcoind/bitcoind-0.7.0.ebuild b/net-p2p/bitcoind/bitcoind-0.7.0.ebuild
index 2476b9f70a7f..1c504a95174c 100644
--- a/net-p2p/bitcoind/bitcoind-0.7.0.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.7.0.ebuild,v 1.1 2012/10/08 18:04:56 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.7.0.ebuild,v 1.2 2012/10/29 01:46:15 blueness Exp $
EAPI="4"
@@ -72,6 +72,9 @@ src_compile() {
fi
use ipv6 || OPTS+=("USE_IPV6=-")
+ # Workaround for bug #440034
+ share/genbuild.sh src/obj/build.h
+
cd src || die
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
}