summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-10-10 11:30:23 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-10-10 11:30:23 +0000
commit225e181a5c7b3741008f535202ec7305c4e3c8b6 (patch)
treeed86f55d0599a7efcf82cf7ab563d18879ff8721 /net-p2p
parentFix dependancy on boost's version (diff)
downloadgentoo-2-225e181a5c7b3741008f535202ec7305c4e3c8b6.tar.gz
gentoo-2-225e181a5c7b3741008f535202ec7305c4e3c8b6.tar.bz2
gentoo-2-225e181a5c7b3741008f535202ec7305c4e3c8b6.zip
Address anti-spam issue, bug #524512
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-qt/ChangeLog6
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.9.3.ebuild10
-rw-r--r--net-p2p/bitcoin-qt/files/0.9.x-ljr_noblacklist.patch12
-rw-r--r--net-p2p/bitcoin-qt/metadata.xml1
4 files changed, 24 insertions, 5 deletions
diff --git a/net-p2p/bitcoin-qt/ChangeLog b/net-p2p/bitcoin-qt/ChangeLog
index 2bfc1478dfd1..32c68c6ed7af 100644
--- a/net-p2p/bitcoin-qt/ChangeLog
+++ b/net-p2p/bitcoin-qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitcoin-qt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.86 2014/10/02 10:21:52 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.87 2014/10/10 11:30:23 blueness Exp $
+
+ 10 Oct 2014; Anthony G. Basile <blueness@gentoo.org>
+ +files/0.9.x-ljr_noblacklist.patch, bitcoin-qt-0.9.3.ebuild, metadata.xml:
+ Address anti-spam issue, bug #524512
*bitcoin-qt-0.9.3 (02 Oct 2014)
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.9.3.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.9.3.ebuild
index ff44e3157193..79f3e04de4fb 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.9.3.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 2010-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.9.3.ebuild,v 1.1 2014/10/02 10:21:52 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.9.3.ebuild,v 1.2 2014/10/10 11:30:23 blueness Exp $
EAPI=4
@@ -24,13 +24,14 @@ SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v
LICENSE="MIT ISC GPL-3 LGPL-2.1 public-domain || ( CC-BY-SA-3.0 LGPL-2.1 )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="$IUSE 1stclassmsg dbus kde +ljr +qrcode test upnp"
+IUSE="$IUSE 1stclassmsg dbus kde ljr ljr-antispam +qrcode test upnp"
REQUIRED_USE="
1stclassmsg? ( ljr )
+ ljr-antispam? ( ljr )
"
RDEPEND="
- >=dev-libs/boost-1.53.0[threads(+)]
+ >=dev-libs/boost-1.52.0[threads(+)]
dev-libs/openssl:0[-bindist]
dev-libs/protobuf
qrcode? (
@@ -55,6 +56,7 @@ S="${WORKDIR}/${MyP}"
src_prepare() {
if use ljr; then
epatch "${WORKDIR}/${LJR_PATCH}"
+ use ljr-antispam || epatch "${FILESDIR}/0.9.x-ljr_noblacklist.patch"
else
epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
fi
@@ -94,7 +96,7 @@ src_configure() {
$(use_with upnp miniupnpc) $(use_enable upnp upnp-default) \
$(use_with qrcode qrencode) \
$(use_enable test tests) \
- $(use_enable 1stclassmsg first-class-messaging) \
+ $(usex ljr $(use_enable 1stclassmsg first-class-messaging)) \
--with-system-leveldb \
--without-cli --without-daemon \
--with-gui
diff --git a/net-p2p/bitcoin-qt/files/0.9.x-ljr_noblacklist.patch b/net-p2p/bitcoin-qt/files/0.9.x-ljr_noblacklist.patch
new file mode 100644
index 000000000000..35194662ecd2
--- /dev/null
+++ b/net-p2p/bitcoin-qt/files/0.9.x-ljr_noblacklist.patch
@@ -0,0 +1,12 @@
+diff --git a/src/script.cpp b/src/script.cpp
+index 24bbbad..a60d8b6 100644
+--- a/src/script.cpp
++++ b/src/script.cpp
+@@ -1870,6 +1870,7 @@ bool fIsBareMultisigStd = false;
+
+ const char *CScript::IsBlacklisted() const
+ {
++ return false;
+ if (this->size() >= 7 && this->at(0) == OP_DUP)
+ {
+ // pay-to-pubkeyhash
diff --git a/net-p2p/bitcoin-qt/metadata.xml b/net-p2p/bitcoin-qt/metadata.xml
index e7016f32ade0..cb53a2afe7c9 100644
--- a/net-p2p/bitcoin-qt/metadata.xml
+++ b/net-p2p/bitcoin-qt/metadata.xml
@@ -13,6 +13,7 @@
<use>
<flag name='1stclassmsg'>Enable first-class Bitcoin message tools</flag>
<flag name='ljr'>Enable Luke Dashjr's patches</flag>
+ <flag name='ljr-antispam'>Enable Luke Dashjr's address-based spam filter</flag>
<flag name='qrcode'>Enable generation of QR Codes for receiving payments</flag>
</use>
</pkgmetadata>