summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-08-15 23:21:49 +0000
committerBen de Groot <yngwin@gentoo.org>2009-08-15 23:21:49 +0000
commit13a50a3c90af1c67e6cf532ec5fd42dcb6de0f0f (patch)
tree4617ef85fc4bd3ee002a3ee1fd230250f563761e /net-p2p
parentVersion bump (#280971). (diff)
downloadgentoo-2-13a50a3c90af1c67e6cf532ec5fd42dcb6de0f0f.tar.gz
gentoo-2-13a50a3c90af1c67e6cf532ec5fd42dcb6de0f0f.tar.bz2
gentoo-2-13a50a3c90af1c67e6cf532ec5fd42dcb6de0f0f.zip
Remove old. Version bump. Patch applied upstream. Add zziplib dependency.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog10
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild9
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.2.1.ebuild50
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild10
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.3.3.ebuild50
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.4.0.ebuild (renamed from net-p2p/qbittorrent/qbittorrent-1.3.2.ebuild)26
6 files changed, 29 insertions, 126 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index b3897af0b10f..2b219a7364ed 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.58 2009/07/10 20:26:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.59 2009/08/15 23:21:49 yngwin Exp $
+
+*qbittorrent-1.4.0 (15 Aug 2009)
+
+ 15 Aug 2009; Ben de Groot <yngwin@gentoo.org> qbittorrent-1.0.0.ebuild,
+ -qbittorrent-1.2.1.ebuild, -qbittorrent-1.3.2.ebuild,
+ -qbittorrent-1.3.3.ebuild, qbittorrent-1.3.3-r1.ebuild,
+ +qbittorrent-1.4.0.ebuild:
+ Remove old. Version bump. Patch applied upstream. Add zziplib dependency.
*qbittorrent-1.3.3-r1 (10 Jul 2009)
diff --git a/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild b/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild
index cd720e0a96a7..d5f76925d2eb 100644
--- a/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild,v 1.6 2009/03/07 16:13:27 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild,v 1.7 2009/08/15 23:21:49 yngwin Exp $
EAPI="1"
@@ -8,7 +8,7 @@ inherit eutils qt4 multilib
MY_P="${P/_/}"
-DESCRIPTION="BitTorrent client in C++ and Qt."
+DESCRIPTION="A C++/Qt4 BitTorrent client"
HOMEPAGE="http://www.qbittorrent.org/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
@@ -19,9 +19,10 @@ KEYWORDS="~amd64 x86"
IUSE=""
# boost version so that we always have threads support
-DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3*:4 )
- >=net-libs/rb_libtorrent-0.13
+DEPEND="x11-libs/qt-gui:4
+ ~net-libs/rb_libtorrent-0.13
>=dev-libs/boost-1.34.1
+ dev-libs/zziplib
net-misc/curl
dev-cpp/commoncpp2"
RDEPEND="${DEPEND}
diff --git a/net-p2p/qbittorrent/qbittorrent-1.2.1.ebuild b/net-p2p/qbittorrent/qbittorrent-1.2.1.ebuild
deleted file mode 100644
index 2992f8c15264..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-1.2.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.2.1.ebuild,v 1.2 2009/03/07 16:13:27 betelgeuse Exp $
-
-EAPI="1"
-
-inherit eutils qt4 multilib
-
-MY_P="${P/_/}"
-
-DESCRIPTION="BitTorrent client in C++ and Qt."
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# boost version so that we always have threads support
-DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3*:4 )
- >=net-libs/rb_libtorrent-0.13.1
- >=dev-libs/boost-1.34.1
- net-misc/curl
- dev-cpp/commoncpp2"
-RDEPEND="${DEPEND}
- >=dev-lang/python-2.3"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
-}
-
-src_compile() {
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr \
- --with-libtorrent-inc=/usr/include \
- --with-libtorrent-lib=/usr/$(get_libdir) \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- dodoc AUTHORS Changelog NEWS README TODO
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild b/net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild
index d37d8d241bdf..3a8696b924ac 100644
--- a/net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild
@@ -1,17 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild,v 1.1 2009/07/10 20:26:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild,v 1.2 2009/08/15 23:21:49 yngwin Exp $
EAPI="2"
-
inherit eutils qt4 multilib
MY_P="${P/_/}"
-
-DESCRIPTION="BitTorrent client in C++ and Qt."
+DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
@@ -22,11 +19,14 @@ IUSE=""
DEPEND=" x11-libs/qt-gui:4
>=net-libs/rb_libtorrent-0.14.1
>=dev-libs/boost-1.34.1
+ dev-libs/zziplib
net-misc/curl
dev-cpp/commoncpp2"
RDEPEND="${DEPEND}
>=dev-lang/python-2.3"
+S="${WORKDIR}/${MY_P}"
+
PATCHES=(
"${FILESDIR}/${P}-no-strip.patch"
)
diff --git a/net-p2p/qbittorrent/qbittorrent-1.3.3.ebuild b/net-p2p/qbittorrent/qbittorrent-1.3.3.ebuild
deleted file mode 100644
index c865b49034fb..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-1.3.3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.3.3.ebuild,v 1.1 2009/04/08 09:32:11 armin76 Exp $
-
-EAPI="1"
-
-inherit eutils qt4 multilib
-
-MY_P="${P/_/}"
-
-DESCRIPTION="BitTorrent client in C++ and Qt."
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# boost version so that we always have thread support
-DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3* )
- >=net-libs/rb_libtorrent-0.14.1
- >=dev-libs/boost-1.34.1
- net-misc/curl
- dev-cpp/commoncpp2"
-RDEPEND="${DEPEND}
- >=dev-lang/python-2.3"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
-}
-
-src_compile() {
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr \
- --with-libtorrent-inc=/usr/include \
- --with-libtorrent-lib=/usr/$(get_libdir) \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- dodoc AUTHORS Changelog NEWS README TODO
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-1.3.2.ebuild b/net-p2p/qbittorrent/qbittorrent-1.4.0.ebuild
index bfb13111029c..f977f3026a4f 100644
--- a/net-p2p/qbittorrent/qbittorrent-1.3.2.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-1.4.0.ebuild
@@ -1,17 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.3.2.ebuild,v 1.1 2009/03/09 13:06:48 armin76 Exp $
-
-EAPI="1"
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.4.0.ebuild,v 1.1 2009/08/15 23:21:49 yngwin Exp $
+EAPI="2"
inherit eutils qt4 multilib
MY_P="${P/_/}"
-
-DESCRIPTION="BitTorrent client in C++ and Qt."
+DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
@@ -19,29 +16,26 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
# boost version so that we always have thread support
-DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3* )
+DEPEND=" x11-libs/qt-gui:4
>=net-libs/rb_libtorrent-0.14.1
>=dev-libs/boost-1.34.1
+ dev-libs/zziplib
net-misc/curl
dev-cpp/commoncpp2"
RDEPEND="${DEPEND}
>=dev-lang/python-2.3"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+S="${WORKDIR}/${MY_P}"
+src_prepare() {
# Respect LDFLAGS
sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4_src_prepare
}
-src_compile() {
+src_configure() {
# econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr \
- --with-libtorrent-inc=/usr/include \
- --with-libtorrent-lib=/usr/$(get_libdir) \
- || die "configure failed"
- emake || die "emake failed"
+ ./configure --prefix=/usr --qtdir=/usr || die "configure failed"
}
src_install() {