summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-08-23 14:58:57 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-08-23 14:58:57 +0000
commit7ffc0725be049cbac6ea2c53814180166ae87989 (patch)
treef73cb9621d6fc813adfe5e983ae25e606daf458d /net-p2p/tribler
parentppc stable (bug 426336). (diff)
downloadgentoo-2-7ffc0725be049cbac6ea2c53814180166ae87989.tar.gz
gentoo-2-7ffc0725be049cbac6ea2c53814180166ae87989.tar.bz2
gentoo-2-7ffc0725be049cbac6ea2c53814180166ae87989.zip
Version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/tribler')
-rw-r--r--net-p2p/tribler/ChangeLog7
-rw-r--r--net-p2p/tribler/tribler-5.9.28.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/net-p2p/tribler/ChangeLog b/net-p2p/tribler/ChangeLog
index 5c3df239a0e9..f7ef82e0700a 100644
--- a/net-p2p/tribler/ChangeLog
+++ b/net-p2p/tribler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/tribler
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/ChangeLog,v 1.30 2012/08/05 13:40:25 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/ChangeLog,v 1.31 2012/08/23 14:58:57 blueness Exp $
+
+*tribler-5.9.28 (23 Aug 2012)
+
+ 23 Aug 2012; Anthony G. Basile <blueness@gentoo.org> +tribler-5.9.28.ebuild:
+ Version bump
*tribler-5.9.27 (05 Aug 2012)
diff --git a/net-p2p/tribler/tribler-5.9.28.ebuild b/net-p2p/tribler/tribler-5.9.28.ebuild
new file mode 100644
index 000000000000..596c50237bf5
--- /dev/null
+++ b/net-p2p/tribler/tribler-5.9.28.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/tribler-5.9.28.ebuild,v 1.1 2012/08/23 14:58:57 blueness Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite"
+
+inherit eutils python
+
+MY_PV="${PN}_${PV}-1ubuntu1_all"
+
+DESCRIPTION="Bittorrent client that does not require a website to discover content"
+HOMEPAGE="http://www.tribler.org/"
+SRC_URI="
+ http://dl.tribler.org/${MY_PV}.deb
+ x86? ( http://dl.tribler.org/tribler-swift_5.9.23-27674_i386.deb )
+ amd64? ( http://dl.tribler.org/tribler-swift_5.9.23-27674_amd64.deb )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vlc"
+
+RDEPEND="
+ dev-python/apsw
+ dev-python/m2crypto
+ dev-python/netifaces
+ dev-libs/openssl
+ dev-python/wxpython
+ vlc? (
+ media-video/vlc
+ media-video/ffmpeg
+ )"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/share/tribler/swift"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_unpack() {
+ for i in ${A}; do
+ unpack ${i}
+ unpack ./data.tar.gz
+ done
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-5.9.12-fix-global-declarations.patch"
+ epatch "${FILESDIR}/${PN}-log2homedir.patch"
+
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() { :; }
+
+src_install() {
+ #Rename the doc dir properly
+ mv usr/share/doc/${PN} usr/share/doc/${P}
+
+ #Move the readme to the doc dir
+ mv usr/share/${PN}/Tribler/readme.txt usr/share/doc/${P}
+
+ #Remove the licenses scattered throughout
+ rm usr/share/doc/${P}/copyright
+ rm usr/share/${PN}/Tribler/*.txt
+ rm usr/share/${PN}/Tribler/Core/DecentralizedTracking/pymdht/{LGPL-2.1.txt,LICENSE.txt}
+
+ #Copy the rest over
+ cp -pPR usr/ "${ED}"/
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}"usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT}"usr/share/${PN}
+}