summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-02-12 01:47:49 +0000
committerPeter Volkov <pva@gentoo.org>2011-02-12 01:47:49 +0000
commit9e17d302f9068bde041fabf92206baf0d0b8d10e (patch)
tree43c9f4599b594da721360140b666bc6aaa45400e /net-p2p/transmission
parentMasked =net-p2p/transmission-2.21 as it depends on libevent-2. (diff)
downloadgentoo-2-9e17d302f9068bde041fabf92206baf0d0b8d10e.tar.gz
gentoo-2-9e17d302f9068bde041fabf92206baf0d0b8d10e.tar.bz2
gentoo-2-9e17d302f9068bde041fabf92206baf0d0b8d10e.zip
Version bump, #351399, now it is compatible (actually depends) with libevent-2, thank Anthony Basile for report. Added possibility to use syslog, #349803, thank Maxime de Roucy for report and feedback. Added ewarn for dropping permissions until better solution will be found, #349867, thank Tony Levi for report.
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/transmission')
-rw-r--r--net-p2p/transmission/ChangeLog12
-rw-r--r--net-p2p/transmission/files/transmission-daemon.confd.314
-rw-r--r--net-p2p/transmission/files/transmission-daemon.initd.672
-rw-r--r--net-p2p/transmission/transmission-2.21.ebuild137
4 files changed, 234 insertions, 1 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index 8f1d59d6fb3c..43b60fdbc059 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.138 2011/01/29 14:10:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.139 2011/02/12 01:47:49 pva Exp $
+
+*transmission-2.21 (12 Feb 2011)
+
+ 12 Feb 2011; Peter Volkov <pva@gentoo.org> +transmission-2.21.ebuild,
+ +files/transmission-daemon.confd.3, +files/transmission-daemon.initd.6:
+ Version bump, #351399, now it is compatible (actually depends) with
+ libevent-2, thank Anthony Basile for report. Added possibility to use syslog,
+ #349803, thank Maxime de Roucy for report and feedback. Added ewarn for
+ dropping permissions until better solution will be found, #349867, thank Tony
+ Levi for report.
29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> transmission-2.13.ebuild,
+files/transmission-2.13-libnotify-0.7.patch:
diff --git a/net-p2p/transmission/files/transmission-daemon.confd.3 b/net-p2p/transmission/files/transmission-daemon.confd.3
new file mode 100644
index 000000000000..fcf37c7912dc
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-daemon.confd.3
@@ -0,0 +1,14 @@
+# This is the transmission-daemon configuration file. For other options and
+# better explanation, take a look at transmission-daemon manual page Note: it's
+# better to configure some settings (like username/password) in
+# /var/transmission/config/settings.json to avoid other users see it with `ps`
+
+TRANSMISSION_OPTIONS="--encryption-preferred"
+
+# Run daemon as another user (username or username:groupname)
+# If you change this setting, chown -R /var/transmission/config <and download directory, check web settings>
+#runas_user=transmission
+
+# Location of logfile (should be writeable for runas_user user)
+# Set logfile=syslog to use syslog for logging
+#logfile=/var/log/transmission/transmission.log
diff --git a/net-p2p/transmission/files/transmission-daemon.initd.6 b/net-p2p/transmission/files/transmission-daemon.initd.6
new file mode 100644
index 000000000000..dc7f1729ef03
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-daemon.initd.6
@@ -0,0 +1,72 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/files/transmission-daemon.initd.6,v 1.1 2011/02/12 01:47:49 pva Exp $
+
+opts="start stop reload"
+description="Transmission is a fast, easy and free bittorrent client"
+description_start="Start transmission-daemon server and web interface"
+description_stop="Stop transmission-daemon server and web interface"
+description_reload="Reload transmission-daemon settings"
+
+pidfile=/var/run/transmission/transmission.pid
+config_dir=/var/transmission/config
+download_dir=/var/transmission/downloads
+logfile=${logfile:-/var/log/transmission/transmission.log}
+runas_user=${runas_user:-transmission:transmission}
+
+SSD_OPTIONS=""
+
+depend() {
+ need net
+}
+
+check_config() {
+ if [ ! -d /var/run/transmission/ ]; then
+ mkdir /var/run/transmission/
+ if [ -n "${runas_user}" ]; then
+ chown -R ${runas_user} /var/run/transmission/
+ fi
+ fi
+
+ # In case no config directory option passed use default
+ if ! $(echo ${TRANSMISSION_OPTIONS} | grep -q -e '\B-g' -e '\B--config-dir'); then
+ TRANSMISSION_OPTIONS="${TRANSMISSION_OPTIONS} --config-dir ${config_dir}"
+ # put download dir location on first run (and take it from config later)
+ if [ ! -f ${config_dir}/settings.json ]; then
+ TRANSMISSION_OPTIONS="${TRANSMISSION_OPTIONS} --download-dir ${download_dir}"
+ fi
+ fi
+
+ if [ -n "${runas_user}" ]; then
+ if [ -f /etc/init.d/sysfs ]; then
+ SSD_OPTIONS="${SSD_OPTIONS} --user ${runas_user}"
+ else
+ SSD_OPTIONS="${SSD_OPTIONS} --chuid ${runas_user}"
+ fi
+ fi
+}
+
+start() {
+ check_config
+
+ ebegin "Starting transmission daemon"
+ start-stop-daemon --start --quiet --background --pidfile ${pidfile} ${SSD_OPTIONS} \
+ --exec /usr/bin/transmission-daemon -- --pid-file ${pidfile} \
+ $(test ${logfile} != "syslog" && echo --logfile ${logfile}) \
+ ${TRANSMISSION_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping transmission daemon"
+ start-stop-daemon --stop --quiet --retry TERM/45/QUIT/15 --pidfile ${pidfile}
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading transmission configuration"
+ start-stop-daemon --signal HUP --pidfile ${pidfile}
+ eend $?
+}
+
diff --git a/net-p2p/transmission/transmission-2.21.ebuild b/net-p2p/transmission/transmission-2.21.ebuild
new file mode 100644
index 000000000000..5705226f4d08
--- /dev/null
+++ b/net-p2p/transmission/transmission-2.21.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.21.ebuild,v 1.1 2011/02/12 01:47:49 pva Exp $
+
+EAPI=2
+inherit eutils fdo-mime gnome2-utils qt4-r2
+
+DESCRIPTION="A Fast, Easy and Free BitTorrent client"
+HOMEPAGE="http://www.transmissionbt.com/"
+SRC_URI="http://download.transmissionbt.com/${PN}/files/${P}.tar.bz2"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="gnome gtk kde libnotify sound qt4"
+
+RDEPEND="
+ sys-libs/zlib
+ >=dev-libs/libevent-2.0.10
+ >=dev-libs/openssl-0.9.4
+ || ( >=net-misc/curl-7.16.3[ssl]
+ >=net-misc/curl-7.16.3[gnutls] )
+ gtk? ( >=dev-libs/glib-2.15.5:2
+ >=x11-libs/gtk+-2.12:2
+ >=dev-libs/dbus-glib-0.70
+ gnome? ( >=gnome-base/gconf-2.20.0 )
+ libnotify? ( >=x11-libs/libnotify-0.4.3 )
+ sound? ( >=media-libs/libcanberra-0.10 ) )
+ qt4? ( x11-libs/qt-gui:4[dbus] )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.6b
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-apps/sed"
+
+pkg_setup() {
+ enewgroup transmission
+ enewuser transmission -1 -1 -1 transmission
+}
+
+src_prepare() {
+ sed -i -e 's:-ggdb3::g' configure || die
+ # Magnet link support
+ if use kde; then
+ cat > qt/transmission-magnet.protocol <<-EOF
+ [Protocol]
+ exec=transmission-qt '%u'
+ protocol=magnet
+ Icon=transmission
+ input=none
+ output=none
+ helper=true
+ listing=
+ reading=false
+ writing=false
+ makedir=false
+ deleting=false
+ EOF
+ fi
+}
+
+src_configure() {
+ # cli and daemon doesn't have external deps and are enabled by default
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable gtk) \
+ $(use gtk && use_enable libnotify) \
+ $(use gtk && use_enable sound libcanberra) \
+ $(use gtk && use_enable gnome gconf2)
+
+ use qt4 && cd qt && eqmake4 qtr.pro
+}
+
+src_compile() {
+ emake || die
+ use qt4 && cd qt && { emake || die; }
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS NEWS qt/README.txt
+ rm -f "${D}"/usr/share/${PN}/web/LICENSE
+
+ newinitd "${FILESDIR}"/${PN}-daemon.initd.6 ${PN}-daemon || die
+ newconfd "${FILESDIR}"/${PN}-daemon.confd.3 ${PN}-daemon || die
+
+ keepdir /var/{transmission/{config,downloads},log/transmission}
+ fowners -R transmission:transmission /var/{transmission/{,config,downloads},log/transmission}
+
+ if use qt4; then
+ cd qt
+ emake INSTALL_ROOT="${D}/usr" install || die
+ insinto /usr/share/applications/
+ doins transmission-qt.desktop || die
+ mv icons/transmission{,-qt}.png
+ doicon icons/transmission-qt.png || die
+ if use kde; then
+ insinto /usr/share/kde4/services/
+ doins transmission-magnet.protocol || die
+ fi
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ # Keep default permissions on default dirs
+ einfo "Seting owners of /var/{transmission/{,config,downloads},log/transmission}"
+ chown -R transmission:transmission /var/{transmission/{,config,downloads},log/transmission}
+
+ ewarn "If you use transmission-daemon, please, set 'rpc-username' and"
+ ewarn "'rpc-password' (in plain text, transmission-daemon will hash it on"
+ ewarn "start) in settings.json file located at /var/transmission/config or"
+ ewarn "any other appropriate config directory."
+ ewarn
+ ewarn "You must change download location after you change a user daemon"
+ ewarn "starts as, or it'll refuse to start, see bug #349867 for details."
+
+ if use gtk; then
+ elog 'If you want magnet link support in gnome run this commands:'
+ elog 'gconftool-2 -t string -s /desktop/gnome/url-handlers/magnet/command "/usr/bin/transmission-gtk %s"'
+ elog 'gconftool-2 -s /desktop/gnome/url-handlers/magnet/needs_terminal false -t bool'
+ elog 'gconftool-2 -t bool -s /desktop/gnome/url-handlers/magnet/enabled true'
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}