summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-03-23 08:31:10 +0000
committerMichael Weber <xmw@gentoo.org>2013-03-23 08:31:10 +0000
commitafc77561d85507f0af19846422ae5312304be38e (patch)
treecfbaeb7d4d61caccad6f220a26a77859cf3bfdbe /net-p2p/transmission-remote-cli
parentRemove old. (diff)
downloadgentoo-2-afc77561d85507f0af19846422ae5312304be38e.tar.gz
gentoo-2-afc77561d85507f0af19846422ae5312304be38e.tar.bz2
gentoo-2-afc77561d85507f0af19846422ae5312304be38e.zip
Version bump by lorem_ipsum
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-p2p/transmission-remote-cli')
-rw-r--r--net-p2p/transmission-remote-cli/ChangeLog9
-rw-r--r--net-p2p/transmission-remote-cli/transmission-remote-cli-1.5.0.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/net-p2p/transmission-remote-cli/ChangeLog b/net-p2p/transmission-remote-cli/ChangeLog
index 43ef086fa6c3..bf19ab08e6d1 100644
--- a/net-p2p/transmission-remote-cli/ChangeLog
+++ b/net-p2p/transmission-remote-cli/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/transmission-remote-cli
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission-remote-cli/ChangeLog,v 1.2 2013/02/14 23:27:11 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission-remote-cli/ChangeLog,v 1.3 2013/03/23 08:31:10 xmw Exp $
+
+*transmission-remote-cli-1.5.0 (23 Mar 2013)
+
+ 23 Mar 2013; Michael Weber <xmw@gentoo.org>
+ +transmission-remote-cli-1.5.0.ebuild:
+ Version bump by lorem_ipsum
*transmission-remote-cli-1.4.7-r1 (14 Feb 2013)
@@ -13,4 +19,3 @@
14 Feb 2013; Michael Weber <xmw@gentoo.org>
+transmission-remote-cli-1.4.7.ebuild, +metadata.xml:
Initial import
-
diff --git a/net-p2p/transmission-remote-cli/transmission-remote-cli-1.5.0.ebuild b/net-p2p/transmission-remote-cli/transmission-remote-cli-1.5.0.ebuild
new file mode 100644
index 000000000000..8d640ed6afa1
--- /dev/null
+++ b/net-p2p/transmission-remote-cli/transmission-remote-cli-1.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission-remote-cli/transmission-remote-cli-1.5.0.ebuild,v 1.1 2013/03/23 08:31:10 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_REQ_USE="ncurses"
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/fagga/transmission-remote-cli/"
+SRC_URI="https://github.com/fagga/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geoip rdns"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep dev-python/simplejson[$(python_gen_usedep python2_5)] python2_5)
+ geoip? ( dev-python/geoip-python )
+ rdns? ( dev-python/adns-python[$PYTHON_USEDEP] )"
+
+src_install() {
+ python_foreach_impl python_doscript transmission-remote-cli
+ newbashcomp transmission-remote-cli-bash-completion.sh \
+ transmission-remote-cli
+ doman transmission-remote-cli.1
+ dodoc NEWS README.md
+}