summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-08 14:31:42 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-08 14:31:42 +0000
commitcefa8155d39ceb481d4f41257be014f76797af23 (patch)
treea2644536016ffc466543b0de253d56c181b165d9 /net-p2p/rtorrent
parentLinux patch 3.10.76. Linuxpatch 3.10.77 (diff)
downloadgentoo-2-cefa8155d39ceb481d4f41257be014f76797af23.tar.gz
gentoo-2-cefa8155d39ceb481d4f41257be014f76797af23.tar.bz2
gentoo-2-cefa8155d39ceb481d4f41257be014f76797af23.zip
Add fix for ncurses[tinfo], bug #522706
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog6
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.9.4-tinfo.patch35
-rw-r--r--net-p2p/rtorrent/metadata.xml13
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild12
4 files changed, 54 insertions, 12 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 75c3fff0828f..5e20bba06c52 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.196 2015/04/07 14:31:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.197 2015/05/08 14:31:42 jlec Exp $
+
+ 08 May 2015; Justin Lecher <jlec@gentoo.org>
+ +files/rtorrent-0.9.4-tinfo.patch, metadata.xml, rtorrent-0.9.4-r1.ebuild:
+ Add fix for ncurses[tinfo], bug #522706
11 Mar 2015; Manuel Rüger <mrueg@gentoo.org> rtorrent-0.9.3.ebuild:
Fix unquoted variable.
diff --git a/net-p2p/rtorrent/files/rtorrent-0.9.4-tinfo.patch b/net-p2p/rtorrent/files/rtorrent-0.9.4-tinfo.patch
new file mode 100644
index 000000000000..19e8d04a18c2
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.9.4-tinfo.patch
@@ -0,0 +1,35 @@
+ configure.ac | 18 ++++++++++++------
+ 1 file changed, 12 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 430c15d..50ce687 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -31,15 +31,21 @@ TORRENT_WITHOUT_STATVFS()
+ TORRENT_WITHOUT_STATFS()
+
+ AX_PTHREAD([], AC_MSG_ERROR([requires pthread]))
+-AX_WITH_CURSES()
+-
+-if test "x$ax_cv_ncursesw" != xyes && test "x$ax_cv_ncurses" != xyes; then
+- AC_MSG_ERROR([requires either NcursesW or Ncurses library])
+-fi
++PKG_CHECK_MODULES([CURSES],[ncursesw],[
++ AC_DEFINE(HAVE_NCURSESW_CURSES_H, 1)
++ ],
++ [PKG_CHECK_MODULES([CURSES],[ncurses],[
++ AC_DEFINE(HAVE_NCURSES_H, 1)
++ ],
++ [AX_WITH_CURSES()
++ if test "x$ax_cv_ncursesw" != xyes && test "x$ax_cv_ncurses" != xyes; then
++ AC_MSG_ERROR([requires either NcursesW or Ncurses library])
++ fi])
++ ])
+
+ CFLAGS="$CFLAGS $PTHREAD_CFLAGS $CURSES_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $PTHREAD_CFLAGS $CURSES_CFLAGS"
+-LIBS="$PTHREAD_LIBS $CURSES_LIB $LIBS"
++LIBS="$PTHREAD_LIBS $CURSES_LIB $CURSES_LIBS $LIBS"
+
+ PKG_CHECK_MODULES([libcurl], libcurl >= 7.15.4,
+ CXXFLAGS="$CXXFLAGS $libcurl_CFLAGS";
diff --git a/net-p2p/rtorrent/metadata.xml b/net-p2p/rtorrent/metadata.xml
index dd9423df796b..678efcd7885e 100644
--- a/net-p2p/rtorrent/metadata.xml
+++ b/net-p2p/rtorrent/metadata.xml
@@ -1,15 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-p2p</herd>
-<longdescription lang="en">
+ <herd>net-p2p</herd>
+ <longdescription lang="en">
Console BitTorrent client using ncurses based on libtorrent written in C++.
</longdescription>
-<use>
- <flag name='daemon'>Uses <pkg>app-misc/screen</pkg> to daemonize this
+ <use>
+ <flag name="daemon">Uses <pkg>app-misc/screen</pkg> to daemonize this
application
</flag>
- <flag name='color'>Add custom color support for torrent list</flag>
-</use>
-
+ <flag name="color">Add custom color support for torrent list</flag>
+ </use>
</pkgmetadata>
diff --git a/net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild b/net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild
index 696e58b9c968..ede17bab3fb0 100644
--- a/net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild,v 1.2 2014/11/02 09:28:15 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.9.4-r1.ebuild,v 1.3 2015/05/08 14:31:42 jlec Exp $
EAPI=5
-inherit eutils systemd
+inherit autotools eutils systemd
DESCRIPTION="BitTorrent Client using libtorrent"
HOMEPAGE="http://libtorrent.rakshasa.no/"
@@ -32,10 +32,14 @@ DOCS=( doc/rtorrent.rc )
src_prepare() {
# bug #358271
- epatch "${FILESDIR}"/${PN}-0.9.1-ncurses.patch
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.1-ncurses.patch \
+ "${FILESDIR}"/${P}-tinfo.patch
# upstream forgot to include
cp "${FILESDIR}"/rtorrent.1 "${S}"/doc/ || die
+
+ eautoreconf
}
src_configure() {