summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-20 23:20:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-20 23:20:12 +0000
commitb6b16fb1802921bd02b3509cfbc6c8b9d87c852e (patch)
treef43ba1ca4b66849ee2531981501a02ae76084207 /net-p2p/rtorrent
parent1.44 version bump for bug 115967. (diff)
downloadgentoo-2-b6b16fb1802921bd02b3509cfbc6c8b9d87c852e.tar.gz
gentoo-2-b6b16fb1802921bd02b3509cfbc6c8b9d87c852e.tar.bz2
gentoo-2-b6b16fb1802921bd02b3509cfbc6c8b9d87c852e.zip
Bump to latest version.
(Portage version: 2.1_pre1)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/Manifest12
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.4.11
-rw-r--r--net-p2p/rtorrent/rtorrent-0.4.1.ebuild40
4 files changed, 49 insertions, 11 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 53fc9977c1b1..8e71ef29b5a3 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.26 2005/11/29 21:07:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.27 2005/12/20 23:20:11 flameeyes Exp $
+
+*rtorrent-0.4.1 (20 Dec 2005)
+
+ 20 Dec 2005; Diego Pettenò <flameeyes@gentoo.org> +rtorrent-0.4.1.ebuild:
+ Bump to latest version.
29 Nov 2005; Diego Pettenò <flameeyes@gentoo.org> -rtorrent-0.3.0.ebuild:
Remove old version.
diff --git a/net-p2p/rtorrent/Manifest b/net-p2p/rtorrent/Manifest
index ff7f9b1bd459..779aa85ef5f3 100644
--- a/net-p2p/rtorrent/Manifest
+++ b/net-p2p/rtorrent/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 bcd5c5e6ce5fdea66da18fa71d0f9fbf ChangeLog 4209
MD5 bbb25789b80690a06bae3aeb2f18b16f files/digest-rtorrent-0.3.6 66
MD5 68495c48ac3f70023ce4894e94c112ff files/digest-rtorrent-0.4.0 66
+MD5 a66428f7c22e95e3ae63cbaad1c76046 files/digest-rtorrent-0.4.1 66
MD5 dc4336d6e768b550ef6da8f6c965d234 metadata.xml 374
MD5 74347323b69e29ee8f3ffaadc7758969 rtorrent-0.3.6.ebuild 1106
MD5 1b9545166b163b35b5e2fc57d6478bf8 rtorrent-0.4.0.ebuild 1115
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDjMMpAiZjviIA2XgRAnRZAKCJoVWwUrPAQ+SLEdEMSnp9FSj47ACdGOzL
-XwtIs18iyoE9ENIkgFuOWw8=
-=HeDD
------END PGP SIGNATURE-----
+MD5 1b9545166b163b35b5e2fc57d6478bf8 rtorrent-0.4.1.ebuild 1115
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.4.1 b/net-p2p/rtorrent/files/digest-rtorrent-0.4.1
new file mode 100644
index 000000000000..0c3f9bcf1cf9
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.4.1
@@ -0,0 +1 @@
+MD5 89826c88d2c2089729cfdf025f0c2026 rtorrent-0.4.1.tar.gz 228821
diff --git a/net-p2p/rtorrent/rtorrent-0.4.1.ebuild b/net-p2p/rtorrent/rtorrent-0.4.1.ebuild
new file mode 100644
index 000000000000..b976b09ef16d
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.4.1.ebuild,v 1.1 2005/12/20 23:20:11 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+DEPEND=">=net-libs/libtorrent-0.8.0
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}