summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-10 17:56:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-10 17:56:41 +0000
commit4f44167b7bf03da72d104429a0581876a32a3ec0 (patch)
tree6978c5436ed30359c7b268533f1216fbcacd9234 /net-p2p/rtorrent
parentBump to 0.12.5, fixes half of #278660. Thanks to Shark for testing. (diff)
downloadgentoo-2-4f44167b7bf03da72d104429a0581876a32a3ec0.tar.gz
gentoo-2-4f44167b7bf03da72d104429a0581876a32a3ec0.tar.bz2
gentoo-2-4f44167b7bf03da72d104429a0581876a32a3ec0.zip
Bump to 0.8.5, fixes other half of #278660. Thanks to Shark for testing.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.5.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 84dab399b6ee..179f847600a9 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.138 2009/07/28 21:52:33 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.139 2009/09/10 17:56:41 patrick Exp $
+
+*rtorrent-0.8.5 (10 Sep 2009)
+
+ 10 Sep 2009; Patrick Lauer <patrick@gentoo.org> +rtorrent-0.8.5.ebuild:
+ Bump to 0.8.5, fixes other half of #278660. Thanks to Shark for testing.
28 Jul 2009; Robin H. Johnson <robbat2@gentoo.org> files/rtorrentd.init:
Bug #262046: If used with a non-local NSS source, we need to start after
diff --git a/net-p2p/rtorrent/rtorrent-0.8.5.ebuild b/net-p2p/rtorrent/rtorrent-0.8.5.ebuild
new file mode 100644
index 000000000000..a431990475b1
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.8.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.5.ebuild,v 1.1 2009/09/10 17:56:41 patrick Exp $
+
+inherit base eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="daemon debug ipv6 xmlrpc"
+
+COMMON_DEPEND=">=net-libs/libtorrent-0.12.${PV##*.}
+ >=dev-libs/libsigc++-2.2.2
+ >=net-misc/curl-7.19.1
+ sys-libs/ncurses
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+RDEPEND="${COMMON_DEPEND}
+ daemon? ( app-misc/screen )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ replace-flags -Os -O2
+ append-flags -fno-strict-aliasing
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ econf $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with xmlrpc xmlrpc-c) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+
+ if use daemon; then
+ newinitd "${FILESDIR}/rtorrentd.init" rtorrentd || die "newinitd failed"
+ newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd || die "newconfd failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "rtorrent now supports a configuration file."
+ elog "A sample configuration file for rtorrent can be found"
+ elog "in rtorrent.rc in ${ROOT}usr/share/doc/${PF}/"
+ elog ""
+ ewarn "If you're upgrading from rtorrent <0.8.0, you will have to delete your"
+ ewarn "session directory or run the fixSession080-c.py script from this address:"
+ ewarn "http://rssdler.googlecode.com/files/fixSession080-c.py"
+ ewarn "See http://libtorrent.rakshasa.no/wiki/LibTorrentKnownIssues for more info."
+}