summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2012-04-08 18:21:45 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2012-04-08 18:21:45 +0000
commit359328b9c05ba7b612366fab22421dbfd3e722fc (patch)
tree1ec4036fef73fb36ff87099f5f8e8a003c28a93b /net-p2p/rtorrent
parentVersion bump (#411041) (diff)
downloadgentoo-2-359328b9c05ba7b612366fab22421dbfd3e722fc.tar.gz
gentoo-2-359328b9c05ba7b612366fab22421dbfd3e722fc.tar.bz2
gentoo-2-359328b9c05ba7b612366fab22421dbfd3e722fc.zip
Version bump (#411041), drop upstreamed patches and support for color. Too
much work to keep working and delays updates. (Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog11
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.9.0-canvas-fix.patch281
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.9.0-clang.patch136
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.9.0-gold.patch32
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.9.1-ncurses.patch10
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.1.ebuild (renamed from net-p2p/rtorrent/rtorrent-0.9.0.ebuild)18
6 files changed, 22 insertions, 466 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 1c5144ca18d4..e6f92c42d9de 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.173 2012/03/09 00:15:08 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.174 2012/04/08 18:21:45 sochotnicky Exp $
+
+*rtorrent-0.9.1 (08 Apr 2012)
+
+ 08 Apr 2012; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ -rtorrent-0.9.0.ebuild, -files/rtorrent-0.9.0-canvas-fix.patch,
+ -files/rtorrent-0.9.0-clang.patch, -files/rtorrent-0.9.0-gold.patch,
+ +rtorrent-0.9.1.ebuild, +files/rtorrent-0.9.1-ncurses.patch:
+ Version bump (#411041), drop upstreamed patches and support for color. Too
+ much work to keep working and delays updates.
09 Mar 2012; Stanislav Ochotnicky <sochotnicky@gentoo.org>
rtorrent-0.9.0.ebuild, +files/rtorrent-0.9.0-clang.patch:
diff --git a/net-p2p/rtorrent/files/rtorrent-0.9.0-canvas-fix.patch b/net-p2p/rtorrent/files/rtorrent-0.9.0-canvas-fix.patch
deleted file mode 100644
index 073bacce3dda..000000000000
--- a/net-p2p/rtorrent/files/rtorrent-0.9.0-canvas-fix.patch
+++ /dev/null
@@ -1,281 +0,0 @@
-Index: rtorrent/src/display/window_download_list.h
-===================================================================
---- rtorrent/src/display/window_download_list.h (revision 1163)
-+++ rtorrent/src/display/window_download_list.h (working copy)
-@@ -59,6 +59,10 @@
- virtual void redraw();
-
- void set_view(core::View* l);
-+ void set_done_fg_color(int64_t color);
-+ void set_done_bg_color(int64_t color);
-+ void set_active_fg_color(int64_t color);
-+ void set_active_bg_color(int64_t color);
-
- private:
- core::View* m_view;
-Index: rtorrent/src/display/canvas.cc
-===================================================================
---- rtorrent/src/display/canvas.cc (revision 1163)
-+++ rtorrent/src/display/canvas.cc (working copy)
-@@ -92,6 +92,10 @@
- m_isInitialized = true;
-
- initscr();
-+ start_color();
-+ use_default_colors();
-+ init_pair(2, -1, -1);
-+ init_pair(1, -1, -1);
- raw();
- noecho();
- nodelay(stdscr, TRUE);
-Index: rtorrent/src/display/window_download_list.cc
-===================================================================
---- rtorrent/src/display/window_download_list.cc (revision 1163)
-+++ rtorrent/src/display/window_download_list.cc (working copy)
-@@ -37,6 +37,7 @@
- #include "config.h"
-
- #include <rak/algorithm.h>
-+#include <torrent/rate.h>
-
- #include "core/download.h"
- #include "core/view.h"
-@@ -96,12 +97,30 @@
- char* position;
- char* last = buffer + m_canvas->width() - 2 + 1;
-
-+ if( pos >= m_canvas->height() ) break;
- position = print_download_title(buffer, last, *range.first);
-- m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
-+ m_canvas->print(0, pos, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
-+ if( (*range.first)->is_done() ) {
-+ if( (*range.first)->info()->up_rate()->rate() != 0 ) {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_BOLD, 2);
-+ } else {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 2);
-+ }
-+ } else if( (*range.first)->info()->is_active() ) {
-+ if( (*range.first)->info()->down_rate()->rate() != 0 ) {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_BOLD, 1);
-+ } else {
-+ m_canvas->set_attr(0, pos, m_canvas->width()-1, A_NORMAL, 1);
-+ }
-+ }
-+ pos++;
-+
-+ if( pos >= m_canvas->height() ) break;
-
- position = print_download_info(buffer, last, *range.first);
- m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
-
-+ if( pos >= m_canvas->height() ) break;
- position = print_download_status(buffer, last, *range.first);
- m_canvas->print(0, pos++, "%c %s", range.first == m_view->focus() ? '*' : ' ', buffer);
-
-@@ -109,4 +128,41 @@
- }
- }
-
-+void
-+WindowDownloadList::set_done_fg_color(int64_t color) {
-+ short fg, bg;
-+ pair_content(2, &fg, &bg);
-+ if( color < 0 ) color = -1;
-+ color = color % 8;
-+ init_pair(2, (short)color, bg);
- }
-+
-+void
-+WindowDownloadList::set_done_bg_color(int64_t color) {
-+ short fg, bg;
-+ pair_content(2, &fg, &bg);
-+ if( color < 0 ) color = -1;
-+ color = color % 8;
-+ init_pair(2, fg, (short)color);
-+}
-+
-+void
-+WindowDownloadList::set_active_fg_color(int64_t color) {
-+ short fg, bg;
-+ pair_content(1, &fg, &bg);
-+ if( color < 0 ) color = -1;
-+ color = color % 8;
-+ init_pair(1, (short)color, bg);
-+}
-+
-+void
-+WindowDownloadList::set_active_bg_color(int64_t color) {
-+ short fg, bg;
-+ pair_content(1, &fg, &bg);
-+ if( color < 0 ) color = -1;
-+ color = color % 8;
-+ init_pair(1, fg, (short)color);
-+}
-+
-+}
-+
-Index: rtorrent/src/ui/download_list.cc
-===================================================================
---- rtorrent/src/ui/download_list.cc (revision 1163)
-+++ rtorrent/src/ui/download_list.cc (working copy)
-@@ -137,6 +137,11 @@
- current_view()->next_focus();
- }
-
-+display::WindowDownloadList*
-+DownloadList::current_window_list() {
-+ return dynamic_cast<ElementDownloadList*>(m_uiArray[DISPLAY_DOWNLOAD_LIST])->window();
-+}
-+
- void
- DownloadList::activate_display(Display displayType) {
- if (!is_active())
-Index: rtorrent/src/ui/download_list.h
-===================================================================
---- rtorrent/src/ui/download_list.h (revision 1163)
-+++ rtorrent/src/ui/download_list.h (working copy)
-@@ -101,6 +101,7 @@
- void activate_display(Display d);
-
- core::View* current_view();
-+ display::WindowDownloadList* current_window_list();
- void set_current_view(const std::string& name);
-
- void slot_open_uri(SlotOpenUri s) { m_slotOpenUri = s; }
-Index: rtorrent/src/ui/element_download_list.h
-===================================================================
---- rtorrent/src/ui/element_download_list.h (revision 1163)
-+++ rtorrent/src/ui/element_download_list.h (working copy)
-@@ -60,6 +60,7 @@
- void disable();
-
- core::View* view() { return m_view; }
-+ WDownloadList* window() { return m_window; }
- void set_view(core::View* l);
-
- void receive_command(const char* cmd);
-Index: rtorrent/src/ui/root.cc
-===================================================================
---- rtorrent/src/ui/root.cc (revision 1163)
-+++ rtorrent/src/ui/root.cc (working copy)
-@@ -44,6 +44,7 @@
-
- #include "core/manager.h"
- #include "display/frame.h"
-+#include "display/window_download_list.h"
- #include "display/window_http_queue.h"
- #include "display/window_title.h"
- #include "display/window_input.h"
-@@ -65,7 +66,11 @@
- m_windowTitle(NULL),
- m_windowHttpQueue(NULL),
- m_windowInput(NULL),
-- m_windowStatusbar(NULL) {
-+ m_windowStatusbar(NULL),
-+ done_fg_color(-1),
-+ done_bg_color(-1),
-+ active_fg_color(-1),
-+ active_bg_color(-1) {
- }
-
- void
-@@ -97,6 +102,10 @@
- setup_keys();
-
- m_downloadList->activate(rootFrame->frame(1));
-+ m_downloadList->current_window_list()->set_done_fg_color(done_fg_color);
-+ m_downloadList->current_window_list()->set_done_bg_color(done_bg_color);
-+ m_downloadList->current_window_list()->set_active_fg_color(active_fg_color);
-+ m_downloadList->current_window_list()->set_active_bg_color(active_bg_color);
- }
-
- void
-@@ -219,7 +228,47 @@
- torrent::set_max_unchoked(maxUnchoked);
- }
-
-+int
-+Root::get_done_fg_color() {
-+ return done_fg_color;
-+}
-+
- void
-+Root::set_done_fg_color(int64_t color) {
-+ done_fg_color = color;
-+}
-+
-+int
-+Root::get_done_bg_color() {
-+ return done_bg_color;
-+}
-+
-+void
-+Root::set_done_bg_color(int64_t color) {
-+ done_bg_color = color;
-+}
-+
-+int
-+Root::get_active_fg_color() {
-+ return active_fg_color;
-+}
-+
-+void
-+Root::set_active_fg_color(int64_t color) {
-+ active_fg_color = color;
-+}
-+
-+int
-+Root::get_active_bg_color() {
-+ return active_bg_color;
-+}
-+
-+void
-+Root::set_active_bg_color(int64_t color) {
-+ active_bg_color = color;
-+}
-+
-+void
- Root::adjust_down_throttle(int throttle) {
- set_down_throttle(std::max<int>(torrent::down_throttle_global()->max_rate() / 1024 + throttle, 0));
- }
-Index: rtorrent/src/ui/root.h
-===================================================================
---- rtorrent/src/ui/root.h (revision 1163)
-+++ rtorrent/src/ui/root.h (working copy)
-@@ -82,7 +82,16 @@
- // Rename to raw or something, make base function.
- void set_down_throttle_i64(int64_t throttle) { set_down_throttle(throttle >> 10); }
- void set_up_throttle_i64(int64_t throttle) { set_up_throttle(throttle >> 10); }
-+ int get_done_fg_color();
-+ void set_done_fg_color(int64_t color);
-+ int get_done_bg_color();
-+ void set_done_bg_color(int64_t color);
-+ int get_active_fg_color();
-+ void set_active_fg_color(int64_t color);
-+ int get_active_bg_color();
-+ void set_active_bg_color(int64_t color);
-
-+
- void adjust_down_throttle(int throttle);
- void adjust_up_throttle(int throttle);
-
-@@ -93,6 +102,11 @@
-
- input::TextInput* current_input();
-
-+ int64_t done_fg_color;
-+ int64_t done_bg_color;
-+ int64_t active_fg_color;
-+ int64_t active_bg_color;
-+
- private:
- void setup_keys();
-
-@@ -105,6 +119,7 @@
- WStatusbar* m_windowStatusbar;
-
- input::Bindings m_bindings;
-+
- };
-
- }
diff --git a/net-p2p/rtorrent/files/rtorrent-0.9.0-clang.patch b/net-p2p/rtorrent/files/rtorrent-0.9.0-clang.patch
deleted file mode 100644
index e3bed62ea03b..000000000000
--- a/net-p2p/rtorrent/files/rtorrent-0.9.0-clang.patch
+++ /dev/null
@@ -1,136 +0,0 @@
-From e58f3975f128f68638843a11b40a239350bf88f4 Mon Sep 17 00:00:00 2001
-From: Jari Sundell <sundell.software@gmail.com>
-Date: Thu, 29 Dec 2011 18:58:12 +0900
-Subject: [PATCH] Fixed compiler issues with clang.
-
----
- src/command_download.cc | 9 ++++-----
- src/command_dynamic.cc | 6 +++---
- src/command_helpers.h | 11 +++++++++--
- src/display/window_file_list.cc | 2 +-
- src/thread_base.h | 4 +---
- 5 files changed, 18 insertions(+), 14 deletions(-)
-
-diff --git a/src/command_download.cc b/src/command_download.cc
-index 30abb4d..bc58b9a 100644
---- a/src/command_download.cc
-+++ b/src/command_download.cc
-@@ -138,10 +138,9 @@ apply_d_change_link(core::Download* download, const torrent::Object::list_type&
-
- switch (changeType) {
- case 0:
-- if (symlink(target.c_str(), link.c_str()) == -1)
-+ // if (symlink(target.c_str(), link.c_str()) == -1)
- // control->core()->push_log("create_link failed: " + std::string(rak::error_number::current().c_str()));
- // control->core()->push_log("create_link failed: " + std::string(rak::error_number::current().c_str()) + " to " + target);
-- ; // Disabled.
- break;
-
- case 1:
-@@ -150,9 +149,9 @@ apply_d_change_link(core::Download* download, const torrent::Object::list_type&
- rak::error_number::clear_global();
-
- if (!fileStat.update_link(link) || !fileStat.is_link() ||
-- unlink(link.c_str()) == -1)
-- ; // control->core()->push_log("delete_link failed: " + std::string(rak::error_number::current().c_str()));
--
-+ unlink(link.c_str()) == -1) {
-+ // control->core()->push_log("delete_link failed: " + std::string(rak::error_number::current().c_str()));
-+ }
- break;
- }
- default:
-diff --git a/src/command_dynamic.cc b/src/command_dynamic.cc
-index 6e83454..013f855 100644
---- a/src/command_dynamic.cc
-+++ b/src/command_dynamic.cc
-@@ -156,7 +156,7 @@ system_method_insert_object(const torrent::Object::list_type& args, int flags) {
- (flags & rpc::object_storage::mask_type) == rpc::object_storage::flag_multi_type) {
-
- rpc::commands.insert_slot<rpc::command_base_is_type<rpc::command_base_call<rpc::target_type> >::type>
-- (create_new_key<0>(rawKey, ""),
-+ (create_new_key(rawKey),
- std::bind(&rpc::object_storage::call_function_str, control->object_storage(),
- rawKey, std::placeholders::_1, std::placeholders::_2),
- &rpc::command_base_call<rpc::target_type>,
-@@ -164,7 +164,7 @@ system_method_insert_object(const torrent::Object::list_type& args, int flags) {
-
- } else {
- rpc::commands.insert_slot<rpc::command_base_is_type<rpc::command_base_call<rpc::target_type> >::type>
-- (create_new_key<0>(rawKey, ""),
-+ (create_new_key(rawKey),
- std::bind(&rpc::object_storage::get_str, control->object_storage(), rawKey),
- &rpc::command_base_call<rpc::target_type>,
- cmd_flags, NULL, NULL);
-@@ -354,7 +354,7 @@ system_method_redirect(const torrent::Object::list_type& args) {
- std::string new_key = torrent::object_create_string(args.front());
- std::string dest_key = torrent::object_create_string(args.back());
-
-- rpc::commands.create_redirect(create_new_key<0>(new_key, ""), create_new_key<0>(dest_key, ""),
-+ rpc::commands.create_redirect(create_new_key(new_key), create_new_key(dest_key),
- rpc::CommandMap::flag_public_xmlrpc | rpc::CommandMap::flag_delete_key | rpc::CommandMap::flag_modifiable);
-
- return torrent::Object();
-diff --git a/src/command_helpers.h b/src/command_helpers.h
-index 8b290ce..b215ec2 100644
---- a/src/command_helpers.h
-+++ b/src/command_helpers.h
-@@ -152,11 +152,11 @@ void initialize_commands();
- rpc::commands.create_redirect(from_key, to_key, rpc::CommandMap::flag_public_xmlrpc | rpc::CommandMap::flag_tracker_target | rpc::CommandMap::flag_dont_delete);
-
- #define CMD2_REDIRECT_GENERIC_STR(from_key, to_key) \
-- rpc::commands.create_redirect(create_new_key<0>(from_key, ""), create_new_key<0>(to_key, ""), \
-+ rpc::commands.create_redirect(create_new_key(from_key), create_new_key(to_key), \
- rpc::CommandMap::flag_public_xmlrpc | rpc::CommandMap::flag_no_target | rpc::CommandMap::flag_delete_key);
-
- #define CMD2_REDIRECT_GENERIC_STR_NO_EXPORT(from_key, to_key) \
-- rpc::commands.create_redirect(create_new_key<0>(from_key, ""), create_new_key<0>(to_key, ""), \
-+ rpc::commands.create_redirect(create_new_key(from_key), create_new_key(to_key), \
- rpc::CommandMap::flag_no_target | rpc::CommandMap::flag_delete_key);
-
- //
-@@ -205,4 +205,11 @@ create_new_key(const std::string& key, const char postfix[postfix_size]) {
- return buffer;
- }
-
-+inline const char*
-+create_new_key(const std::string& key) {
-+ char *buffer = new char[key.size() + 1];
-+ std::memcpy(buffer, key.c_str(), key.size() + 1);
-+ return buffer;
-+}
-+
- #endif
-diff --git a/src/display/window_file_list.cc b/src/display/window_file_list.cc
-index 6a923dc..7c9f692 100644
---- a/src/display/window_file_list.cc
-+++ b/src/display/window_file_list.cc
-@@ -123,7 +123,7 @@ WindowFileList::redraw() {
- if (fl->size_files() == 0 || m_canvas->height() < 2)
- return;
-
-- iterator entries[m_canvas->height() - 1];
-+ std::vector<iterator> entries(m_canvas->height() - 1);
-
- unsigned int last = 0;
-
-diff --git a/src/thread_base.h b/src/thread_base.h
-index 4cd38de..479e3cd 100644
---- a/src/thread_base.h
-+++ b/src/thread_base.h
-@@ -44,11 +44,9 @@
- #include "rak/priority_queue_default.h"
- #include "core/poll_manager.h"
-
--struct thread_queue_hack;
--
- // Move this class to libtorrent.
-
--struct thread_queue_hack;
-+class thread_queue_hack;
-
- class ThreadBase : public torrent::thread_base {
- public:
---
-1.7.3.4
-
diff --git a/net-p2p/rtorrent/files/rtorrent-0.9.0-gold.patch b/net-p2p/rtorrent/files/rtorrent-0.9.0-gold.patch
deleted file mode 100644
index aeec1941519f..000000000000
--- a/net-p2p/rtorrent/files/rtorrent-0.9.0-gold.patch
+++ /dev/null
@@ -1,32 +0,0 @@
- src/Makefile.am | 3 ++-
- src/Makefile.in | 3 ++-
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 33ab889..ee9340e 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -48,7 +48,8 @@ rtorrent_LDADD = \
- display/libsub_display.a \
- input/libsub_input.a \
- rpc/libsub_rpc.a \
-- utils/libsub_utils.a
-+ utils/libsub_utils.a \
-+ @PTHREAD_LIBS@
-
- rtorrent_SOURCES = \
- main.cc
-diff --git a/src/Makefile.in b/src/Makefile.in
-index 0eecb06..cf52bf5 100644
---- a/src/Makefile.in
-+++ b/src/Makefile.in
-@@ -324,7 +324,8 @@ rtorrent_LDADD = \
- display/libsub_display.a \
- input/libsub_input.a \
- rpc/libsub_rpc.a \
-- utils/libsub_utils.a
-+ utils/libsub_utils.a \
-+ @PTHREAD_LIBS@
-
- rtorrent_SOURCES = \
- main.cc
diff --git a/net-p2p/rtorrent/files/rtorrent-0.9.1-ncurses.patch b/net-p2p/rtorrent/files/rtorrent-0.9.1-ncurses.patch
new file mode 100644
index 000000000000..260cd9a38425
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.9.1-ncurses.patch
@@ -0,0 +1,10 @@
+--- src/display/canvas.h
++++ src/display/canvas.h
+@@ -48,5 +48,5 @@ class Canvas {
+ public:
+ typedef std::vector<Attributes> attributes_list;
+
+- Canvas(int x = 0, int y = 0, int width = 0, int height = 0);
++ Canvas(int x = 0, int y = 0, int width = 1, int height = 1);
+ ~Canvas() { delwin(m_window); }
+ void refresh() { wnoutrefresh(m_window); }
diff --git a/net-p2p/rtorrent/rtorrent-0.9.0.ebuild b/net-p2p/rtorrent/rtorrent-0.9.1.ebuild
index 97bab101dbcd..68367332ec56 100644
--- a/net-p2p/rtorrent/rtorrent-0.9.0.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.9.0.ebuild,v 1.4 2012/03/09 00:15:08 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.9.1.ebuild,v 1.1 2012/04/08 18:21:45 sochotnicky Exp $
EAPI=2
@@ -13,7 +13,7 @@ SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="color daemon debug ipv6 test xmlrpc"
+IUSE="daemon debug ipv6 test xmlrpc"
COMMON_DEPEND=">=net-libs/libtorrent-0.13.${PV##*.}
>=dev-libs/libsigc++-2.2.2:2
@@ -29,9 +29,6 @@ DEPEND="${COMMON_DEPEND}
src_prepare() {
# bug #358271
epatch "${FILESDIR}"/${P}-ncurses.patch
- epatch "${FILESDIR}"/${P}-gold.patch
- epatch "${FILESDIR}"/${P}-clang.patch
- use color && EPATCH_OPTS="-p1" epatch "${FILESDIR}"/${P}-canvas-fix.patch
}
src_configure() {
@@ -51,14 +48,3 @@ src_install() {
newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd || die "newconfd failed"
fi
}
-
-pkg_postinst() {
- if use color; then
- elog "rtorrent colors patch"
- elog "Set colors using the options below in .rtorrent.rc:"
- elog "Options: done_fg_color, done_bg_color, active_fg_color, active_bg_color"
- elog "Colors: 0 = black, 1 = red, 2 = green, 3 = yellow, 4 = blue,"
- elog "5 = magenta, 6 = cyan and 7 = white"
- elog "Example: done_fg_color = 1"
- fi
-}