summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-01-23 19:21:53 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-01-23 19:21:53 +0000
commitfc9b7d758f02f53d167fccf08c3a779d7d57c138 (patch)
treeac9dc5393cc6cc8ef7b730dd55b9ad814793cc56 /net-p2p/qbittorrent
parentVersion bump. (diff)
downloadgentoo-2-fc9b7d758f02f53d167fccf08c3a779d7d57c138.tar.gz
gentoo-2-fc9b7d758f02f53d167fccf08c3a779d7d57c138.tar.bz2
gentoo-2-fc9b7d758f02f53d167fccf08c3a779d7d57c138.zip
Version bump
(Portage version: 2.1.11.47/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog9
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.0.8.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index d6b7bf94e1ae..1ce27d4a42dc 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.204 2012/10/09 19:49:12 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.205 2013/01/23 19:21:53 hwoarang Exp $
+
+*qbittorrent-3.0.8 (23 Jan 2013)
+
+ 23 Jan 2013; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-3.0.8.ebuild:
+ Version bump
*qbittorrent-3.0.6 (09 Oct 2012)
diff --git a/net-p2p/qbittorrent/qbittorrent-3.0.8.ebuild b/net-p2p/qbittorrent/qbittorrent-3.0.8.ebuild
new file mode 100644
index 000000000000..819204a9e4b2
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.0.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.0.8.ebuild,v 1.1 2013/01/23 19:21:53 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus +X geoip"
+
+QT_MIN="4.6.1"
+# boost version so that we always have thread support
+CDEPEND=">=net-libs/rb_libtorrent-0.16.3
+ >=x11-libs/qt-core-${QT_MIN}:4
+ X? ( >=x11-libs/qt-gui-${QT_MIN}:4 )
+ dbus? ( >=x11-libs/qt-dbus-${QT_MIN}:4 )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}