summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-04-08 07:52:10 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-04-08 07:52:10 +0000
commit04874bf06fe2440e22fad631715ccd8370721037 (patch)
treeb23807d2d516480e8978c1804f51bfc9f594ccfb /net-p2p/qbittorrent
parentadd missing DEPEND on gnome-vfs (diff)
downloadgentoo-2-04874bf06fe2440e22fad631715ccd8370721037.tar.gz
gentoo-2-04874bf06fe2440e22fad631715ccd8370721037.tar.bz2
gentoo-2-04874bf06fe2440e22fad631715ccd8370721037.zip
Remove libnotify. Has been replaced with qt-dbus API. Bug #362423
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog6
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild17
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild17
3 files changed, 19 insertions, 21 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index f0d285f51ec2..17849c0019d6 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.146 2011/04/06 08:21:43 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.147 2011/04/08 07:52:10 hwoarang Exp $
+
+ 08 Apr 2011; Markos Chandras <hwoarang@gentoo.org> qbittorrent-2.7.2.ebuild,
+ qbittorrent-9999.ebuild:
+ Remove libnotify. Has been replaced with qt-dbus API. Bug #362423
*qbittorrent-2.7.2 (06 Apr 2011)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild b/net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild
index 76136a5307c7..51a0e41465d8 100644
--- a/net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild,v 1.1 2011/04/06 08:21:43 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild,v 1.2 2011/04/08 07:52:10 hwoarang Exp $
EAPI="2"
PYTHON_DEPEND="2"
-inherit python confutils qt4-r2 versionator
+inherit python qt4-r2 versionator
MY_P="${P/_/}"
DESCRIPTION="BitTorrent client in C++ and Qt"
@@ -15,28 +15,25 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+X geoip libnotify"
+IUSE="dbus +X geoip"
QT_MIN="4.7.1"
# boost version so that we always have thread support
CDEPEND="net-libs/rb_libtorrent
>=x11-libs/qt-core-${QT_MIN}:4
- >=x11-libs/qt-dbus-${QT_MIN}:4
- X? ( >=x11-libs/qt-gui-${QT_MIN}:4
- libnotify? ( >=x11-libs/qt-gui-${QT_MIN}:4[glib] ) )
+ X? ( >=x11-libs/qt-gui-${QT_MIN}:4 )
+ dbus? ( >=x11-libs/qt-dbus-${QT_MIN}:4 )
dev-libs/boost"
DEPEND="${CDEPEND}
dev-util/pkgconfig"
RDEPEND="${CDEPEND}
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
+ geoip? ( dev-libs/geoip )"
DOCS="AUTHORS Changelog NEWS README TODO"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- confutils_use_depend_all libnotify X
python_set_active_version 2
python_pkg_setup
}
@@ -51,7 +48,7 @@ src_configure() {
local myconf
use X || myconf+=" --disable-gui"
use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
+ use dbus || myconf+=" --disable-qt-dbus"
# slotted boost detection, bug #309415
BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 362959abf3e6..76da8522b2bb 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.2 2011/03/04 19:56:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.3 2011/04/08 07:52:10 hwoarang Exp $
EAPI="2"
PYTHON_DEPEND="2"
-inherit python confutils qt4-r2 versionator subversion
+inherit python qt4-r2 versionator subversion
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
@@ -15,26 +15,23 @@ SLOT="0"
ESVN_REPO_URI="https://qbittorrent.svn.sourceforge.net/svnroot/qbittorrent/trunk"
KEYWORDS=""
-IUSE="+X geoip libnotify"
+IUSE="dbus +X geoip"
QT_MIN="4.7.1"
# boost version so that we always have thread support
CDEPEND="net-libs/rb_libtorrent
>=x11-libs/qt-core-${QT_MIN}:4
- >=x11-libs/qt-dbus-${QT_MIN}:4
- X? ( >=x11-libs/qt-gui-${QT_MIN}:4
- libnotify? ( >=x11-libs/qt-gui-${QT_MIN}:4[glib] ) )
+ X? ( >=x11-libs/qt-gui-${QT_MIN}:4 )
+ dbus? ( >=x11-libs/qt-dbus-${QT_MIN}:4 )
dev-libs/boost"
DEPEND="${CDEPEND}
dev-util/pkgconfig"
RDEPEND="${CDEPEND}
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
+ geoip? ( dev-libs/geoip )"
DOCS="AUTHORS Changelog NEWS README TODO"
pkg_setup() {
- confutils_use_depend_all libnotify X
python_set_active_version 2
python_pkg_setup
}
@@ -49,7 +46,7 @@ src_configure() {
local myconf
use X || myconf+=" --disable-gui"
use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
+ use dbus || myconf+=" --disable-qt-dbus"
# slotted boost detection, bug #309415
BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"