summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-04-12 10:43:08 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-04-12 10:43:08 +0000
commit7cdbd5bbd586df6977fa7650d9341baad669233c (patch)
tree07071f0cd73f23e3d99b9def292e2874dd6712d0 /net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-7cdbd5bbd586df6977fa7650d9341baad669233c.tar.gz
gentoo-2-7cdbd5bbd586df6977fa7650d9341baad669233c.tar.bz2
gentoo-2-7cdbd5bbd586df6977fa7650d9341baad669233c.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild b/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild
new file mode 100644
index 000000000000..722e3479da47
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.0.0.ebuild,v 1.1 2008/04/12 10:43:08 armin76 Exp $
+
+inherit eutils qt4 multilib
+
+MY_P="${P/_/}"
+
+DESCRIPTION="BitTorrent client in C++ and Qt."
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-libs/rb_libtorrent-0.13
+ $(qt4_min_version 4.2)
+ dev-libs/boost
+ net-misc/curl
+ dev-cpp/commoncpp2"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.3"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! has_version ">=dev-libs/boost-1.34_pre20061214" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_compile() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libtorrent-inc=/usr/include \
+ --with-libtorrent-lib=/usr/$(get_libdir) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}