summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-03-07 21:49:38 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-03-07 21:49:38 +0000
commite04e755c90a39966f52b39e5144127dc9ace8333 (patch)
tree0e1ed392b88a809f0fe7cb90e3492445dd4354cd /net-p2p/nicotine+
parentChange the FILESDIR checks to be DISTDIR, so nobody needs to keep a copy fo t... (diff)
downloadgentoo-2-e04e755c90a39966f52b39e5144127dc9ace8333.tar.gz
gentoo-2-e04e755c90a39966f52b39e5144127dc9ace8333.tar.bz2
gentoo-2-e04e755c90a39966f52b39e5144127dc9ace8333.zip
Version bump wrt bug 169821
(Portage version: 2.1.2.1-r1)
Diffstat (limited to 'net-p2p/nicotine+')
-rw-r--r--net-p2p/nicotine+/ChangeLog7
-rw-r--r--net-p2p/nicotine+/files/digest-nicotine+-1.2.7.13
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.7.1.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index a32b8a24ad00..1c47320db4fb 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.10 2007/02/26 15:55:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.11 2007/03/07 21:49:37 armin76 Exp $
+
+*nicotine+-1.2.7.1 (07 Mar 2007)
+
+ 07 Mar 2007; Raúl Porcel <armin76@gentoo.org> +nicotine+-1.2.7.1.ebuild:
+ Version bump wrt bug 169821
*nicotine+-1.2.7 (26 Feb 2007)
diff --git a/net-p2p/nicotine+/files/digest-nicotine+-1.2.7.1 b/net-p2p/nicotine+/files/digest-nicotine+-1.2.7.1
new file mode 100644
index 000000000000..343e64dc81b7
--- /dev/null
+++ b/net-p2p/nicotine+/files/digest-nicotine+-1.2.7.1
@@ -0,0 +1,3 @@
+MD5 42c4f1d4cea8e738dad59505a1eaeb9e nicotine+-1.2.7.1.tar.bz2 746571
+RMD160 70ad020d01ad1daa15626a1bb0956a6e7bdf3c8b nicotine+-1.2.7.1.tar.bz2 746571
+SHA256 2c128dc7b09d5b7b07146e18784120b64c14510b7abfb8d087fc78081cb9a4cf nicotine+-1.2.7.1.tar.bz2 746571
diff --git a/net-p2p/nicotine+/nicotine+-1.2.7.1.ebuild b/net-p2p/nicotine+/nicotine+-1.2.7.1.ebuild
new file mode 100644
index 000000000000..06ccbb1dd548
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.7.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.7.1.ebuild,v 1.1 2007/03/07 21:49:37 armin76 Exp $
+
+inherit distutils eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://www.nicotine-plus.org"
+SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="vorbis geoip"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2
+ vorbis? ( >=dev-python/pyvorbis-1.4-r1
+ >=dev-python/pyogg-1 )
+ geoip? ( >=dev-python/geoip-python-0.2.0
+ >=dev-libs/geoip-1.2.1 )
+ !net-p2p/nicotine"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+src_compile() {
+ distutils_src_compile
+
+ cd "${S}"/trayicon/
+ sed -i -e "s:/lib/:/$(get_libdir)/:" \
+ Makefile.in || die "sed failed"
+ ./autogen.py
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ distutils_python_version
+ distutils_src_install --install-lib \
+ /usr/$(get_libdir)/python${PYVER}/site-packages
+
+ cd "${S}"/trayicon/
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon ${FILESDIR}/nicotine-n.png
+ domenu ${FILESDIR}/${PN}.desktop
+}